OSDN Git Service

* include/Makefile.am (c_base_builddir): Remove redundant slash.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index baf3b0a..f3fef8d 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -21,8 +21,6 @@
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-## $Id: Makefile.am,v 1.4 2001/08/10 20:44:53 ljrittle Exp $
-
 AUTOMAKE_OPTIONS = 1.3 gnits
 MAINT_CHARSET = latin1
 
@@ -66,35 +64,6 @@ bits_headers = \
        ${bits_srcdir}/slice.h \
        ${bits_srcdir}/slice_array.h \
        ${bits_srcdir}/sstream.tcc \
-       ${bits_srcdir}/std_algorithm.h \
-       ${bits_srcdir}/std_bitset.h \
-       ${bits_srcdir}/std_complex.h \
-       ${bits_srcdir}/std_deque.h \
-       ${bits_srcdir}/std_fstream.h \
-       ${bits_srcdir}/std_functional.h \
-       ${bits_srcdir}/std_iomanip.h \
-       ${bits_srcdir}/std_ios.h \
-       ${bits_srcdir}/std_iosfwd.h \
-       ${bits_srcdir}/std_iostream.h \
-       ${bits_srcdir}/std_istream.h \
-       ${bits_srcdir}/std_iterator.h \
-       ${bits_srcdir}/std_limits.h \
-       ${bits_srcdir}/std_list.h \
-       ${bits_srcdir}/std_locale.h \
-       ${bits_srcdir}/std_map.h \
-       ${bits_srcdir}/std_memory.h \
-       ${bits_srcdir}/std_numeric.h \
-       ${bits_srcdir}/std_ostream.h \
-       ${bits_srcdir}/std_queue.h \
-       ${bits_srcdir}/std_set.h \
-       ${bits_srcdir}/std_sstream.h \
-       ${bits_srcdir}/std_stack.h \
-       ${bits_srcdir}/std_stdexcept.h \
-       ${bits_srcdir}/std_streambuf.h \
-       ${bits_srcdir}/std_string.h \
-       ${bits_srcdir}/std_utility.h \
-       ${bits_srcdir}/std_valarray.h \
-       ${bits_srcdir}/std_vector.h \
        ${bits_srcdir}/stl_algo.h \
        ${bits_srcdir}/stl_algobase.h \
        ${bits_srcdir}/stl_alloc.h \
@@ -174,23 +143,30 @@ backward_headers = \
 ext_srcdir = ${glibcpp_srcdir}/include/ext
 ext_builddir = ./ext
 ext_headers = \
+       ${ext_srcdir}/algorithm \
+       ${ext_srcdir}/functional \
+       ${ext_srcdir}/hash_map \
+       ${ext_srcdir}/hash_set \
+       ${ext_srcdir}/iterator \
+       ${ext_srcdir}/memory \
+       ${ext_srcdir}/numeric \
+       ${ext_srcdir}/rb_tree \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
-       ${ext_srcdir}/stl_rope.h \
        ${ext_srcdir}/slist \
-       ${ext_srcdir}/hash_map \
-       ${ext_srcdir}/hash_set \
+       ${ext_srcdir}/stl_hash_fun.h \
        ${ext_srcdir}/stl_hashtable.h \
-       ${ext_srcdir}/stl_hash_fun.h
+       ${ext_srcdir}/stl_rope.h
 
 # This is the common subset of files that all three "C" header models use.
-c_base_srcdir = @C_INCLUDE_DIR@/bits
-c_base_builddir = ./bits
+c_base_srcdir = @C_INCLUDE_DIR@
+c_base_builddir = .
 c_base_headers = \
        ${c_base_srcdir}/std_cassert.h \
        ${c_base_srcdir}/std_cctype.h \
        ${c_base_srcdir}/std_cerrno.h \
        ${c_base_srcdir}/std_cfloat.h \
+       ${c_base_srcdir}/std_ciso646.h \
        ${c_base_srcdir}/std_climits.h \
        ${c_base_srcdir}/std_clocale.h \
        ${c_base_srcdir}/std_cmath.h \
@@ -203,80 +179,93 @@ c_base_headers = \
        ${c_base_srcdir}/std_cstring.h \
        ${c_base_srcdir}/std_ctime.h \
        ${c_base_srcdir}/std_cwchar.h \
-       ${c_base_srcdir}/std_cwctype.h \
+       ${c_base_srcdir}/std_cwctype.h 
+# Some of the "C" headers need extra files.
+c_base_headers_extra = \
        ${c_base_srcdir}/cmath.tcc 
-
-##c_compatibility_srcdir = ${glibcpp_srcdir}/include/c_compatibility
-##c_compatibility_builddir = ./
-##c_compatibility_headers = \
-##     ${c_compatibility_srcdir}/assert.h \
-##     ${c_compatibility_srcdir}/ctype.h \
-##     ${c_compatibility_srcdir}/errno.h \
-##     ${c_compatibility_srcdir}/float.h \
-##     ${c_compatibility_srcdir}/limits.h \
-##     ${c_compatibility_srcdir}/locale.h \
-##     ${c_compatibility_srcdir}/math.h \
-##     ${c_compatibility_srcdir}/setjmp.h \
-##     ${c_compatibility_srcdir}/signal.h \
-##     ${c_compatibility_srcdir}/stdarg.h \
-##     ${c_compatibility_srcdir}/stddef.h \
-##     ${c_compatibility_srcdir}/stdio.h \
-##     ${c_compatibility_srcdir}/stdlib.h \
-##     ${c_compatibility_srcdir}/string.h \
-##     ${c_compatibility_srcdir}/time.h \
-##     ${c_compatibility_srcdir}/wchar.h \
-##     ${c_compatibility_srcdir}/wctype.h 
+c_base_headers_rename = \
+       cassert \
+       cctype \
+       cerrno \
+       cfloat \
+       ciso646 \
+       climits \
+       clocale \
+       cmath \
+       csetjmp \
+       csignal \
+       cstdarg \
+       cstddef \
+       cstdio \
+       cstdlib \
+       cstring \
+       ctime \
+       cwchar \
+       cwctype 
 
 std_srcdir = ${glibcpp_srcdir}/include/std
-std_builddir = ./
+std_builddir = .
 std_headers = \
-       ${std_srcdir}/algorithm \
-       ${std_srcdir}/bitset \
-       ${std_srcdir}/complex \
-       ${std_srcdir}/deque \
-       ${std_srcdir}/fstream \
-       ${std_srcdir}/functional \
-       ${std_srcdir}/iomanip \
-       ${std_srcdir}/ios \
-       ${std_srcdir}/iosfwd \
-       ${std_srcdir}/iostream \
-       ${std_srcdir}/istream \
-       ${std_srcdir}/iterator \
-       ${std_srcdir}/limits \
-       ${std_srcdir}/list \
-       ${std_srcdir}/locale \
-       ${std_srcdir}/map \
-       ${std_srcdir}/memory \
-       ${std_srcdir}/numeric \
-       ${std_srcdir}/ostream \
-       ${std_srcdir}/queue \
-       ${std_srcdir}/set \
-       ${std_srcdir}/sstream \
-       ${std_srcdir}/stack \
-       ${std_srcdir}/stdexcept \
-       ${std_srcdir}/streambuf \
-       ${std_srcdir}/string \
-       ${std_srcdir}/utility \
-       ${std_srcdir}/valarray \
-       ${std_srcdir}/vector \
-       ${std_srcdir}/cassert \
-       ${std_srcdir}/cctype \
-       ${std_srcdir}/cerrno \
-       ${std_srcdir}/cfloat \
-       ${std_srcdir}/climits \
-       ${std_srcdir}/clocale \
-       ${std_srcdir}/ciso646 \
-       ${std_srcdir}/cmath \
-       ${std_srcdir}/csetjmp \
-       ${std_srcdir}/csignal \
-       ${std_srcdir}/cstdarg \
-       ${std_srcdir}/cstddef \
-       ${std_srcdir}/cstdio \
-       ${std_srcdir}/cstdlib \
-       ${std_srcdir}/cstring \
-       ${std_srcdir}/ctime \
-       ${std_srcdir}/cwchar \
-       ${std_srcdir}/cwctype
+       ${std_srcdir}/std_algorithm.h \
+       ${std_srcdir}/std_bitset.h \
+       ${std_srcdir}/std_complex.h \
+       ${std_srcdir}/std_deque.h \
+       ${std_srcdir}/std_fstream.h \
+       ${std_srcdir}/std_functional.h \
+       ${std_srcdir}/std_iomanip.h \
+       ${std_srcdir}/std_ios.h \
+       ${std_srcdir}/std_iosfwd.h \
+       ${std_srcdir}/std_iostream.h \
+       ${std_srcdir}/std_istream.h \
+       ${std_srcdir}/std_iterator.h \
+       ${std_srcdir}/std_limits.h \
+       ${std_srcdir}/std_list.h \
+       ${std_srcdir}/std_locale.h \
+       ${std_srcdir}/std_map.h \
+       ${std_srcdir}/std_memory.h \
+       ${std_srcdir}/std_numeric.h \
+       ${std_srcdir}/std_ostream.h \
+       ${std_srcdir}/std_queue.h \
+       ${std_srcdir}/std_set.h \
+       ${std_srcdir}/std_sstream.h \
+       ${std_srcdir}/std_stack.h \
+       ${std_srcdir}/std_stdexcept.h \
+       ${std_srcdir}/std_streambuf.h \
+       ${std_srcdir}/std_string.h \
+       ${std_srcdir}/std_utility.h \
+       ${std_srcdir}/std_valarray.h \
+       ${std_srcdir}/std_vector.h
+# Renamed at build time. 
+std_headers_rename = \
+       algorithm \
+       bitset \
+       complex \
+       deque \
+       fstream \
+       functional \
+       iomanip \
+       ios \
+       iosfwd \
+       iostream \
+       istream \
+       iterator \
+       limits \
+       list \
+       locale \
+       map \
+       memory \
+       numeric \
+       ostream \
+       queue \
+       set \
+       sstream \
+       stack \
+       stdexcept \
+       streambuf \
+       string \
+       utility \
+       valarray \
+       vector
 
 target_srcdir = ${glibcpp_srcdir}/@OS_INC_SRCDIR@
 target_builddir = ./${target_alias}/bits
@@ -286,7 +275,15 @@ target_headers = \
        ${target_srcdir}/ctype_noninline.h \
        ${target_srcdir}/os_defines.h \
        ${glibcpp_srcdir}/@ATOMICITY_INC_SRCDIR@/atomicity.h \
-       ${glibcpp_srcdir}/@LIMITS_INC_SRCDIR@/limits.h
+       ${glibcpp_srcdir}/@CPU_LIMITS_INC_SRCDIR@/cpu_limits.h 
+# These extra_target_headers files are all built with ad hoc naming rules.
+extra_target_headers = \
+       ${target_builddir}/basic_file_model.h \
+       ${target_builddir}/c++config.h \
+       ${target_builddir}/c++io.h \
+       ${target_builddir}/c++locale.h \
+       ${target_builddir}/messages_members.h \
+       ${target_builddir}/codecvt_specializations.h
 
 thread_builddir = ./${target_alias}/bits
 thread_headers = \
@@ -296,102 +293,82 @@ thread_headers = \
 
 # List of all timestamp files.  By keeping only one copy of this list, both
 # CLEANFILES and all-local are kept up-to-date.
-# XXX stamp-c_compatibility not implemented yet.
 allstamps = stamp-std stamp-bits stamp-c_base stamp-backward stamp-ext \
-       stamp-target stamp-thread stamp-file_model stamp-io \
-       stamp-locale stamp-messages_model stamp-codecvt_model
+       stamp-target stamp-thread 
 
-# By adding these files here, automake will remove them for 'make clean'
-CLEANFILES = ${allstamps}
 
 # Here are the rules for building the headers
-all-local: \
-       ${target_builddir}/c++config.h \
-       ${allstamps}
+all-local: ${target_builddir}/c++config.h ${allstamps}
 
+# This rule is slightly different, in that we must change the name of the
+# local file from std_foo.h to foo.
 stamp-std: ${std_headers}
        @if [ ! -d "${std_builddir}" ]; then \
          mkdir -p ${std_builddir} ;\
        fi ;\
-       (cd ${std_builddir} && @LN_S@ $? .) ;\
-       echo `date` > stamp-std
+       (cd ${std_builddir} && for h in $?; do \
+         official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
+         @LN_S@ $$h ./$${official_name} || true ;\
+       done) ;\
+       echo `date` > stamp-std 
 
 stamp-bits: ${bits_headers}
        @if [ ! -d "${bits_builddir}" ]; then \
          mkdir -p ${bits_builddir} ;\
        fi ;\
-       (cd ${bits_builddir} && @LN_S@ $? .) ;\
+       (cd ${bits_builddir} && @LN_S@ $? . || true) ;\
        echo `date` > stamp-bits
 
-stamp-c_base: ${c_base_headers}
+stamp-c_base: ${c_base_headers} ${c_base_headers_extra}
        @if [ ! -d "${c_base_builddir}" ]; then \
          mkdir -p ${c_base_builddir} ;\
        fi ;\
-       (cd ${c_base_builddir} && @LN_S@ $? .) ;\
+       (cd ${c_base_builddir} && for h in ${c_base_headers}; do \
+         official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
+         @LN_S@ $$h ./$${official_name} || true ;\
+       done) ;\
+       (cd ${c_base_builddir} && @LN_S@ ${c_base_headers_extra}  . || true) ;\
        echo `date` > stamp-c_base
 
-stamp-c_compatibility: ${c_compatibility_headers}
-       @if [ ! -d "${c_compatibility_builddir}" ]; then \
-         mkdir -p ${c_compatibility_builddir} ;\
-       fi ;\
-       (cd ${c_compatibility_builddir} && @LN_S@ $? .) ;\
-       echo `date` > stamp-c_compatibility
-
 stamp-backward: ${backward_headers}
        @if [ ! -d "${backward_builddir}" ]; then \
          mkdir -p ${backward_builddir} ;\
        fi ;\
-       (cd ${backward_builddir} && @LN_S@ $? .) ;\
+       (cd ${backward_builddir} && @LN_S@ $? . || true) ;\
        echo `date` > stamp-backward
 
 stamp-ext: ${ext_headers}
        @if [ ! -d "${ext_builddir}" ]; then \
          mkdir -p ${ext_builddir} ;\
        fi ;\
-       (cd ${ext_builddir} && @LN_S@ $? .) ;\
+       (cd ${ext_builddir} && @LN_S@ $? . || true) ;\
        echo `date` > stamp-ext
 
-# Can't use $? in command, otherwise target_builddir will trigger it, and
-# we get bizarre symlinks mazes.
-stamp-target: ${target_headers} ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${target_headers} .) ;\
-       echo `date` > stamp-target
-
-stamp-thread: ${thread_headers} ${thread_builddir}
-       @echo `date` > stamp-thread
-
-stamp-file_model: ${glibcpp_srcdir}/@BASIC_FILE_H@ ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${glibcpp_srcdir}/@BASIC_FILE_H@ basic_file_model.h) ;\
-       echo `date` > stamp-file_model
-
-stamp-io: ${glibcpp_srcdir}/@CSTDIO_H@ ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${glibcpp_srcdir}/@CSTDIO_H@ c++io.h) ;\
-       echo `date` > stamp-io
-
-stamp-locale: ${glibcpp_srcdir}/@CLOCALE_H@ ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${glibcpp_srcdir}/@CLOCALE_H@ c++locale.h) ;\
-       echo `date` > stamp-locale
-
-stamp-messages_model: ${glibcpp_srcdir}/@CMESSAGES_H@ ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${glibcpp_srcdir}/@CMESSAGES_H@ messages_members.h) ;\
-       echo `date` > stamp-messages_model
-
-stamp-codecvt_model: ${glibcpp_srcdir}/@CCODECVT_H@ ${target_builddir}
-       @(cd ${target_builddir} && @LN_S@ ${glibcpp_srcdir}/@CCODECVT_H@ codecvt_specializations.h) ;\
-       echo `date` > stamp-codecvt_model
-
-# This target is kinda special.  The timestamp on a directory gets modified
+# This target is special.  The timestamp on a directory gets modified
 # whenever a file it contains gets modified, and that'll throw off all the
 # build dependencies that need this target.  On the other hand, someone
-# could delete the directory and not the stamp file, faking out the make.
+# could delete the directory and not the stamp file, faking out make.
 ${target_builddir}: stamp-${target_alias}
-
 stamp-${target_alias}:
        @if [ ! -d ${target_builddir} ]; then \
          mkdir -p ${target_builddir} ;\
+         echo `date` > stamp-${target_alias} ;\
+       fi
+
+# Target includes static.
+stamp-target: ${target_headers} ${target_builddir}
+       @cd ${target_builddir} ;\
+       if [ ! -f stamp-target ]; then \
+         @LN_S@ ${target_headers} . || true ;\
+         @LN_S@ ${glibcpp_srcdir}/@BASIC_FILE_H@ basic_file_model.h || true ;\
+         @LN_S@ ${glibcpp_srcdir}/@CSTDIO_H@ c++io.h || true ;\
+         @LN_S@ ${glibcpp_srcdir}/@CLOCALE_H@ c++locale.h || true ;\
+         @LN_S@ ${glibcpp_srcdir}/@CMESSAGES_H@ messages_members.h || true ;\
+         @LN_S@ ${glibcpp_srcdir}/@CCODECVT_H@ codecvt_specializations.h || true ;\
+         echo `date` > stamp-target; \
        fi
-       echo `date` > stamp-${target_alias}
 
+# Target includes dynamic.
 ${target_builddir}/c++config.h: ../config.h \
                                ${glibcpp_srcdir}/include/bits/c++config \
                                ${target_builddir}
@@ -403,36 +380,75 @@ ${target_builddir}/c++config.h: ../config.h \
            < ${glibcpp_builddir}/config.h >> $@ ;\
        echo "#endif // _CPP_CPPCONFIG_" >>$@
 
+# Target includes for threads
 glibcpp_thread_h = @glibcpp_thread_h@
 uppercase = [ABCDEFGHIJKLMNOPQRSTUVWXYZ_]
 
+stamp-thread: ${thread_headers} ${thread_builddir}
+       @echo `date` > stamp-thread
+
+
 ${thread_builddir}/gthr.h:
        sed -e '/^#/s/\(${uppercase}${uppercase}*\)/_GLIBCPP_\1/g' \
            -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
-           < ${glibcpp_srcdir}/../gcc/gthr.h > $@
+           < ${toplevel_srcdir}/gcc/gthr.h > $@
 
 ${thread_builddir}/gthr-single.h:
        sed -e 's/\(UNUSED\)/_GLIBCPP_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCPP_\1/g' \
-           < ${glibcpp_srcdir}/../gcc/gthr-single.h > $@
+           < ${toplevel_srcdir}/gcc/gthr-single.h > $@
 
 ${thread_builddir}/gthr-default.h:
        sed -e 's/\(UNUSED\)/_GLIBCPP_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCPP_\1/g' \
            -e 's/\(${uppercase}*WEAK\)/_GLIBCPP_\1/g' \
-           < ${glibcpp_srcdir}/../gcc/${glibcpp_thread_h} > $@
-
-# One big happy istallation:  just copy everything from the build to the
-# install tree (except for the build stamps).
+           < ${toplevel_srcdir}/gcc/${glibcpp_thread_h} > $@
+
+# For robustness sake (in light of junk files or in-source
+# configuration), copy from the build or source tree to the install
+# tree using only the human-maintained file lists and directory
+# components.  Yes, with minor differences, this is sheer duplication
+# of the staging rules above using $(INSTALL_DATA) instead of LN_S and
+# `$(INSTALL) -d' instead of `mkdir -p'.  In particular,
+# extra_target_headers are taken out of the build tree staging area;
+# the rest are taken from the original source tree.
 gxx_include_dir = @gxx_include_dir@
-
 install-data-local:
-       for file in `find . ! -name stamp-\* ! -name Makefile -print`; do \
-       installFile=${gxx_include_dir}/$${file} ;\
-       if [ -d $${file} ]; then \
-         $(INSTALL) -d $${installFile} ;\
-       else \
-         $(INSTALL_DATA) $${file} $${installFile} ;\
-       fi ;\
-       done
+       $(INSTALL) -d ${gxx_include_dir}
+       $(INSTALL) -d ${gxx_include_dir}/${bits_builddir}
+       for file in ${bits_headers}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${bits_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${backward_builddir}
+       for file in ${backward_headers}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${backward_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${ext_builddir}
+       for file in ${ext_headers}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${ext_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${c_base_builddir}
+       for file in ${c_base_headers_rename}; do \
+         $(INSTALL_DATA) ${c_base_builddir}/$${file} \
+           ${gxx_include_dir}/${c_base_builddir}; done
+       for file in ${c_base_headers_extra}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${c_base_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${std_builddir}
+       for file in ${std_headers_rename}; do \
+         $(INSTALL_DATA) ${std_builddir}/$${file} \
+           ${gxx_include_dir}/${std_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${target_builddir}
+       for file in ${target_headers} ${extra_target_headers}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${target_builddir}; done
+       $(INSTALL) -d ${gxx_include_dir}/${thread_builddir}
+       for file in ${thread_headers}; do \
+         $(INSTALL_DATA) $${file} ${gxx_include_dir}/${thread_builddir}; done
 
+# By adding these files here, automake will remove them for 'make clean'
+#CLEANFILES = ${allstamps}
+
+# Stop implicit '.o' make rules from ever stomping on extensionless
+# headers, in the improbable case where some foolish, crack-addled
+# developer tries to create them via make in the include build
+# directory. (This is more of an example of how this kind of rule can
+# be made.)
+.PRECIOUS: $(std_headers_rename) $(c_base_headers_rename)
+$(std_headers_rename): ; @:
+$(c_base_headers_rename): ; @: