OSDN Git Service

2014-04-04 Richard Biener <rguenther@suse.de>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index c342528..e6de256 100644 (file)
@@ -1,7 +1,7 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
 ## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
-## 2011
+## 2011, 2012
 ## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
@@ -83,8 +83,6 @@ bits_headers = \
        ${bits_srcdir}/alloc_traits.h \
        ${bits_srcdir}/allocator.h \
        ${bits_srcdir}/atomic_base.h \
-       ${bits_srcdir}/atomic_0.h \
-       ${bits_srcdir}/atomic_2.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
@@ -179,6 +177,7 @@ bits_headers = \
 
 bits_sup_srcdir = ${glibcxx_srcdir}/libsupc++
 bits_sup_headers = \
+       ${bits_sup_srcdir}/atomic_lockfree_defines.h \
        ${bits_sup_srcdir}/cxxabi_forced.h \
        ${bits_sup_srcdir}/exception_defines.h \
        ${bits_sup_srcdir}/exception_ptr.h \
@@ -636,6 +635,7 @@ c_base_headers = \
        ${c_base_srcdir}/cmath \
        ${c_base_srcdir}/csetjmp \
        ${c_base_srcdir}/csignal \
+       ${c_base_srcdir}/cstdalign \
        ${c_base_srcdir}/cstdarg \
        ${c_base_srcdir}/cstdbool \
        ${c_base_srcdir}/cstddef \
@@ -1105,7 +1105,7 @@ ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
        sed -e "s,define __GLIBCXX__,define __GLIBCXX__ $$date," \
        -e "s,define _GLIBCXX_INLINE_VERSION, define _GLIBCXX_INLINE_VERSION $$ns_version," \
        -e "s,define _GLIBCXX_HAVE_ATTRIBUTE_VISIBILITY, define _GLIBCXX_HAVE_ATTRIBUTE_VISIBILITY $$visibility," \
-       -e "s,define _GLIBCXX_EXTERN_TEMPLATE, define _GLIBCXX_EXTERN_TEMPLATE $$externtemplate," \
+       -e "s,define _GLIBCXX_EXTERN_TEMPLATE$$, define _GLIBCXX_EXTERN_TEMPLATE $$externtemplate," \
        -e "$$ldbl_compat" \
            < ${glibcxx_srcdir}/include/bits/c++config > $@ ;\
        sed -e 's/HAVE_/_GLIBCXX_HAVE_/g' \
@@ -1134,7 +1134,7 @@ ${host_builddir}/gthr-single.h: ${toplevel_srcdir}/libgcc/gthr-single.h \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
            < $< > $@
 
-${host_builddir}/gthr-posix.h: ${toplevel_srcdir}/libgcc/config/gthr-posix.h \
+${host_builddir}/gthr-posix.h: ${toplevel_srcdir}/libgcc/gthr-posix.h \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \