OSDN Git Service

* include/Makefile.am, include/Makefile.in: Fix accidental extra
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index c502d72..ad4930c 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -150,7 +150,6 @@ bits_headers = \
        ${bits_srcdir}/stl_vector.h \
        ${bits_srcdir}/streambuf.tcc \
        ${bits_srcdir}/stringfwd.h \
-       ${bits_srcdir}/type_traits.h \
        ${bits_srcdir}/valarray_array.h \
        ${bits_srcdir}/valarray_array.tcc \
        ${bits_srcdir}/valarray_before.h \
@@ -201,10 +200,10 @@ ext_srcdir = ${glibcxx_srcdir}/include/ext
 ext_builddir = ./ext
 ext_headers = \
        ${ext_srcdir}/algorithm \
+       ${ext_srcdir}/array_allocator.h \
        ${ext_srcdir}/bitmap_allocator.h \
+       ${ext_srcdir}/codecvt_specializations.h \
        ${ext_srcdir}/debug_allocator.h \
-       ${ext_srcdir}/demangle.h \
-       ${ext_srcdir}/enc_filebuf.h \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
        ${ext_srcdir}/functional \
@@ -225,6 +224,21 @@ ext_headers = \
        ${ext_srcdir}/hash_fun.h \
        ${ext_srcdir}/hashtable.h
 
+tr1_srcdir = ${glibcxx_srcdir}/include/tr1
+tr1_builddir = ./tr1
+tr1_headers = \
+       ${tr1_srcdir}/array \
+       ${tr1_srcdir}/functional \
+       ${tr1_srcdir}/memory \
+       ${tr1_srcdir}/tuple \
+       ${tr1_srcdir}/utility \
+       ${tr1_srcdir}/type_traits \
+       ${tr1_srcdir}/type_traits_fwd.h \
+       ${tr1_srcdir}/hashtable \
+       ${tr1_srcdir}/unordered_set \
+       ${tr1_srcdir}/unordered_map
+
+
 # This is the common subset of files that all three "C" header models use.
 c_base_srcdir = $(C_INCLUDE_DIR)
 c_base_builddir = .
@@ -355,13 +369,13 @@ host_headers_extra = \
        ${host_builddir}/c++io.h \
        ${host_builddir}/c++locale.h \
        ${host_builddir}/messages_members.h \
-       ${host_builddir}/time_members.h \
-       ${host_builddir}/codecvt_specializations.h
+       ${host_builddir}/time_members.h 
 
 thread_host_headers = \
        ${host_builddir}/gthr.h \
        ${host_builddir}/gthr-single.h \
        ${host_builddir}/gthr-posix.h \
+       ${host_builddir}/gthr-tpf.h \
        ${host_builddir}/gthr-default.h
 
 pch_input = ${host_builddir}/stdc++.h
@@ -380,7 +394,7 @@ endif
 # CLEANFILES and all-local are kept up-to-date.
 allstamped = \
        stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
-       stamp-backward stamp-ext stamp-debug stamp-host
+       stamp-backward stamp-ext stamp-tr1 stamp-debug stamp-host
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -459,6 +473,16 @@ stamp-ext: ${ext_headers}
        fi ;\
        $(STAMP) stamp-ext
 
+
+stamp-tr1: ${tr1_headers}
+       @if [ ! -d "${tr1_builddir}" ]; then \
+           mkdir -p ${tr1_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-tr1 ]; then \
+         (cd ${tr1_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-tr1
+
 stamp-debug: ${debug_headers}
        @if [ ! -d "${debug_builddir}" ]; then \
          mkdir -p ${debug_builddir} ;\
@@ -527,6 +551,14 @@ ${host_builddir}/gthr-posix.h: ${toplevel_srcdir}/gcc/gthr-posix.h \
            -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
            < ${toplevel_srcdir}/gcc/gthr-posix.h > $@
 
+${host_builddir}/gthr-tpf.h: ${toplevel_srcdir}/gcc/gthr-tpf.h \
+                                  stamp-${host_alias}
+       sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
+           -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
+           < ${toplevel_srcdir}/gcc/gthr-tpf.h > $@
+
 ${host_builddir}/gthr-default.h: ${toplevel_srcdir}/gcc/${glibcxx_thread_h} \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
@@ -588,6 +620,9 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${ext_builddir}
        for file in ${ext_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${ext_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_builddir}
+       for file in ${tr1_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
        for file in ${c_base_headers_rename}; do \
          $(INSTALL_DATA) ${c_base_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done