OSDN Git Service

2008-07-05 Paolo Carlini <paolo.carlini@oracle.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index 7bfde7c..89ac735 100644 (file)
@@ -33,6 +33,7 @@ std_headers = \
        ${std_srcdir}/bitset \
        ${std_srcdir}/c++0x_warning.h \
        ${std_srcdir}/complex \
+       ${std_srcdir}/condition_variable \
        ${std_srcdir}/date_time \
        ${std_srcdir}/deque \
        ${std_srcdir}/fstream \
@@ -48,10 +49,12 @@ std_headers = \
        ${std_srcdir}/locale \
        ${std_srcdir}/map \
        ${std_srcdir}/memory \
+       ${std_srcdir}/mutex \
        ${std_srcdir}/numeric \
        ${std_srcdir}/ostream \
        ${std_srcdir}/queue \
        ${std_srcdir}/random \
+       ${std_srcdir}/ratio \
        ${std_srcdir}/regex \
        ${std_srcdir}/set \
        ${std_srcdir}/sstream \
@@ -102,6 +105,7 @@ bits_headers = \
        ${bits_srcdir}/locale_facets_nonio.tcc \
        ${bits_srcdir}/localefwd.h \
        ${bits_srcdir}/mask_array.h \
+       ${bits_srcdir}/move.h \
        ${bits_srcdir}/ostream.tcc \
        ${bits_srcdir}/ostream_insert.h \
        ${bits_srcdir}/postypes.h \
@@ -121,7 +125,6 @@ bits_headers = \
        ${bits_srcdir}/stl_iterator_base_types.h \
        ${bits_srcdir}/stl_list.h \
        ${bits_srcdir}/stl_map.h \
-       ${bits_srcdir}/stl_move.h \
        ${bits_srcdir}/stl_multimap.h \
        ${bits_srcdir}/stl_multiset.h \
        ${bits_srcdir}/stl_numeric.h \
@@ -137,6 +140,7 @@ bits_headers = \
        ${bits_srcdir}/stl_vector.h \
        ${bits_srcdir}/streambuf.tcc \
        ${bits_srcdir}/stringfwd.h \
+       ${bits_srcdir}/unique_ptr.h \
        ${bits_srcdir}/valarray_array.h \
        ${bits_srcdir}/valarray_array.tcc \
        ${bits_srcdir}/valarray_before.h \
@@ -153,7 +157,7 @@ backward_headers = \
        ${backward_srcdir}/hash_set \
        ${backward_srcdir}/hash_fun.h \
        ${backward_srcdir}/hashtable.h \
-       ${backward_srcdir}/strstream 
+       ${backward_srcdir}/strstream
 
 pb_srcdir = ${glibcxx_srcdir}/include/ext/pb_ds
 pb_builddir = ./ext/pb_ds
@@ -185,7 +189,7 @@ pb_subdirs = \
        ${pb_builddir}/detail/list_update_policy
 
 # The ability for make and the underlying host to deal with this
-# unweildy list as one entire entity is not a sure thing, and may
+# unwieldy list as one entire entity is not a sure thing, and may
 # cause build errors. Thus, split one list into many smaller
 # mini-lists, with the maximum size per mini-list of no more than 42.
 
@@ -230,7 +234,7 @@ pb_headers1 = \
        ${pb_srcdir}/detail/binomial_heap_/debug_fn_imps.hpp \
        ${pb_srcdir}/detail/bin_search_tree_/bin_search_tree_.hpp \
        ${pb_srcdir}/detail/bin_search_tree_/cond_dtor_entry_dealtor.hpp \
-       ${pb_srcdir}/detail/bin_search_tree_/cond_key_dtor_entry_dealtor.hpp 
+       ${pb_srcdir}/detail/bin_search_tree_/cond_key_dtor_entry_dealtor.hpp
 
 pb_headers2 = \
        ${pb_srcdir}/detail/bin_search_tree_/constructors_destructor_fn_imps.hpp \
@@ -272,7 +276,7 @@ pb_headers2 = \
        ${pb_srcdir}/detail/cc_hash_table_map_/resize_no_store_hash_fn_imps.hpp \
        ${pb_srcdir}/detail/cc_hash_table_map_/resize_store_hash_fn_imps.hpp \
        ${pb_srcdir}/detail/cc_hash_table_map_/size_fn_imps.hpp \
-       ${pb_srcdir}/detail/cc_hash_table_map_/standard_policies.hpp 
+       ${pb_srcdir}/detail/cc_hash_table_map_/standard_policies.hpp
 
 pb_headers3 = \
        ${pb_srcdir}/detail/cc_hash_table_map_/trace_fn_imps.hpp \
@@ -313,7 +317,7 @@ pb_headers3 = \
        ${pb_srcdir}/detail/hash_fn/probe_fn_base.hpp \
        ${pb_srcdir}/detail/hash_fn/quadratic_probe_fn_imp.hpp \
        ${pb_srcdir}/detail/hash_fn/ranged_hash_fn.hpp \
-       ${pb_srcdir}/detail/hash_fn/ranged_probe_fn.hpp 
+       ${pb_srcdir}/detail/hash_fn/ranged_probe_fn.hpp
 
 pb_headers4 = \
        ${pb_srcdir}/detail/hash_fn/sample_probe_fn.hpp \
@@ -356,7 +360,7 @@ pb_headers4 = \
        ${pb_srcdir}/detail/ov_tree_map_/insert_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/iterators_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/node_iterators.hpp \
-       ${pb_srcdir}/detail/ov_tree_map_/ov_tree_map_.hpp 
+       ${pb_srcdir}/detail/ov_tree_map_/ov_tree_map_.hpp
 
 pb_headers5 = \
        ${pb_srcdir}/detail/ov_tree_map_/policy_access_fn_imps.hpp \
@@ -398,7 +402,7 @@ pb_headers5 = \
        ${pb_srcdir}/detail/pat_trie_/update_fn_imps.hpp \
        ${pb_srcdir}/detail/priority_queue_base_dispatch.hpp \
        ${pb_srcdir}/detail/rb_tree_map_/constructors_destructor_fn_imps.hpp \
-       ${pb_srcdir}/detail/rb_tree_map_/debug_fn_imps.hpp 
+       ${pb_srcdir}/detail/rb_tree_map_/debug_fn_imps.hpp
 
 pb_headers6 = \
        ${pb_srcdir}/detail/rb_tree_map_/erase_fn_imps.hpp \
@@ -440,7 +444,7 @@ pb_headers6 = \
        ${pb_srcdir}/detail/standard_policies.hpp \
        ${pb_srcdir}/detail/thin_heap_/constructors_destructor_fn_imps.hpp \
        ${pb_srcdir}/detail/thin_heap_/debug_fn_imps.hpp \
-       ${pb_srcdir}/detail/thin_heap_/erase_fn_imps.hpp 
+       ${pb_srcdir}/detail/thin_heap_/erase_fn_imps.hpp
 
 pb_headers7 = \
        ${pb_srcdir}/detail/thin_heap_/find_fn_imps.hpp \
@@ -466,11 +470,11 @@ pb_headers7 = \
        ${pb_srcdir}/detail/unordered_iterator/const_iterator.hpp \
        ${pb_srcdir}/detail/unordered_iterator/const_point_iterator.hpp \
        ${pb_srcdir}/detail/unordered_iterator/iterator.hpp \
-       ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp 
+       ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp
 
 
 ext_srcdir = ${glibcxx_srcdir}/include/ext
-ext_builddir = ./ext 
+ext_builddir = ./ext
 ext_headers = \
        ${ext_srcdir}/algorithm \
        ${ext_srcdir}/atomicity.h \
@@ -496,6 +500,7 @@ ext_headers = \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
        ${ext_srcdir}/slist \
+       ${ext_srcdir}/string_conversions.h \
        ${ext_srcdir}/throw_allocator.h \
        ${ext_srcdir}/typelist.h \
        ${ext_srcdir}/type_traits.h \
@@ -637,7 +642,7 @@ c_compatibility_srcdir = ${glibcxx_srcdir}/include/c_compatibility
 c_compatibility_builddir = .
 
 if GLIBCXX_C_HEADERS_C_STD
-c_compatibility_headers = 
+c_compatibility_headers =
 endif
 
 if GLIBCXX_C_HEADERS_C_GLOBAL
@@ -645,7 +650,7 @@ c_compatibility_headers = \
        ${c_compatibility_srcdir}/complex.h \
        ${c_compatibility_srcdir}/fenv.h \
        ${c_compatibility_srcdir}/tgmath.h \
-       ${c_compatibility_srcdir}/stdatomic.h 
+       ${c_compatibility_srcdir}/stdatomic.h
 endif
 
 if GLIBCXX_C_HEADERS_C
@@ -706,10 +711,10 @@ debug_headers = \
 # Parallel mode headers
 parallel_srcdir = ${glibcxx_srcdir}/include/parallel
 parallel_builddir = ./parallel
+if ENABLE_PARALLEL
 parallel_headers = \
-        ${parallel_srcdir}/algorithm \
-        ${parallel_srcdir}/algobase.h \
         ${parallel_srcdir}/algo.h \
+        ${parallel_srcdir}/algobase.h \
         ${parallel_srcdir}/algorithm \
         ${parallel_srcdir}/algorithmfwd.h \
         ${parallel_srcdir}/balanced_quicksort.h \
@@ -735,8 +740,8 @@ parallel_headers = \
         ${parallel_srcdir}/numericfwd.h \
         ${parallel_srcdir}/omp_loop.h \
         ${parallel_srcdir}/omp_loop_static.h \
-        ${parallel_srcdir}/parallel.h \
         ${parallel_srcdir}/par_loop.h \
+        ${parallel_srcdir}/parallel.h \
         ${parallel_srcdir}/partial_sum.h \
         ${parallel_srcdir}/partition.h \
         ${parallel_srcdir}/queue.h \
@@ -750,7 +755,10 @@ parallel_headers = \
         ${parallel_srcdir}/tags.h \
         ${parallel_srcdir}/types.h \
         ${parallel_srcdir}/unique_copy.h \
-        ${parallel_srcdir}/workstealing.h 
+        ${parallel_srcdir}/workstealing.h
+else
+parallel_headers =
+endif
 
 
 # Some of the different "C" header models need extra files.
@@ -782,7 +790,7 @@ host_headers = \
        ${glibcxx_srcdir}/$(ERROR_CONSTANTS_SRCDIR)/error_constants.h \
        ${glibcxx_srcdir}/include/precompiled/stdc++.h \
        ${glibcxx_srcdir}/include/precompiled/stdtr1c++.h \
-       ${glibcxx_srcdir}/include/precompiled/extc++.h 
+       ${glibcxx_srcdir}/include/precompiled/extc++.h
 
 # Non-installed host_header files.
 COMPATIBILITY_H = config/abi/compatibility.h
@@ -798,7 +806,7 @@ host_headers_extra = \
        ${host_builddir}/c++io.h \
        ${host_builddir}/c++locale.h \
        ${host_builddir}/messages_members.h \
-       ${host_builddir}/time_members.h 
+       ${host_builddir}/time_members.h
 
 thread_host_headers = \
        ${host_builddir}/gthr.h \
@@ -905,7 +913,7 @@ stamp-ext: ${ext_headers}
 stamp-pb:
        @if [ ! -d "${pb_builddir}" ]; then \
            mkdir -p ${pb_subdirs} ;\
-       fi 
+       fi
        @if [ ! -f stamp-pb ]; then \
            cd ${pb_builddir} && for h in ${pb_headers1}; do \
                build_name=`echo $$h | sed -e "s|${pb_srcdir}|.|g"` ;\
@@ -1080,34 +1088,22 @@ ${host_builddir}/gthr-default.h: ${toplevel_srcdir}/gcc/${glibcxx_thread_h} \
 
 # Build two precompiled C++ includes, stdc++.h.gch/*.gch
 ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
-       if [ ! -d "${pch1_output_builddir}" ]; then \
-         mkdir -p ${pch1_output_builddir}; \
-       fi; \
+       -mkdir -p ${pch1_output_builddir}
        $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O0 -g ${pch1_source} -o $@
-       touch ${pch1_output_anchor}
 
 ${pch1b_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
-       if [ ! -d "${pch1_output_builddir}" ]; then \
-         mkdir -p ${pch1_output_builddir}; \
-       fi; \
+       -mkdir -p ${pch1_output_builddir}
        $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch1_source} -o $@
-       touch ${pch1_output_anchor}
 
 # Build a precompiled TR1 include, stdtr1c++.h.gch/O2.gch
 ${pch2_output}: ${pch2_source} ${pch1_output}
-       if [ ! -d "${pch2_output_builddir}" ]; then \
-         mkdir -p ${pch2_output_builddir}; \
-       fi; \
+       -mkdir -p ${pch2_output_builddir}
        $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch2_source} -o $@
-       touch ${pch2_output_anchor}
 
 # Build a precompiled extension include, extc++.h.gch/O2.gch
 ${pch3_output}: ${pch3_source} ${pch2_output}
-       if [ ! -d "${pch3_output_builddir}" ]; then \
-         mkdir -p ${pch3_output_builddir}; \
-       fi; \
+       -mkdir -p ${pch3_output_builddir}
        $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch3_source} -o $@
-       touch ${pch3_output_anchor}
 
 # For robustness sake (in light of junk files or in-source
 # configuration), copy from the build or source tree to the install
@@ -1119,7 +1115,7 @@ ${pch3_output}: ${pch3_source} ${pch2_output}
 # the rest are taken from the original source tree.
 
 if GLIBCXX_HOSTED
-install-data-local: install-headers 
+install-data-local: install-headers
 else
 install-data-local: install-freestanding-headers
 endif
@@ -1204,8 +1200,10 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
        for file in ${debug_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
-       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir}
-       for file in ${parallel_headers}; do \
+       parallel_headers_install='${parallel_headers}';\
+       test -z "$$parallel_headers_install" || \
+         $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir};\
+       for file in $$parallel_headers_install; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${parallel_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${host_installdir}
        for file in ${host_headers} ${host_headers_extra} \