OSDN Git Service

* include/bits/istream.tcc (getline): Make sure arguments passed
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index 20b7025..34e2033 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
-
-mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
-
-# Cross compiler and multilib support.
-CXX = @glibcxx_CXX@
-glibcxx_srcdir=@glibcxx_srcdir@
-glibcxx_builddir=@glibcxx_builddir@
-
-GLIBCXX_INCLUDES = @GLIBCXX_INCLUDES@
-LIBSUPCXX_INCLUDES = @LIBSUPCXX_INCLUDES@
-INCLUDES = -nostdinc++ $(GLIBCXX_INCLUDES) $(LIBSUPCXX_INCLUDES)
+include $(top_srcdir)/fragment.am
 
 # Standard C++ includes.
 std_srcdir = ${glibcxx_srcdir}/include/std
@@ -68,7 +56,7 @@ std_headers = \
        ${std_srcdir}/std_utility.h \
        ${std_srcdir}/std_valarray.h \
        ${std_srcdir}/std_vector.h
-# Renamed at build time. 
+# Renamed at build time.
 std_headers_rename = \
        algorithm \
        bitset \
@@ -104,7 +92,7 @@ bits_srcdir = ${glibcxx_srcdir}/include/bits
 bits_builddir = ./bits
 bits_headers = \
        ${bits_srcdir}/allocator.h \
-       ${bits_srcdir}/allocator_traits.h \
+       ${bits_srcdir}/atomicity.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
@@ -113,8 +101,8 @@ bits_headers = \
        ${bits_srcdir}/char_traits.h \
        ${bits_srcdir}/codecvt.h \
        ${bits_srcdir}/concept_check.h \
+       ${bits_srcdir}/concurrence.h \
        ${bits_srcdir}/cpp_type_traits.h \
-       ${bits_srcdir}/demangle.h \
        ${bits_srcdir}/deque.tcc \
        ${bits_srcdir}/fstream.tcc \
        ${bits_srcdir}/functexcept.h \
@@ -130,6 +118,7 @@ bits_headers = \
        ${bits_srcdir}/localefwd.h \
        ${bits_srcdir}/mask_array.h \
        ${bits_srcdir}/ostream.tcc \
+       ${bits_srcdir}/postypes.h \
        ${bits_srcdir}/stream_iterator.h \
        ${bits_srcdir}/streambuf_iterator.h \
        ${bits_srcdir}/slice_array.h \
@@ -213,7 +202,9 @@ ext_srcdir = ${glibcxx_srcdir}/include/ext
 ext_builddir = ./ext
 ext_headers = \
        ${ext_srcdir}/algorithm \
+       ${ext_srcdir}/bitmap_allocator.h \
        ${ext_srcdir}/debug_allocator.h \
+       ${ext_srcdir}/demangle.h \
        ${ext_srcdir}/enc_filebuf.h \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
@@ -226,17 +217,17 @@ ext_headers = \
        ${ext_srcdir}/mt_allocator.h \
        ${ext_srcdir}/new_allocator.h \
        ${ext_srcdir}/numeric \
+       ${ext_srcdir}/pod_char_traits.h \
        ${ext_srcdir}/pool_allocator.h \
        ${ext_srcdir}/rb_tree \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
        ${ext_srcdir}/slist \
        ${ext_srcdir}/hash_fun.h \
-       ${ext_srcdir}/hashtable.h 
-
+       ${ext_srcdir}/hashtable.h
 
 # This is the common subset of files that all three "C" header models use.
-c_base_srcdir = @C_INCLUDE_DIR@
+c_base_srcdir = $(C_INCLUDE_DIR)
 c_base_builddir = .
 c_base_headers = \
        ${c_base_srcdir}/std_cassert.h \
@@ -256,7 +247,7 @@ c_base_headers = \
        ${c_base_srcdir}/std_cstring.h \
        ${c_base_srcdir}/std_ctime.h \
        ${c_base_srcdir}/std_cwchar.h \
-       ${c_base_srcdir}/std_cwctype.h 
+       ${c_base_srcdir}/std_cwctype.h
 c_base_headers_rename = \
        cassert \
        cctype \
@@ -275,7 +266,7 @@ c_base_headers_rename = \
        cstring \
        ctime \
        cwchar \
-       cwctype 
+       cwctype
 
 # "C" compatibility headers.
 c_compatibility_srcdir = ${glibcxx_srcdir}/include/c_compatibility
@@ -298,41 +289,69 @@ c_compatibility_headers = \
        ${c_compatibility_srcdir}/string.h \
        ${c_compatibility_srcdir}/time.h \
        ${c_compatibility_srcdir}/wchar.h \
-       ${c_compatibility_srcdir}/wctype.h 
+       ${c_compatibility_srcdir}/wctype.h
+
+# Debug mode headers
+debug_srcdir = ${glibcxx_srcdir}/include/debug
+debug_builddir = ./debug
+debug_headers = \
+       ${debug_srcdir}/bitset \
+       ${debug_srcdir}/debug.h \
+       ${debug_srcdir}/deque \
+       ${debug_srcdir}/formatter.h \
+       ${debug_srcdir}/hash_map \
+       ${debug_srcdir}/hash_map.h \
+       ${debug_srcdir}/hash_multimap.h \
+       ${debug_srcdir}/hash_multiset.h \
+       ${debug_srcdir}/hash_set \
+       ${debug_srcdir}/hash_set.h \
+       ${debug_srcdir}/list \
+       ${debug_srcdir}/map \
+       ${debug_srcdir}/map.h \
+       ${debug_srcdir}/multimap.h \
+       ${debug_srcdir}/multiset.h \
+       ${debug_srcdir}/safe_base.h \
+       ${debug_srcdir}/safe_iterator.h \
+       ${debug_srcdir}/safe_iterator.tcc \
+       ${debug_srcdir}/safe_sequence.h \
+       ${debug_srcdir}/set \
+       ${debug_srcdir}/set.h \
+       ${debug_srcdir}/string \
+       ${debug_srcdir}/vector
 
 # Some of the different "C" header models need extra files.
 # Some "C" header schemes require the "C" compatibility headers.
 # For --enable-cheaders=c_std
 if GLIBCXX_C_HEADERS_C_STD
-c_base_headers_extra = ${c_base_srcdir}/cmath.tcc 
+c_base_headers_extra = ${c_base_srcdir}/cmath.tcc
 else
-c_base_headers_extra = 
+c_base_headers_extra =
 endif
 
 if GLIBCXX_C_HEADERS_COMPATIBILITY
 c_compatibility_headers_extra = ${c_compatibility_headers}
 else
-c_compatibility_headers_extra = 
+c_compatibility_headers_extra =
 endif
 
-host_srcdir = ${glibcxx_srcdir}/@OS_INC_SRCDIR@
+host_srcdir = ${glibcxx_srcdir}/$(OS_INC_SRCDIR)
 host_builddir = ./${host_alias}/bits
 host_headers = \
        ${host_srcdir}/ctype_base.h \
        ${host_srcdir}/ctype_inline.h \
        ${host_srcdir}/ctype_noninline.h \
        ${host_srcdir}/os_defines.h \
-       ${glibcxx_srcdir}/@ATOMICITY_INC_SRCDIR@/atomicity.h \
-       ${glibcxx_srcdir}/@FPOS_INC_SRCDIR@/fpos.h 
+       ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h 
 
 # Non-installed host_header files.
 host_headers_noinst = \
-       ${glibcxx_srcdir}/@CLOCALE_INTERNAL_H@
+       ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H)
 
 # These host_headers_extra files are all built with ad hoc naming rules.
 host_headers_extra = \
        ${host_builddir}/basic_file.h \
        ${host_builddir}/c++config.h \
+       ${host_builddir}/c++allocator.h \
        ${host_builddir}/c++io.h \
        ${host_builddir}/c++locale.h \
        ${host_builddir}/messages_members.h \
@@ -353,15 +372,15 @@ if GLIBCXX_BUILD_PCH
 pch_build = ${pch_input}
 pch_install = install-pch
 else
-pch_build = 
-pch_install = 
+pch_build =
+pch_install =
 endif
 
 # List of all timestamp files.  By keeping only one copy of this list, both
 # CLEANFILES and all-local are kept up-to-date.
 allstamped = \
        stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
-       stamp-backward stamp-ext stamp-host 
+       stamp-backward stamp-ext stamp-debug stamp-host
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -371,7 +390,7 @@ allcreated = \
        ${pch_build}
 
 # Here are the rules for building the headers
-all-local: ${allstamped} ${allcreated} 
+all-local: ${allstamped} ${allcreated}
 
 # This rule is slightly different, in that we must change the name of the
 # local file from std_foo.h to foo.
@@ -382,34 +401,34 @@ stamp-std: ${std_headers}
        if [ ! -f stamp-std ]; then \
          (cd ${std_builddir} && for h in $?; do \
            official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           @LN_S@ $$h ./$${official_name} || true ;\
+           $(LN_S) $$h ./$${official_name} || true ;\
          done) ;\
-         echo `date` > stamp-std ;\
-       fi
+       fi ;\
+       $(STAMP) stamp-std
 
 stamp-bits: ${bits_headers}
        @if [ ! -d "${bits_builddir}" ]; then \
          mkdir -p ${bits_builddir} ;\
        fi ;\
        if [ ! -f stamp-bits ]; then \
-         (cd ${bits_builddir} && @LN_S@ $? . || true) ;\
-         echo `date` > stamp-bits ;\
-       fi
+         (cd ${bits_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-bits
 
-stamp-c_base: ${c_base_headers} ${c_base_headers_extra} 
+stamp-c_base: stamp-bits ${c_base_headers} ${c_base_headers_extra}
        @if [ ! -d "${c_base_builddir}" ]; then \
          mkdir -p ${c_base_builddir} ;\
        fi ;\
        if [ ! -f stamp-c_base ]; then \
          (cd ${c_base_builddir} && for h in ${c_base_headers}; do \
            official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           @LN_S@ $$h ./$${official_name} || true ;\
+           $(LN_S) $$h ./$${official_name} || true ;\
          done) ;\
          if [ ! -z "${c_base_headers_extra}" ]; then \
-         (cd ${bits_builddir} && @LN_S@ ${c_base_headers_extra}  . || true) ;\
+         (cd ${bits_builddir} && $(LN_S) ${c_base_headers_extra}  . || true) ;\
          fi ;\
-         echo `date` > stamp-c_base ;\
-       fi
+       fi ;\
+       $(STAMP) stamp-c_base
 
 stamp-c_compatibility: ${c_compatibility_headers_extra}
        @if [ ! -d "${c_compatibility_builddir}" ]; then \
@@ -417,53 +436,63 @@ stamp-c_compatibility: ${c_compatibility_headers_extra}
        fi ;\
        if [ ! -f stamp-c_compatibility ]; then \
          if [ ! -z "${c_compatibility_headers_extra}" ]; then \
-           (cd ${c_compatibility_builddir} && @LN_S@ $? . || true) ;\
+           (cd ${c_compatibility_builddir} && $(LN_S) $? . || true) ;\
          fi ;\
-         echo `date` > stamp-c_compatibility ;\
-       fi 
+       fi ;\
+       $(STAMP) stamp-c_compatibility
 
 stamp-backward: ${backward_headers}
        @if [ ! -d "${backward_builddir}" ]; then \
          mkdir -p ${backward_builddir} ;\
        fi ;\
        if [ ! -f stamp-backward ]; then \
-         (cd ${backward_builddir} && @LN_S@ $? . || true) ;\
-         echo `date` > stamp-backward ;\
-       fi
+         (cd ${backward_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-backward
 
 stamp-ext: ${ext_headers}
        @if [ ! -d "${ext_builddir}" ]; then \
            mkdir -p ${ext_builddir} ;\
        fi ;\
        if [ ! -f stamp-ext ]; then \
-         (cd ${ext_builddir} && @LN_S@ $? . || true) ;\
-         echo `date` > stamp-ext ;\
-       fi
+         (cd ${ext_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-ext
+
+stamp-debug: ${debug_headers}
+       @if [ ! -d "${debug_builddir}" ]; then \
+         mkdir -p ${debug_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-debug ]; then \
+         (cd ${debug_builddir} && @LN_S@ $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-debug
 
 stamp-${host_alias}:
        @if [ ! -d ${host_builddir} ]; then \
          mkdir -p ${host_builddir} ;\
-         echo `date` > stamp-${host_alias} ;\
-       fi
+       fi ;\
+       $(STAMP) stamp-${host_alias}
 
 # Host includes static.
 # XXX Missing dependency info for {host_headers_extra}
 stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
        @if [ ! -f stamp-host ]; then \
          (cd ${host_builddir} ;\
-         @LN_S@ ${host_headers} . || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@BASIC_FILE_H@ basic_file.h || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CSTDIO_H@ c++io.h || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CLOCALE_H@ c++locale.h || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CLOCALE_INTERNAL_H@ . || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CMESSAGES_H@ messages_members.h || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CTIME_H@ time_members.h || true ;\
-         @LN_S@ ${glibcxx_srcdir}/@CCODECVT_H@ codecvt_specializations.h || true);\
-         echo `date` > stamp-host ; \
-       fi
+         $(LN_S) ${host_headers} . || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(BASIC_FILE_H) basic_file.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(ALLOCATOR_H) c++allocator.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CSTDIO_H) c++io.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_H) c++locale.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H) . || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CMESSAGES_H) messages_members.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CTIME_H) time_members.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(CCODECVT_H) codecvt_specializations.h || true);\
+       fi ;\
+       $(STAMP) stamp-host
 
 # Host includes dynamic.
-${host_builddir}/c++config.h: ${CONFIG_HEADER} \
+${host_builddir}/c++config.h: ${top_builddir}/config.h \
                                ${glibcxx_srcdir}/include/bits/c++config \
                                stamp-${host_alias}
        @cat ${glibcxx_srcdir}/include/bits/c++config > $@ ;\
@@ -475,11 +504,11 @@ ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
        echo "#endif // _CXXCONFIG_" >>$@
 
 # Host includes for threads
-glibcxx_thread_h = @glibcxx_thread_h@
 uppercase = [ABCDEFGHIJKLMNOPQRSTUVWXYZ_]
 
 ${host_builddir}/gthr.h: ${toplevel_srcdir}/gcc/gthr.h stamp-${host_alias}
        sed -e '/^#/s/\(${uppercase}${uppercase}*\)/_GLIBCXX_\1/g' \
+           -e 's/_GLIBCXX_SUPPORTS_WEAK/__GXX_WEAK__/g' \
            -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
            < ${toplevel_srcdir}/gcc/gthr.h > $@
 
@@ -493,14 +522,16 @@ ${host_builddir}/gthr-posix.h: ${toplevel_srcdir}/gcc/gthr-posix.h \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
-           -e 's/\(${uppercase}*WEAK\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
            < ${toplevel_srcdir}/gcc/gthr-posix.h > $@
 
 ${host_builddir}/gthr-default.h: ${toplevel_srcdir}/gcc/${glibcxx_thread_h} \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
-           -e 's/\(${uppercase}*WEAK\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
            -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
            < ${toplevel_srcdir}/gcc/${glibcxx_thread_h} > $@
 
@@ -510,8 +541,8 @@ ${pch_input}: ${allstamped} ${host_builddir}/c++config.h ${pch_source}
        if [ ! -d "${pch_output_builddir}" ]; then \
          mkdir -p ${pch_output_builddir}; \
        fi; \
-       $(CXX) $(PCHFLAGS) $(INCLUDES) ${pch_source} -O0 -g -o ${pch_output_builddir}/O0g; \
-       $(CXX) $(PCHFLAGS) $(INCLUDES) ${pch_source} -O2 -g -o ${pch_output_builddir}/O2g;
+       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O0 -g -o ${pch_output_builddir}/O0g; \
+       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O2 -g -o ${pch_output_builddir}/O2g;
 
 # For robustness sake (in light of junk files or in-source
 # configuration), copy from the build or source tree to the install
@@ -521,10 +552,30 @@ ${pch_input}: ${allstamped} ${host_builddir}/c++config.h ${pch_source}
 # `$(mkinstalldirs)' instead of `mkdir -p'.  In particular,
 # host_headers_extra are taken out of the build tree staging area;
 # the rest are taken from the original source tree.
-gxx_include_dir = @gxx_include_dir@
 
+if GLIBCXX_HOSTED
 install-data-local: install-headers ${pch_install}
+else
+install-data-local: install-freestanding-headers
+endif
+
+# This is a subset of the full install-headers rule.  We only need <cstddef>,
+# <limits>, <cstdlib>, <cstdarg>, <new>, <typeinfo>, <exception>, and any
+# files which they include (and which we provide).  The last three headers
+# are installed by libsupc++, so only the first four and the sub-includes
+# are copied here.
+install-freestanding-headers:
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${host_builddir}
+       for file in ${host_srcdir}/os_defines.h ${host_builddir}/c++config.h; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${host_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${std_builddir}
+       $(INSTALL_DATA) ${std_builddir}/limits $(DESTDIR)${gxx_include_dir}/${std_builddir}
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
+       for file in cstddef cstdlib cstdarg; do \
+         $(INSTALL_DATA) ${c_base_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done
 
+# The real deal.
 install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${bits_builddir}
@@ -548,6 +599,9 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${std_builddir}
        for file in ${std_headers_rename}; do \
          $(INSTALL_DATA) ${std_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${std_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
+       for file in ${debug_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${host_builddir}
        for file in ${host_headers} ${host_headers_extra} \
         ${thread_host_headers}; do \