OSDN Git Service

2009-10-05 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index f3dcd19..196ccb9 100644 (file)
@@ -618,6 +618,11 @@ tr1_impl_headers = \
        ${tr1_impl_srcdir}/unordered_set \
        ${tr1_impl_srcdir}/utility
 
+decimal_srcdir = ${glibcxx_srcdir}/include/decimal
+decimal_builddir = ./decimal
+decimal_headers = \
+       ${decimal_srcdir}/decimal \
+       ${decimal_srcdir}/decimal.h
 
 # This is the common subset of C++ files that all three "C" header models use.
 c_base_srcdir = $(C_INCLUDE_DIR)
@@ -896,8 +901,8 @@ endif
 allstamped = \
        stamp-std stamp-bits stamp-c_base stamp-c_base_extra \
        stamp-c_compatibility  stamp-backward stamp-ext stamp-pb \
-       stamp-tr1 stamp-tr1-impl stamp-debug stamp-parallel stamp-host \
-    stamp-profile stamp-profile-impl
+       stamp-tr1 stamp-tr1-impl stamp-decimal stamp-debug \
+       stamp-parallel stamp-profile stamp-profile-impl stamp-host 
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -1011,6 +1016,11 @@ stamp-tr1-impl: ${tr1_impl_headers}
        @-cd ${tr1_impl_builddir} && $(LN_S) $? . 2>/dev/null
        @$(STAMP) stamp-tr1-impl
 
+stamp-decimal: ${decimal_headers}
+       @-mkdir -p ${decimal_builddir}
+       @-cd ${decimal_builddir} && $(LN_S) $? . 2>/dev/null
+       @$(STAMP) stamp-decimal
+
 stamp-debug: ${debug_headers}
        @-mkdir -p ${debug_builddir}
        @-cd ${debug_builddir} && $(LN_S) $? . 2>/dev/null
@@ -1239,6 +1249,9 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}
        for file in ${tr1_impl_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${decimal_builddir}
+       for file in ${decimal_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${decimal_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
        for file in ${c_base_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done
@@ -1283,9 +1296,10 @@ clean-local:
 # directory. (This is more of an example of how this kind of rule can
 # be made.)
 .PRECIOUS: $(std_headers) $(c_base_headers) $(tr1_headers) $(tr1_impl_headers)
-          $(ext_headers)
+          $(decimal_headers) $(ext_headers)
 $(std_headers): ; @:
 $(c_base_headers): ; @:
 $(tr1_headers): ; @:
 $(tr1_impl_headers): ; @:
+$(decimal_headers): ; @:
 $(ext_headers): ; @: