OSDN Git Service

2009-04-06 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index 22ac39c..1938b83 100644 (file)
@@ -32,9 +32,11 @@ std_headers = \
        ${std_srcdir}/array \
        ${std_srcdir}/bitset \
        ${std_srcdir}/c++0x_warning.h \
+       ${std_srcdir}/chrono \
        ${std_srcdir}/complex \
-       ${std_srcdir}/date_time \
+       ${std_srcdir}/condition_variable \
        ${std_srcdir}/deque \
+       ${std_srcdir}/forward_list \
        ${std_srcdir}/fstream \
        ${std_srcdir}/functional \
        ${std_srcdir}/iomanip \
@@ -48,10 +50,12 @@ std_headers = \
        ${std_srcdir}/locale \
        ${std_srcdir}/map \
        ${std_srcdir}/memory \
+       ${std_srcdir}/mutex \
        ${std_srcdir}/numeric \
        ${std_srcdir}/ostream \
        ${std_srcdir}/queue \
        ${std_srcdir}/random \
+       ${std_srcdir}/ratio \
        ${std_srcdir}/regex \
        ${std_srcdir}/set \
        ${std_srcdir}/sstream \
@@ -60,6 +64,7 @@ std_headers = \
        ${std_srcdir}/streambuf \
        ${std_srcdir}/string \
        ${std_srcdir}/system_error \
+       ${std_srcdir}/thread \
        ${std_srcdir}/tuple \
        ${std_srcdir}/type_traits \
        ${std_srcdir}/unordered_map \
@@ -73,17 +78,22 @@ bits_builddir = ./bits
 bits_headers = \
         ${bits_srcdir}/algorithmfwd.h \
        ${bits_srcdir}/allocator.h \
+       ${bits_srcdir}/atomicfwd_c.h \
+       ${bits_srcdir}/atomicfwd_cxx.h \
+       ${bits_srcdir}/atomic_0.h \
+       ${bits_srcdir}/atomic_2.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
        ${bits_srcdir}/basic_string.tcc \
        ${bits_srcdir}/boost_concept_check.h \
-       ${bits_srcdir}/boost_sp_shared_count.h \
        ${bits_srcdir}/char_traits.h \
        ${bits_srcdir}/codecvt.h \
        ${bits_srcdir}/concept_check.h \
        ${bits_srcdir}/cpp_type_traits.h \
        ${bits_srcdir}/deque.tcc \
+       ${bits_srcdir}/forward_list.h \
+       ${bits_srcdir}/forward_list.tcc \
        ${bits_srcdir}/fstream.tcc \
        ${bits_srcdir}/functexcept.h \
        ${bits_srcdir}/functional_hash.h \
@@ -102,11 +112,15 @@ bits_headers = \
        ${bits_srcdir}/locale_facets_nonio.tcc \
        ${bits_srcdir}/localefwd.h \
        ${bits_srcdir}/mask_array.h \
+       ${bits_srcdir}/move.h \
        ${bits_srcdir}/ostream.tcc \
        ${bits_srcdir}/ostream_insert.h \
        ${bits_srcdir}/postypes.h \
+       ${bits_srcdir}/random.h \
+       ${bits_srcdir}/random.tcc \
        ${bits_srcdir}/stream_iterator.h \
        ${bits_srcdir}/streambuf_iterator.h \
+       ${bits_srcdir}/shared_ptr.h \
        ${bits_srcdir}/slice_array.h \
        ${bits_srcdir}/sstream.tcc \
        ${bits_srcdir}/stl_algo.h \
@@ -121,7 +135,6 @@ bits_headers = \
        ${bits_srcdir}/stl_iterator_base_types.h \
        ${bits_srcdir}/stl_list.h \
        ${bits_srcdir}/stl_map.h \
-       ${bits_srcdir}/stl_move.h \
        ${bits_srcdir}/stl_multimap.h \
        ${bits_srcdir}/stl_multiset.h \
        ${bits_srcdir}/stl_numeric.h \
@@ -137,6 +150,7 @@ bits_headers = \
        ${bits_srcdir}/stl_vector.h \
        ${bits_srcdir}/streambuf.tcc \
        ${bits_srcdir}/stringfwd.h \
+       ${bits_srcdir}/unique_ptr.h \
        ${bits_srcdir}/valarray_array.h \
        ${bits_srcdir}/valarray_array.tcc \
        ${bits_srcdir}/valarray_before.h \
@@ -153,7 +167,7 @@ backward_headers = \
        ${backward_srcdir}/hash_set \
        ${backward_srcdir}/hash_fun.h \
        ${backward_srcdir}/hashtable.h \
-       ${backward_srcdir}/strstream 
+       ${backward_srcdir}/strstream
 
 pb_srcdir = ${glibcxx_srcdir}/include/ext/pb_ds
 pb_builddir = ./ext/pb_ds
@@ -185,7 +199,7 @@ pb_subdirs = \
        ${pb_builddir}/detail/list_update_policy
 
 # The ability for make and the underlying host to deal with this
-# unweildy list as one entire entity is not a sure thing, and may
+# unwieldy list as one entire entity is not a sure thing, and may
 # cause build errors. Thus, split one list into many smaller
 # mini-lists, with the maximum size per mini-list of no more than 42.
 
@@ -230,7 +244,7 @@ pb_headers1 = \
        ${pb_srcdir}/detail/binomial_heap_/debug_fn_imps.hpp \
        ${pb_srcdir}/detail/bin_search_tree_/bin_search_tree_.hpp \
        ${pb_srcdir}/detail/bin_search_tree_/cond_dtor_entry_dealtor.hpp \
-       ${pb_srcdir}/detail/bin_search_tree_/cond_key_dtor_entry_dealtor.hpp 
+       ${pb_srcdir}/detail/bin_search_tree_/cond_key_dtor_entry_dealtor.hpp
 
 pb_headers2 = \
        ${pb_srcdir}/detail/bin_search_tree_/constructors_destructor_fn_imps.hpp \
@@ -272,7 +286,7 @@ pb_headers2 = \
        ${pb_srcdir}/detail/cc_hash_table_map_/resize_no_store_hash_fn_imps.hpp \
        ${pb_srcdir}/detail/cc_hash_table_map_/resize_store_hash_fn_imps.hpp \
        ${pb_srcdir}/detail/cc_hash_table_map_/size_fn_imps.hpp \
-       ${pb_srcdir}/detail/cc_hash_table_map_/standard_policies.hpp 
+       ${pb_srcdir}/detail/cc_hash_table_map_/standard_policies.hpp
 
 pb_headers3 = \
        ${pb_srcdir}/detail/cc_hash_table_map_/trace_fn_imps.hpp \
@@ -313,7 +327,7 @@ pb_headers3 = \
        ${pb_srcdir}/detail/hash_fn/probe_fn_base.hpp \
        ${pb_srcdir}/detail/hash_fn/quadratic_probe_fn_imp.hpp \
        ${pb_srcdir}/detail/hash_fn/ranged_hash_fn.hpp \
-       ${pb_srcdir}/detail/hash_fn/ranged_probe_fn.hpp 
+       ${pb_srcdir}/detail/hash_fn/ranged_probe_fn.hpp
 
 pb_headers4 = \
        ${pb_srcdir}/detail/hash_fn/sample_probe_fn.hpp \
@@ -356,7 +370,7 @@ pb_headers4 = \
        ${pb_srcdir}/detail/ov_tree_map_/insert_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/iterators_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/node_iterators.hpp \
-       ${pb_srcdir}/detail/ov_tree_map_/ov_tree_map_.hpp 
+       ${pb_srcdir}/detail/ov_tree_map_/ov_tree_map_.hpp
 
 pb_headers5 = \
        ${pb_srcdir}/detail/ov_tree_map_/policy_access_fn_imps.hpp \
@@ -398,7 +412,7 @@ pb_headers5 = \
        ${pb_srcdir}/detail/pat_trie_/update_fn_imps.hpp \
        ${pb_srcdir}/detail/priority_queue_base_dispatch.hpp \
        ${pb_srcdir}/detail/rb_tree_map_/constructors_destructor_fn_imps.hpp \
-       ${pb_srcdir}/detail/rb_tree_map_/debug_fn_imps.hpp 
+       ${pb_srcdir}/detail/rb_tree_map_/debug_fn_imps.hpp
 
 pb_headers6 = \
        ${pb_srcdir}/detail/rb_tree_map_/erase_fn_imps.hpp \
@@ -440,7 +454,7 @@ pb_headers6 = \
        ${pb_srcdir}/detail/standard_policies.hpp \
        ${pb_srcdir}/detail/thin_heap_/constructors_destructor_fn_imps.hpp \
        ${pb_srcdir}/detail/thin_heap_/debug_fn_imps.hpp \
-       ${pb_srcdir}/detail/thin_heap_/erase_fn_imps.hpp 
+       ${pb_srcdir}/detail/thin_heap_/erase_fn_imps.hpp
 
 pb_headers7 = \
        ${pb_srcdir}/detail/thin_heap_/find_fn_imps.hpp \
@@ -466,20 +480,22 @@ pb_headers7 = \
        ${pb_srcdir}/detail/unordered_iterator/const_iterator.hpp \
        ${pb_srcdir}/detail/unordered_iterator/const_point_iterator.hpp \
        ${pb_srcdir}/detail/unordered_iterator/iterator.hpp \
-       ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp 
+       ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp
 
 
 ext_srcdir = ${glibcxx_srcdir}/include/ext
-ext_builddir = ./ext 
+ext_builddir = ./ext
 ext_headers = \
        ${ext_srcdir}/algorithm \
        ${ext_srcdir}/atomicity.h \
        ${ext_srcdir}/array_allocator.h \
        ${ext_srcdir}/bitmap_allocator.h \
+       ${ext_srcdir}/cast.h \
        ${ext_srcdir}/codecvt_specializations.h \
        ${ext_srcdir}/concurrence.h \
        ${ext_srcdir}/debug_allocator.h \
        ${ext_srcdir}/enc_filebuf.h \
+       ${ext_srcdir}/extptr_allocator.h \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
        ${ext_srcdir}/functional \
@@ -491,11 +507,13 @@ ext_headers = \
        ${ext_srcdir}/numeric \
        ${ext_srcdir}/numeric_traits.h \
        ${ext_srcdir}/pod_char_traits.h \
+       ${ext_srcdir}/pointer.h \
        ${ext_srcdir}/pool_allocator.h \
        ${ext_srcdir}/rb_tree \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
        ${ext_srcdir}/slist \
+       ${ext_srcdir}/string_conversions.h \
        ${ext_srcdir}/throw_allocator.h \
        ${ext_srcdir}/typelist.h \
        ${ext_srcdir}/type_traits.h \
@@ -517,7 +535,6 @@ tr1_headers = \
        ${tr1_srcdir}/array \
        ${tr1_srcdir}/bessel_function.tcc \
        ${tr1_srcdir}/beta_function.tcc \
-       ${tr1_srcdir}/boost_sp_shared_count.h \
        ${tr1_srcdir}/ccomplex \
        ${tr1_srcdir}/cctype \
        ${tr1_srcdir}/cfenv \
@@ -555,8 +572,11 @@ tr1_headers = \
        ${tr1_srcdir}/poly_laguerre.tcc \
        ${tr1_srcdir}/legendre_function.tcc \
        ${tr1_srcdir}/random \
+       ${tr1_srcdir}/random.h \
+       ${tr1_srcdir}/random.tcc \
        ${tr1_srcdir}/regex \
        ${tr1_srcdir}/riemann_zeta.tcc \
+       ${tr1_srcdir}/shared_ptr.h \
        ${tr1_srcdir}/special_function_util.h \
        ${tr1_srcdir}/stdarg.h \
        ${tr1_srcdir}/stdbool.h \
@@ -577,7 +597,6 @@ tr1_impl_srcdir = ${glibcxx_srcdir}/include/tr1_impl
 tr1_impl_builddir = ./tr1_impl
 tr1_impl_headers = \
        ${tr1_impl_srcdir}/array \
-       ${tr1_impl_srcdir}/boost_shared_ptr.h \
        ${tr1_impl_srcdir}/boost_sp_counted_base.h \
        ${tr1_impl_srcdir}/cctype \
        ${tr1_impl_srcdir}/cfenv \
@@ -593,8 +612,6 @@ tr1_impl_headers = \
        ${tr1_impl_srcdir}/functional_hash.h \
        ${tr1_impl_srcdir}/hashtable \
        ${tr1_impl_srcdir}/hashtable_policy.h \
-       ${tr1_impl_srcdir}/random \
-       ${tr1_impl_srcdir}/random.tcc \
        ${tr1_impl_srcdir}/regex \
        ${tr1_impl_srcdir}/type_traits \
        ${tr1_impl_srcdir}/unordered_map \
@@ -637,7 +654,7 @@ c_compatibility_srcdir = ${glibcxx_srcdir}/include/c_compatibility
 c_compatibility_builddir = .
 
 if GLIBCXX_C_HEADERS_C_STD
-c_compatibility_headers = 
+c_compatibility_headers =
 endif
 
 if GLIBCXX_C_HEADERS_C_GLOBAL
@@ -645,7 +662,7 @@ c_compatibility_headers = \
        ${c_compatibility_srcdir}/complex.h \
        ${c_compatibility_srcdir}/fenv.h \
        ${c_compatibility_srcdir}/tgmath.h \
-       ${c_compatibility_srcdir}/stdatomic.h 
+       ${c_compatibility_srcdir}/stdatomic.h
 endif
 
 if GLIBCXX_C_HEADERS_C
@@ -691,7 +708,6 @@ debug_headers = \
        ${debug_srcdir}/map.h \
        ${debug_srcdir}/multimap.h \
        ${debug_srcdir}/multiset.h \
-       ${debug_srcdir}/safe_association.h \
        ${debug_srcdir}/safe_base.h \
        ${debug_srcdir}/safe_iterator.h \
        ${debug_srcdir}/safe_iterator.tcc \
@@ -708,9 +724,8 @@ parallel_srcdir = ${glibcxx_srcdir}/include/parallel
 parallel_builddir = ./parallel
 if ENABLE_PARALLEL
 parallel_headers = \
-        ${parallel_srcdir}/algorithm \
-        ${parallel_srcdir}/algobase.h \
         ${parallel_srcdir}/algo.h \
+        ${parallel_srcdir}/algobase.h \
         ${parallel_srcdir}/algorithm \
         ${parallel_srcdir}/algorithmfwd.h \
         ${parallel_srcdir}/balanced_quicksort.h \
@@ -736,8 +751,8 @@ parallel_headers = \
         ${parallel_srcdir}/numericfwd.h \
         ${parallel_srcdir}/omp_loop.h \
         ${parallel_srcdir}/omp_loop_static.h \
-        ${parallel_srcdir}/parallel.h \
         ${parallel_srcdir}/par_loop.h \
+        ${parallel_srcdir}/parallel.h \
         ${parallel_srcdir}/partial_sum.h \
         ${parallel_srcdir}/partition.h \
         ${parallel_srcdir}/queue.h \
@@ -751,7 +766,7 @@ parallel_headers = \
         ${parallel_srcdir}/tags.h \
         ${parallel_srcdir}/types.h \
         ${parallel_srcdir}/unique_copy.h \
-        ${parallel_srcdir}/workstealing.h 
+        ${parallel_srcdir}/workstealing.h
 else
 parallel_headers =
 endif
@@ -786,7 +801,7 @@ host_headers = \
        ${glibcxx_srcdir}/$(ERROR_CONSTANTS_SRCDIR)/error_constants.h \
        ${glibcxx_srcdir}/include/precompiled/stdc++.h \
        ${glibcxx_srcdir}/include/precompiled/stdtr1c++.h \
-       ${glibcxx_srcdir}/include/precompiled/extc++.h 
+       ${glibcxx_srcdir}/include/precompiled/extc++.h
 
 # Non-installed host_header files.
 COMPATIBILITY_H = config/abi/compatibility.h
@@ -802,7 +817,7 @@ host_headers_extra = \
        ${host_builddir}/c++io.h \
        ${host_builddir}/c++locale.h \
        ${host_builddir}/messages_members.h \
-       ${host_builddir}/time_members.h 
+       ${host_builddir}/time_members.h
 
 thread_host_headers = \
        ${host_builddir}/gthr.h \
@@ -816,7 +831,7 @@ pch1_source = ${glibcxx_srcdir}/include/precompiled/stdc++.h
 pch1_output_builddir = ${host_builddir}/stdc++.h.gch
 pch1_output_anchor = ${host_builddir}/stdc++.h
 pch1_output_installdir = ${host_installdir}/stdc++.h.gch
-pch1a_output = ${pch1_output_builddir}/O0g.gch
+pch1a_output = ${pch1_output_builddir}/O2ggnu++0x.gch
 pch1b_output = ${pch1_output_builddir}/O2g.gch
 pch1_output = ${pch1a_output} ${pch1b_output}
 
@@ -909,7 +924,7 @@ stamp-ext: ${ext_headers}
 stamp-pb:
        @if [ ! -d "${pb_builddir}" ]; then \
            mkdir -p ${pb_subdirs} ;\
-       fi 
+       fi
        @if [ ! -f stamp-pb ]; then \
            cd ${pb_builddir} && for h in ${pb_headers1}; do \
                build_name=`echo $$h | sed -e "s|${pb_srcdir}|.|g"` ;\
@@ -1085,7 +1100,8 @@ ${host_builddir}/gthr-default.h: ${toplevel_srcdir}/gcc/${glibcxx_thread_h} \
 # Build two precompiled C++ includes, stdc++.h.gch/*.gch
 ${pch1a_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
-       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O0 -g ${pch1_source} -o $@
+       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g -std=gnu++0x ${pch1_source} \
+       -o $@
 
 ${pch1b_output}: ${allstamped} ${host_builddir}/c++config.h ${pch1_source}
        -mkdir -p ${pch1_output_builddir}
@@ -1111,7 +1127,7 @@ ${pch3_output}: ${pch3_source} ${pch2_output}
 # the rest are taken from the original source tree.
 
 if GLIBCXX_HOSTED
-install-data-local: install-headers 
+install-data-local: install-headers
 else
 install-data-local: install-freestanding-headers
 endif
@@ -1196,8 +1212,10 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
        for file in ${debug_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
-       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir}
-       for file in ${parallel_headers}; do \
+       parallel_headers_install='${parallel_headers}';\
+       test -z "$$parallel_headers_install" || \
+         $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir};\
+       for file in $$parallel_headers_install; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${parallel_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${host_installdir}
        for file in ${host_headers} ${host_headers_extra} \