OSDN Git Service

2008-04-10 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index e3ca800..0d00227 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007
+## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
 ## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
@@ -33,6 +33,7 @@ std_headers = \
        ${std_srcdir}/bitset \
        ${std_srcdir}/c++0x_warning.h \
        ${std_srcdir}/complex \
+       ${std_srcdir}/date_time \
        ${std_srcdir}/deque \
        ${std_srcdir}/fstream \
        ${std_srcdir}/functional \
@@ -58,6 +59,7 @@ std_headers = \
        ${std_srcdir}/stdexcept \
        ${std_srcdir}/streambuf \
        ${std_srcdir}/string \
+       ${std_srcdir}/system_error \
        ${std_srcdir}/tuple \
        ${std_srcdir}/type_traits \
        ${std_srcdir}/unordered_map \
@@ -69,12 +71,14 @@ std_headers = \
 bits_srcdir = ${glibcxx_srcdir}/include/bits
 bits_builddir = ./bits
 bits_headers = \
+        ${bits_srcdir}/algorithmfwd.h \
        ${bits_srcdir}/allocator.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
        ${bits_srcdir}/basic_string.tcc \
        ${bits_srcdir}/boost_concept_check.h \
+       ${bits_srcdir}/boost_sp_shared_count.h \
        ${bits_srcdir}/char_traits.h \
        ${bits_srcdir}/codecvt.h \
        ${bits_srcdir}/concept_check.h \
@@ -82,18 +86,24 @@ bits_headers = \
        ${bits_srcdir}/deque.tcc \
        ${bits_srcdir}/fstream.tcc \
        ${bits_srcdir}/functexcept.h \
+       ${bits_srcdir}/functional_hash.h \
        ${bits_srcdir}/gslice.h \
        ${bits_srcdir}/gslice_array.h \
+       ${bits_srcdir}/hashtable.h \
        ${bits_srcdir}/indirect_array.h \
        ${bits_srcdir}/ios_base.h \
        ${bits_srcdir}/istream.tcc \
        ${bits_srcdir}/list.tcc \
        ${bits_srcdir}/locale_classes.h \
+       ${bits_srcdir}/locale_classes.tcc \
        ${bits_srcdir}/locale_facets.h \
        ${bits_srcdir}/locale_facets.tcc \
+       ${bits_srcdir}/locale_facets_nonio.h \
+       ${bits_srcdir}/locale_facets_nonio.tcc \
        ${bits_srcdir}/localefwd.h \
        ${bits_srcdir}/mask_array.h \
        ${bits_srcdir}/ostream.tcc \
+       ${bits_srcdir}/ostream_insert.h \
        ${bits_srcdir}/postypes.h \
        ${bits_srcdir}/stream_iterator.h \
        ${bits_srcdir}/streambuf_iterator.h \
@@ -111,7 +121,7 @@ bits_headers = \
        ${bits_srcdir}/stl_iterator_base_types.h \
        ${bits_srcdir}/stl_list.h \
        ${bits_srcdir}/stl_map.h \
-       ${bits_srcdir}/stl_memory.h \
+       ${bits_srcdir}/stl_move.h \
        ${bits_srcdir}/stl_multimap.h \
        ${bits_srcdir}/stl_multiset.h \
        ${bits_srcdir}/stl_numeric.h \
@@ -136,42 +146,14 @@ bits_headers = \
 backward_srcdir = ${glibcxx_srcdir}/include/backward
 backward_builddir = ./backward
 backward_headers = \
-       ${backward_srcdir}/complex.h \
-       ${backward_srcdir}/iomanip.h \
-       ${backward_srcdir}/istream.h \
-       ${backward_srcdir}/ostream.h \
-       ${backward_srcdir}/stream.h \
-       ${backward_srcdir}/streambuf.h \
-       ${backward_srcdir}/algo.h \
-       ${backward_srcdir}/algobase.h \
-       ${backward_srcdir}/alloc.h \
-       ${backward_srcdir}/bvector.h \
-       ${backward_srcdir}/defalloc.h \
-       ${backward_srcdir}/deque.h \
-       ${backward_srcdir}/function.h \
-       ${backward_srcdir}/hash_map.h \
-       ${backward_srcdir}/hash_set.h \
+       ${backward_srcdir}/auto_ptr.h \
+       ${backward_srcdir}/backward_warning.h \
+       ${backward_srcdir}/binders.h \
+       ${backward_srcdir}/hash_map \
+       ${backward_srcdir}/hash_set \
+       ${backward_srcdir}/hash_fun.h \
        ${backward_srcdir}/hashtable.h \
-       ${backward_srcdir}/heap.h \
-       ${backward_srcdir}/iostream.h \
-       ${backward_srcdir}/iterator.h \
-       ${backward_srcdir}/list.h \
-       ${backward_srcdir}/map.h \
-       ${backward_srcdir}/multimap.h \
-       ${backward_srcdir}/new.h \
-       ${backward_srcdir}/multiset.h \
-       ${backward_srcdir}/pair.h \
-       ${backward_srcdir}/queue.h \
-       ${backward_srcdir}/rope.h \
-       ${backward_srcdir}/set.h \
-       ${backward_srcdir}/slist.h \
-       ${backward_srcdir}/stack.h \
-       ${backward_srcdir}/tempbuf.h \
-       ${backward_srcdir}/tree.h \
-       ${backward_srcdir}/vector.h \
-       ${backward_srcdir}/fstream.h \
-       ${backward_srcdir}/strstream \
-       ${backward_srcdir}/backward_warning.h
+       ${backward_srcdir}/strstream 
 
 pb_srcdir = ${glibcxx_srcdir}/include/ext/pb_ds
 pb_builddir = ./ext/pb_ds
@@ -365,7 +347,7 @@ pb_headers4 = \
        ${pb_srcdir}/detail/list_update_policy/counter_lu_policy_imp.hpp \
        ${pb_srcdir}/detail/list_update_policy/mtf_lu_policy_imp.hpp \
        ${pb_srcdir}/detail/list_update_policy/sample_update_policy.hpp \
-       ${pb_srcdir}/detail/map_debug_base.hpp \
+       ${pb_srcdir}/detail/debug_map_base.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/cond_dtor.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/constructors_destructor_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/debug_fn_imps.hpp \
@@ -487,7 +469,6 @@ pb_headers7 = \
        ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp 
 
 
-
 ext_srcdir = ${glibcxx_srcdir}/include/ext
 ext_builddir = ./ext 
 ext_headers = \
@@ -502,16 +483,13 @@ ext_headers = \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
        ${ext_srcdir}/functional \
-       ${ext_srcdir}/hash_map \
-       ${ext_srcdir}/hash_set \
-       ${ext_srcdir}/hash_fun.h \
-       ${ext_srcdir}/hashtable.h \
        ${ext_srcdir}/iterator \
        ${ext_srcdir}/malloc_allocator.h \
        ${ext_srcdir}/memory \
        ${ext_srcdir}/mt_allocator.h \
        ${ext_srcdir}/new_allocator.h \
        ${ext_srcdir}/numeric \
+       ${ext_srcdir}/numeric_traits.h \
        ${ext_srcdir}/pod_char_traits.h \
        ${ext_srcdir}/pool_allocator.h \
        ${ext_srcdir}/rb_tree \
@@ -526,8 +504,12 @@ ext_headers = \
        ${ext_srcdir}/vstring.h \
        ${ext_srcdir}/vstring.tcc \
        ${ext_srcdir}/vstring_fwd.h \
-       ${ext_srcdir}/vstring_util.h    
+       ${ext_srcdir}/vstring_util.h \
+       ${ext_compat_headers}
 
+ext_compat_headers = \
+       ${backward_srcdir}/hash_set \
+       ${backward_srcdir}/hash_map
 
 tr1_srcdir = ${glibcxx_srcdir}/include/tr1
 tr1_builddir = ./tr1
@@ -535,7 +517,7 @@ tr1_headers = \
        ${tr1_srcdir}/array \
        ${tr1_srcdir}/bessel_function.tcc \
        ${tr1_srcdir}/beta_function.tcc \
-       ${tr1_srcdir}/boost_shared_ptr.h \
+       ${tr1_srcdir}/boost_sp_shared_count.h \
        ${tr1_srcdir}/ccomplex \
        ${tr1_srcdir}/cctype \
        ${tr1_srcdir}/cfenv \
@@ -543,7 +525,6 @@ tr1_headers = \
        ${tr1_srcdir}/cinttypes \
        ${tr1_srcdir}/climits \
        ${tr1_srcdir}/cmath \
-       ${tr1_srcdir}/common.h \
        ${tr1_srcdir}/complex \
        ${tr1_srcdir}/complex.h \
        ${tr1_srcdir}/cstdarg \
@@ -563,9 +544,8 @@ tr1_headers = \
        ${tr1_srcdir}/functional \
        ${tr1_srcdir}/functional_hash.h \
        ${tr1_srcdir}/gamma.tcc \
-       ${tr1_srcdir}/hashtable \
        ${tr1_srcdir}/hypergeometric.tcc \
-       ${tr1_srcdir}/hashtable_policy.h \
+       ${tr1_srcdir}/hashtable.h \
        ${tr1_srcdir}/inttypes.h \
        ${tr1_srcdir}/limits.h \
        ${tr1_srcdir}/math.h \
@@ -575,7 +555,6 @@ tr1_headers = \
        ${tr1_srcdir}/poly_laguerre.tcc \
        ${tr1_srcdir}/legendre_function.tcc \
        ${tr1_srcdir}/random \
-       ${tr1_srcdir}/random.tcc \
        ${tr1_srcdir}/regex \
        ${tr1_srcdir}/riemann_zeta.tcc \
        ${tr1_srcdir}/special_function_util.h \
@@ -587,7 +566,6 @@ tr1_headers = \
        ${tr1_srcdir}/tgmath.h \
        ${tr1_srcdir}/tuple \
        ${tr1_srcdir}/type_traits \
-       ${tr1_srcdir}/type_traits_fwd.h \
        ${tr1_srcdir}/unordered_set \
        ${tr1_srcdir}/unordered_map \
        ${tr1_srcdir}/utility \
@@ -595,6 +573,35 @@ tr1_headers = \
        ${tr1_srcdir}/wctype.h
 
 
+tr1_impl_srcdir = ${glibcxx_srcdir}/include/tr1_impl
+tr1_impl_builddir = ./tr1_impl
+tr1_impl_headers = \
+       ${tr1_impl_srcdir}/array \
+       ${tr1_impl_srcdir}/boost_shared_ptr.h \
+       ${tr1_impl_srcdir}/boost_sp_counted_base.h \
+       ${tr1_impl_srcdir}/cctype \
+       ${tr1_impl_srcdir}/cfenv \
+       ${tr1_impl_srcdir}/cinttypes \
+       ${tr1_impl_srcdir}/cmath \
+       ${tr1_impl_srcdir}/complex \
+       ${tr1_impl_srcdir}/cstdint \
+       ${tr1_impl_srcdir}/cstdio \
+       ${tr1_impl_srcdir}/cstdlib \
+       ${tr1_impl_srcdir}/cwchar \
+       ${tr1_impl_srcdir}/cwctype \
+       ${tr1_impl_srcdir}/functional \
+       ${tr1_impl_srcdir}/functional_hash.h \
+       ${tr1_impl_srcdir}/hashtable \
+       ${tr1_impl_srcdir}/hashtable_policy.h \
+       ${tr1_impl_srcdir}/random \
+       ${tr1_impl_srcdir}/random.tcc \
+       ${tr1_impl_srcdir}/regex \
+       ${tr1_impl_srcdir}/type_traits \
+       ${tr1_impl_srcdir}/unordered_map \
+       ${tr1_impl_srcdir}/unordered_set \
+       ${tr1_impl_srcdir}/utility
+
+
 # This is the common subset of C++ files that all three "C" header models use.
 c_base_srcdir = $(C_INCLUDE_DIR)
 c_base_builddir = .
@@ -613,6 +620,7 @@ c_base_headers = \
        ${c_base_srcdir}/csetjmp \
        ${c_base_srcdir}/csignal \
        ${c_base_srcdir}/cstdarg \
+       ${c_base_srcdir}/cstdatomic \
        ${c_base_srcdir}/cstdbool \
        ${c_base_srcdir}/cstddef \
        ${c_base_srcdir}/cstdint \
@@ -635,7 +643,9 @@ endif
 if GLIBCXX_C_HEADERS_C_GLOBAL
 c_compatibility_headers = \
        ${c_compatibility_srcdir}/complex.h \
-       ${c_compatibility_srcdir}/tgmath.h 
+       ${c_compatibility_srcdir}/fenv.h \
+       ${c_compatibility_srcdir}/tgmath.h \
+       ${c_compatibility_srcdir}/stdatomic.h 
 endif
 
 if GLIBCXX_C_HEADERS_C
@@ -675,18 +685,13 @@ debug_headers = \
        ${debug_srcdir}/deque \
        ${debug_srcdir}/formatter.h \
        ${debug_srcdir}/functions.h \
-       ${debug_srcdir}/hash_map \
-       ${debug_srcdir}/hash_map.h \
-       ${debug_srcdir}/hash_multimap.h \
-       ${debug_srcdir}/hash_multiset.h \
-       ${debug_srcdir}/hash_set \
-       ${debug_srcdir}/hash_set.h \
        ${debug_srcdir}/list \
        ${debug_srcdir}/map \
        ${debug_srcdir}/macros.h \
        ${debug_srcdir}/map.h \
        ${debug_srcdir}/multimap.h \
        ${debug_srcdir}/multiset.h \
+       ${debug_srcdir}/safe_association.h \
        ${debug_srcdir}/safe_base.h \
        ${debug_srcdir}/safe_iterator.h \
        ${debug_srcdir}/safe_iterator.tcc \
@@ -694,8 +699,60 @@ debug_headers = \
        ${debug_srcdir}/set \
        ${debug_srcdir}/set.h \
        ${debug_srcdir}/string \
+       ${debug_srcdir}/unordered_map \
+       ${debug_srcdir}/unordered_set \
        ${debug_srcdir}/vector
 
+# Parallel mode headers
+parallel_srcdir = ${glibcxx_srcdir}/include/parallel
+parallel_builddir = ./parallel
+parallel_headers = \
+        ${parallel_srcdir}/algorithm \
+        ${parallel_srcdir}/algobase.h \
+        ${parallel_srcdir}/algo.h \
+        ${parallel_srcdir}/algorithm \
+        ${parallel_srcdir}/algorithmfwd.h \
+        ${parallel_srcdir}/balanced_quicksort.h \
+        ${parallel_srcdir}/base.h \
+        ${parallel_srcdir}/basic_iterator.h \
+        ${parallel_srcdir}/checkers.h \
+        ${parallel_srcdir}/compatibility.h \
+        ${parallel_srcdir}/compiletime_settings.h \
+        ${parallel_srcdir}/equally_split.h \
+        ${parallel_srcdir}/features.h \
+        ${parallel_srcdir}/find.h \
+        ${parallel_srcdir}/find_selectors.h \
+        ${parallel_srcdir}/for_each.h \
+        ${parallel_srcdir}/for_each_selectors.h \
+        ${parallel_srcdir}/iterator.h \
+        ${parallel_srcdir}/list_partition.h \
+        ${parallel_srcdir}/losertree.h \
+        ${parallel_srcdir}/merge.h \
+        ${parallel_srcdir}/multiseq_selection.h \
+        ${parallel_srcdir}/multiway_merge.h \
+        ${parallel_srcdir}/multiway_mergesort.h \
+        ${parallel_srcdir}/numeric \
+        ${parallel_srcdir}/numericfwd.h \
+        ${parallel_srcdir}/omp_loop.h \
+        ${parallel_srcdir}/omp_loop_static.h \
+        ${parallel_srcdir}/parallel.h \
+        ${parallel_srcdir}/par_loop.h \
+        ${parallel_srcdir}/partial_sum.h \
+        ${parallel_srcdir}/partition.h \
+        ${parallel_srcdir}/queue.h \
+        ${parallel_srcdir}/quicksort.h \
+        ${parallel_srcdir}/random_number.h \
+        ${parallel_srcdir}/random_shuffle.h \
+        ${parallel_srcdir}/search.h \
+        ${parallel_srcdir}/set_operations.h \
+        ${parallel_srcdir}/settings.h \
+        ${parallel_srcdir}/sort.h \
+        ${parallel_srcdir}/tags.h \
+        ${parallel_srcdir}/types.h \
+        ${parallel_srcdir}/unique_copy.h \
+        ${parallel_srcdir}/workstealing.h 
+
+
 # Some of the different "C" header models need extra files.
 # Some "C" header schemes require the "C" compatibility headers.
 # For --enable-cheaders=c_std
@@ -721,7 +778,11 @@ host_headers = \
        ${host_srcdir}/os_defines.h \
        ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h \
        ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h \
-       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h   
+       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h \
+       ${glibcxx_srcdir}/$(ERROR_CONSTANTS_SRCDIR)/error_constants.h \
+       ${glibcxx_srcdir}/include/precompiled/stdc++.h \
+       ${glibcxx_srcdir}/include/precompiled/stdtr1c++.h \
+       ${glibcxx_srcdir}/include/precompiled/extc++.h 
 
 # Non-installed host_header files.
 COMPATIBILITY_H = config/abi/compatibility.h
@@ -773,13 +834,11 @@ pch_output_dirs = \
        ${pch1_output_builddir} ${pch2_output_builddir} ${pch3_output_builddir}
 pch_output_anchors = \
        ${pch1_output_anchor} ${pch2_output_anchor} ${pch3_output_anchor}
-PCHFLAGS=-Winvalid-pch -Wno-deprecated -x c++-header $(CXXFLAGS)
+PCHFLAGS=-Winvalid-pch -x c++-header $(CXXFLAGS)
 if GLIBCXX_BUILD_PCH
 pch_build = ${pch_output}
-pch_install = install-pch
 else
 pch_build =
-pch_install =
 endif
 
 # List of all timestamp files.  By keeping only one copy of this list, both
@@ -787,7 +846,7 @@ endif
 allstamped = \
        stamp-std stamp-bits stamp-c_base stamp-c_base_extra \
        stamp-c_compatibility  stamp-backward stamp-ext stamp-pb \
-       stamp-tr1 stamp-debug stamp-host
+       stamp-tr1 stamp-tr1-impl stamp-debug stamp-parallel stamp-host
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -926,6 +985,15 @@ stamp-tr1: ${tr1_headers}
        fi ;\
        $(STAMP) stamp-tr1
 
+stamp-tr1-impl: ${tr1_impl_headers}
+       @if [ ! -d "${tr1_impl_builddir}" ]; then \
+           mkdir -p ${tr1_impl_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-tr1-impl ]; then \
+         (cd ${tr1_impl_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-tr1-impl
+
 stamp-debug: ${debug_headers}
        @if [ ! -d "${debug_builddir}" ]; then \
          mkdir -p ${debug_builddir} ;\
@@ -935,6 +1003,15 @@ stamp-debug: ${debug_headers}
        fi ;\
        $(STAMP) stamp-debug
 
+stamp-parallel: ${parallel_headers}
+       @if [ ! -d "${parallel_builddir}" ]; then \
+         mkdir -p ${parallel_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-parallel ]; then \
+         (cd ${parallel_builddir} && @LN_S@ $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-parallel
+
 stamp-${host_alias}:
        @if [ ! -d ${host_builddir} ]; then \
          mkdir -p ${host_builddir} ;\
@@ -975,6 +1052,8 @@ stamp-visibility:
        echo 0 > stamp-visibility
 endif
 
+# NB: The non-empty default ldbl_compat works around an AIX sed
+# oddity, see libstdc++/31957 for details.
 ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
                              ${glibcxx_srcdir}/include/bits/c++config \
                              stamp-${host_alias} \
@@ -984,7 +1063,7 @@ ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
        @date=`cat ${toplevel_srcdir}/gcc/DATESTAMP` ;\
        nsa_version=`cat stamp-namespace-version` ;\
        visibility=`cat stamp-visibility` ;\
-       ldbl_compat='' ;\
+       ldbl_compat='s,g,g,' ;\
        grep "^[        ]*#[    ]*define[       ][      ]*_GLIBCXX_LONG_DOUBLE_COMPAT[  ][      ]*1[    ]*$$" \
        ${CONFIG_HEADER} > /dev/null 2>&1 \
        && ldbl_compat='s,^#undef _GLIBCXX_LONG_DOUBLE_COMPAT$$,#define _GLIBCXX_LONG_DOUBLE_COMPAT 1,' ;\
@@ -1085,7 +1164,7 @@ ${pch3_output}: ${pch3_source} ${pch2_output}
 # the rest are taken from the original source tree.
 
 if GLIBCXX_HOSTED
-install-data-local: install-headers ${pch_install}
+install-data-local: install-headers 
 else
 install-data-local: install-freestanding-headers
 endif
@@ -1152,6 +1231,9 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_builddir}
        for file in ${tr1_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}
+       for file in ${tr1_impl_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
        for file in ${c_base_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done
@@ -1167,21 +1249,14 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
        for file in ${debug_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir}
+       for file in ${parallel_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${parallel_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${host_installdir}
        for file in ${host_headers} ${host_headers_extra} \
         ${thread_host_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${host_installdir}; done
 
-install-pch:
-       $(mkinstalldirs) $(DESTDIR)${pch1_output_installdir}
-       for file in ${pch1_output_builddir}/*; do \
-         $(INSTALL_DATA) $$file $(DESTDIR)${pch1_output_installdir}; done
-       $(mkinstalldirs) $(DESTDIR)${pch2_output_installdir}
-       for file in ${pch2_output_builddir}/*; do \
-         $(INSTALL_DATA) $$file $(DESTDIR)${pch2_output_installdir}; done
-       $(INSTALL_DATA) ${pch1_output_anchor} $(DESTDIR)${host_installdir}
-       $(INSTALL_DATA) ${pch2_output_anchor} $(DESTDIR)${host_installdir}
-
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = ${pch_output} ${pch_output_anchors}
 
@@ -1194,8 +1269,10 @@ clean-local:
 # developer tries to create them via make in the include build
 # directory. (This is more of an example of how this kind of rule can
 # be made.)
-.PRECIOUS: $(std_headers) $(c_base_headers) $(tr1_headers) $(ext_headers)
+.PRECIOUS: $(std_headers) $(c_base_headers) $(tr1_headers) $(tr1_impl_headers)
+          $(ext_headers)
 $(std_headers): ; @:
 $(c_base_headers): ; @:
 $(tr1_headers): ; @:
+$(tr1_impl_headers): ; @:
 $(ext_headers): ; @: