OSDN Git Service

2008-04-10 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index ce4234d..0d00227 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006
+## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
 ## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
@@ -28,97 +28,82 @@ include $(top_srcdir)/fragment.am
 std_srcdir = ${glibcxx_srcdir}/include/std
 std_builddir = .
 std_headers = \
-       ${std_srcdir}/std_algorithm.h \
-       ${std_srcdir}/std_bitset.h \
-       ${std_srcdir}/std_complex.h \
-       ${std_srcdir}/std_deque.h \
-       ${std_srcdir}/std_fstream.h \
-       ${std_srcdir}/std_functional.h \
-       ${std_srcdir}/std_iomanip.h \
-       ${std_srcdir}/std_ios.h \
-       ${std_srcdir}/std_iosfwd.h \
-       ${std_srcdir}/std_iostream.h \
-       ${std_srcdir}/std_istream.h \
-       ${std_srcdir}/std_iterator.h \
-       ${std_srcdir}/std_limits.h \
-       ${std_srcdir}/std_list.h \
-       ${std_srcdir}/std_locale.h \
-       ${std_srcdir}/std_map.h \
-       ${std_srcdir}/std_memory.h \
-       ${std_srcdir}/std_numeric.h \
-       ${std_srcdir}/std_ostream.h \
-       ${std_srcdir}/std_queue.h \
-       ${std_srcdir}/std_set.h \
-       ${std_srcdir}/std_sstream.h \
-       ${std_srcdir}/std_stack.h \
-       ${std_srcdir}/std_stdexcept.h \
-       ${std_srcdir}/std_streambuf.h \
-       ${std_srcdir}/std_string.h \
-       ${std_srcdir}/std_utility.h \
-       ${std_srcdir}/std_valarray.h \
-       ${std_srcdir}/std_vector.h
-# Renamed at build time.
-std_headers_rename = \
-       algorithm \
-       bitset \
-       complex \
-       deque \
-       fstream \
-       functional \
-       iomanip \
-       ios \
-       iosfwd \
-       iostream \
-       istream \
-       iterator \
-       limits \
-       list \
-       locale \
-       map \
-       memory \
-       numeric \
-       ostream \
-       queue \
-       set \
-       sstream \
-       stack \
-       stdexcept \
-       streambuf \
-       string \
-       utility \
-       valarray \
-       vector
+       ${std_srcdir}/algorithm \
+       ${std_srcdir}/array \
+       ${std_srcdir}/bitset \
+       ${std_srcdir}/c++0x_warning.h \
+       ${std_srcdir}/complex \
+       ${std_srcdir}/date_time \
+       ${std_srcdir}/deque \
+       ${std_srcdir}/fstream \
+       ${std_srcdir}/functional \
+       ${std_srcdir}/iomanip \
+       ${std_srcdir}/ios \
+       ${std_srcdir}/iosfwd \
+       ${std_srcdir}/iostream \
+       ${std_srcdir}/istream \
+       ${std_srcdir}/iterator \
+       ${std_srcdir}/limits \
+       ${std_srcdir}/list \
+       ${std_srcdir}/locale \
+       ${std_srcdir}/map \
+       ${std_srcdir}/memory \
+       ${std_srcdir}/numeric \
+       ${std_srcdir}/ostream \
+       ${std_srcdir}/queue \
+       ${std_srcdir}/random \
+       ${std_srcdir}/regex \
+       ${std_srcdir}/set \
+       ${std_srcdir}/sstream \
+       ${std_srcdir}/stack \
+       ${std_srcdir}/stdexcept \
+       ${std_srcdir}/streambuf \
+       ${std_srcdir}/string \
+       ${std_srcdir}/system_error \
+       ${std_srcdir}/tuple \
+       ${std_srcdir}/type_traits \
+       ${std_srcdir}/unordered_map \
+       ${std_srcdir}/unordered_set \
+       ${std_srcdir}/utility \
+       ${std_srcdir}/valarray \
+       ${std_srcdir}/vector
 
 bits_srcdir = ${glibcxx_srcdir}/include/bits
 bits_builddir = ./bits
 bits_headers = \
+        ${bits_srcdir}/algorithmfwd.h \
        ${bits_srcdir}/allocator.h \
-       ${bits_srcdir}/atomicity.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
        ${bits_srcdir}/basic_string.tcc \
        ${bits_srcdir}/boost_concept_check.h \
+       ${bits_srcdir}/boost_sp_shared_count.h \
        ${bits_srcdir}/char_traits.h \
        ${bits_srcdir}/codecvt.h \
        ${bits_srcdir}/concept_check.h \
-       ${bits_srcdir}/concurrence.h \
        ${bits_srcdir}/cpp_type_traits.h \
        ${bits_srcdir}/deque.tcc \
        ${bits_srcdir}/fstream.tcc \
        ${bits_srcdir}/functexcept.h \
+       ${bits_srcdir}/functional_hash.h \
        ${bits_srcdir}/gslice.h \
        ${bits_srcdir}/gslice_array.h \
+       ${bits_srcdir}/hashtable.h \
        ${bits_srcdir}/indirect_array.h \
        ${bits_srcdir}/ios_base.h \
        ${bits_srcdir}/istream.tcc \
        ${bits_srcdir}/list.tcc \
        ${bits_srcdir}/locale_classes.h \
+       ${bits_srcdir}/locale_classes.tcc \
        ${bits_srcdir}/locale_facets.h \
        ${bits_srcdir}/locale_facets.tcc \
+       ${bits_srcdir}/locale_facets_nonio.h \
+       ${bits_srcdir}/locale_facets_nonio.tcc \
        ${bits_srcdir}/localefwd.h \
        ${bits_srcdir}/mask_array.h \
        ${bits_srcdir}/ostream.tcc \
+       ${bits_srcdir}/ostream_insert.h \
        ${bits_srcdir}/postypes.h \
        ${bits_srcdir}/stream_iterator.h \
        ${bits_srcdir}/streambuf_iterator.h \
@@ -136,6 +121,7 @@ bits_headers = \
        ${bits_srcdir}/stl_iterator_base_types.h \
        ${bits_srcdir}/stl_list.h \
        ${bits_srcdir}/stl_map.h \
+       ${bits_srcdir}/stl_move.h \
        ${bits_srcdir}/stl_multimap.h \
        ${bits_srcdir}/stl_multiset.h \
        ${bits_srcdir}/stl_numeric.h \
@@ -160,43 +146,14 @@ bits_headers = \
 backward_srcdir = ${glibcxx_srcdir}/include/backward
 backward_builddir = ./backward
 backward_headers = \
-       ${backward_srcdir}/complex.h \
-       ${backward_srcdir}/iomanip.h \
-       ${backward_srcdir}/istream.h \
-       ${backward_srcdir}/ostream.h \
-       ${backward_srcdir}/stream.h \
-       ${backward_srcdir}/streambuf.h \
-       ${backward_srcdir}/algo.h \
-       ${backward_srcdir}/algobase.h \
-       ${backward_srcdir}/alloc.h \
-       ${backward_srcdir}/bvector.h \
-       ${backward_srcdir}/defalloc.h \
-       ${backward_srcdir}/deque.h \
-       ${backward_srcdir}/function.h \
-       ${backward_srcdir}/hash_map.h \
-       ${backward_srcdir}/hash_set.h \
+       ${backward_srcdir}/auto_ptr.h \
+       ${backward_srcdir}/backward_warning.h \
+       ${backward_srcdir}/binders.h \
+       ${backward_srcdir}/hash_map \
+       ${backward_srcdir}/hash_set \
+       ${backward_srcdir}/hash_fun.h \
        ${backward_srcdir}/hashtable.h \
-       ${backward_srcdir}/heap.h \
-       ${backward_srcdir}/iostream.h \
-       ${backward_srcdir}/iterator.h \
-       ${backward_srcdir}/list.h \
-       ${backward_srcdir}/map.h \
-       ${backward_srcdir}/multimap.h \
-       ${backward_srcdir}/new.h \
-       ${backward_srcdir}/multiset.h \
-       ${backward_srcdir}/pair.h \
-       ${backward_srcdir}/queue.h \
-       ${backward_srcdir}/rope.h \
-       ${backward_srcdir}/set.h \
-       ${backward_srcdir}/slist.h \
-       ${backward_srcdir}/stack.h \
-       ${backward_srcdir}/tempbuf.h \
-       ${backward_srcdir}/tree.h \
-       ${backward_srcdir}/vector.h \
-       ${backward_srcdir}/fstream.h \
-       ${backward_srcdir}/strstream \
-       ${backward_srcdir}/backward_warning.h
-
+       ${backward_srcdir}/strstream 
 
 pb_srcdir = ${glibcxx_srcdir}/include/ext/pb_ds
 pb_builddir = ./ext/pb_ds
@@ -206,7 +163,6 @@ pb_subdirs = \
        ${pb_builddir}/detail/pairing_heap_ \
        ${pb_builddir}/detail/splay_tree_ \
        ${pb_builddir}/detail/list_update_map_ \
-       ${pb_builddir}/detail/typelist \
        ${pb_builddir}/detail/basic_tree_policy \
        ${pb_builddir}/detail/trie_policy \
        ${pb_builddir}/detail/gp_hash_table_map_ \
@@ -391,7 +347,7 @@ pb_headers4 = \
        ${pb_srcdir}/detail/list_update_policy/counter_lu_policy_imp.hpp \
        ${pb_srcdir}/detail/list_update_policy/mtf_lu_policy_imp.hpp \
        ${pb_srcdir}/detail/list_update_policy/sample_update_policy.hpp \
-       ${pb_srcdir}/detail/map_debug_base.hpp \
+       ${pb_srcdir}/detail/debug_map_base.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/cond_dtor.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/constructors_destructor_fn_imps.hpp \
        ${pb_srcdir}/detail/ov_tree_map_/debug_fn_imps.hpp \
@@ -505,17 +461,6 @@ pb_headers7 = \
        ${pb_srcdir}/detail/trie_policy/sample_trie_node_update.hpp \
        ${pb_srcdir}/detail/trie_policy/string_trie_e_access_traits_imp.hpp \
        ${pb_srcdir}/detail/trie_policy/trie_policy_base.hpp \
-       ${pb_srcdir}/detail/typelist_assoc_container.hpp \
-       ${pb_srcdir}/detail/typelist.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_append.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_apply.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_assoc_container_find.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_at_index.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_contains.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_filter.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_flatten.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_transform.hpp \
-       ${pb_srcdir}/detail/typelist/typelist_typelist_append.hpp \
        ${pb_srcdir}/detail/types_traits.hpp \
        ${pb_srcdir}/detail/type_utils.hpp \
        ${pb_srcdir}/detail/unordered_iterator/const_iterator.hpp \
@@ -524,58 +469,64 @@ pb_headers7 = \
        ${pb_srcdir}/detail/unordered_iterator/point_iterator.hpp 
 
 
-
 ext_srcdir = ${glibcxx_srcdir}/include/ext
 ext_builddir = ./ext 
 ext_headers = \
        ${ext_srcdir}/algorithm \
+       ${ext_srcdir}/atomicity.h \
        ${ext_srcdir}/array_allocator.h \
        ${ext_srcdir}/bitmap_allocator.h \
        ${ext_srcdir}/codecvt_specializations.h \
+       ${ext_srcdir}/concurrence.h \
        ${ext_srcdir}/debug_allocator.h \
+       ${ext_srcdir}/enc_filebuf.h \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
        ${ext_srcdir}/functional \
-       ${ext_srcdir}/hash_map \
-       ${ext_srcdir}/hash_set \
-       ${ext_srcdir}/hash_fun.h \
-       ${ext_srcdir}/hashtable.h \
        ${ext_srcdir}/iterator \
        ${ext_srcdir}/malloc_allocator.h \
        ${ext_srcdir}/memory \
        ${ext_srcdir}/mt_allocator.h \
        ${ext_srcdir}/new_allocator.h \
        ${ext_srcdir}/numeric \
+       ${ext_srcdir}/numeric_traits.h \
        ${ext_srcdir}/pod_char_traits.h \
        ${ext_srcdir}/pool_allocator.h \
        ${ext_srcdir}/rb_tree \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
        ${ext_srcdir}/slist \
+       ${ext_srcdir}/throw_allocator.h \
        ${ext_srcdir}/typelist.h \
+       ${ext_srcdir}/type_traits.h \
        ${ext_srcdir}/rc_string_base.h \
        ${ext_srcdir}/sso_string_base.h \
        ${ext_srcdir}/vstring.h \
        ${ext_srcdir}/vstring.tcc \
        ${ext_srcdir}/vstring_fwd.h \
-       ${ext_srcdir}/vstring_util.h    
+       ${ext_srcdir}/vstring_util.h \
+       ${ext_compat_headers}
 
+ext_compat_headers = \
+       ${backward_srcdir}/hash_set \
+       ${backward_srcdir}/hash_map
 
 tr1_srcdir = ${glibcxx_srcdir}/include/tr1
 tr1_builddir = ./tr1
 tr1_headers = \
        ${tr1_srcdir}/array \
-       ${tr1_srcdir}/bind_repeat.h \
-       ${tr1_srcdir}/bind_iterate.h \
-       ${tr1_srcdir}/boost_shared_ptr.h \
+       ${tr1_srcdir}/bessel_function.tcc \
+       ${tr1_srcdir}/beta_function.tcc \
+       ${tr1_srcdir}/boost_sp_shared_count.h \
+       ${tr1_srcdir}/ccomplex \
        ${tr1_srcdir}/cctype \
        ${tr1_srcdir}/cfenv \
        ${tr1_srcdir}/cfloat \
        ${tr1_srcdir}/cinttypes \
        ${tr1_srcdir}/climits \
        ${tr1_srcdir}/cmath \
-       ${tr1_srcdir}/common.h \
        ${tr1_srcdir}/complex \
+       ${tr1_srcdir}/complex.h \
        ${tr1_srcdir}/cstdarg \
        ${tr1_srcdir}/cstdbool \
        ${tr1_srcdir}/cstdint \
@@ -586,21 +537,27 @@ tr1_headers = \
        ${tr1_srcdir}/ctype.h \
        ${tr1_srcdir}/cwchar \
        ${tr1_srcdir}/cwctype \
+       ${tr1_srcdir}/ell_integral.tcc \
+       ${tr1_srcdir}/exp_integral.tcc \
        ${tr1_srcdir}/fenv.h \
        ${tr1_srcdir}/float.h \
        ${tr1_srcdir}/functional \
-       ${tr1_srcdir}/functional_iterate.h \
-       ${tr1_srcdir}/hashtable \
+       ${tr1_srcdir}/functional_hash.h \
+       ${tr1_srcdir}/gamma.tcc \
+       ${tr1_srcdir}/hypergeometric.tcc \
+       ${tr1_srcdir}/hashtable.h \
        ${tr1_srcdir}/inttypes.h \
        ${tr1_srcdir}/limits.h \
        ${tr1_srcdir}/math.h \
        ${tr1_srcdir}/memory \
-       ${tr1_srcdir}/mu_iterate.h \
+       ${tr1_srcdir}/modified_bessel_func.tcc \
+       ${tr1_srcdir}/poly_hermite.tcc \
+       ${tr1_srcdir}/poly_laguerre.tcc \
+       ${tr1_srcdir}/legendre_function.tcc \
        ${tr1_srcdir}/random \
-       ${tr1_srcdir}/random.tcc \
-       ${tr1_srcdir}/ref_fwd.h \
-       ${tr1_srcdir}/ref_wrap_iterate.h \
-       ${tr1_srcdir}/repeat.h \
+       ${tr1_srcdir}/regex \
+       ${tr1_srcdir}/riemann_zeta.tcc \
+       ${tr1_srcdir}/special_function_util.h \
        ${tr1_srcdir}/stdarg.h \
        ${tr1_srcdir}/stdbool.h \
        ${tr1_srcdir}/stdint.h \
@@ -608,9 +565,7 @@ tr1_headers = \
        ${tr1_srcdir}/stdlib.h \
        ${tr1_srcdir}/tgmath.h \
        ${tr1_srcdir}/tuple \
-       ${tr1_srcdir}/tuple_iterate.h \
        ${tr1_srcdir}/type_traits \
-       ${tr1_srcdir}/type_traits_fwd.h \
        ${tr1_srcdir}/unordered_set \
        ${tr1_srcdir}/unordered_map \
        ${tr1_srcdir}/utility \
@@ -618,56 +573,90 @@ tr1_headers = \
        ${tr1_srcdir}/wctype.h
 
 
-# This is the common subset of files that all three "C" header models use.
+tr1_impl_srcdir = ${glibcxx_srcdir}/include/tr1_impl
+tr1_impl_builddir = ./tr1_impl
+tr1_impl_headers = \
+       ${tr1_impl_srcdir}/array \
+       ${tr1_impl_srcdir}/boost_shared_ptr.h \
+       ${tr1_impl_srcdir}/boost_sp_counted_base.h \
+       ${tr1_impl_srcdir}/cctype \
+       ${tr1_impl_srcdir}/cfenv \
+       ${tr1_impl_srcdir}/cinttypes \
+       ${tr1_impl_srcdir}/cmath \
+       ${tr1_impl_srcdir}/complex \
+       ${tr1_impl_srcdir}/cstdint \
+       ${tr1_impl_srcdir}/cstdio \
+       ${tr1_impl_srcdir}/cstdlib \
+       ${tr1_impl_srcdir}/cwchar \
+       ${tr1_impl_srcdir}/cwctype \
+       ${tr1_impl_srcdir}/functional \
+       ${tr1_impl_srcdir}/functional_hash.h \
+       ${tr1_impl_srcdir}/hashtable \
+       ${tr1_impl_srcdir}/hashtable_policy.h \
+       ${tr1_impl_srcdir}/random \
+       ${tr1_impl_srcdir}/random.tcc \
+       ${tr1_impl_srcdir}/regex \
+       ${tr1_impl_srcdir}/type_traits \
+       ${tr1_impl_srcdir}/unordered_map \
+       ${tr1_impl_srcdir}/unordered_set \
+       ${tr1_impl_srcdir}/utility
+
+
+# This is the common subset of C++ files that all three "C" header models use.
 c_base_srcdir = $(C_INCLUDE_DIR)
 c_base_builddir = .
 c_base_headers = \
-       ${c_base_srcdir}/std_cassert.h \
-       ${c_base_srcdir}/std_cctype.h \
-       ${c_base_srcdir}/std_cerrno.h \
-       ${c_base_srcdir}/std_cfloat.h \
-       ${c_base_srcdir}/std_ciso646.h \
-       ${c_base_srcdir}/std_climits.h \
-       ${c_base_srcdir}/std_clocale.h \
-       ${c_base_srcdir}/std_cmath.h \
-       ${c_base_srcdir}/std_csetjmp.h \
-       ${c_base_srcdir}/std_csignal.h \
-       ${c_base_srcdir}/std_cstdarg.h \
-       ${c_base_srcdir}/std_cstddef.h \
-       ${c_base_srcdir}/std_cstdio.h \
-       ${c_base_srcdir}/std_cstdlib.h \
-       ${c_base_srcdir}/std_cstring.h \
-       ${c_base_srcdir}/std_ctime.h \
-       ${c_base_srcdir}/std_cwchar.h \
-       ${c_base_srcdir}/std_cwctype.h
-c_base_headers_rename = \
-       cassert \
-       cctype \
-       cerrno \
-       cfloat \
-       ciso646 \
-       climits \
-       clocale \
-       cmath \
-       csetjmp \
-       csignal \
-       cstdarg \
-       cstddef \
-       cstdio \
-       cstdlib \
-       cstring \
-       ctime \
-       cwchar \
-       cwctype
+       ${c_base_srcdir}/cassert \
+       ${c_base_srcdir}/ccomplex \
+       ${c_base_srcdir}/cctype \
+       ${c_base_srcdir}/cerrno \
+       ${c_base_srcdir}/cfenv \
+       ${c_base_srcdir}/cfloat \
+       ${c_base_srcdir}/cinttypes \
+       ${c_base_srcdir}/ciso646 \
+       ${c_base_srcdir}/climits \
+       ${c_base_srcdir}/clocale \
+       ${c_base_srcdir}/cmath \
+       ${c_base_srcdir}/csetjmp \
+       ${c_base_srcdir}/csignal \
+       ${c_base_srcdir}/cstdarg \
+       ${c_base_srcdir}/cstdatomic \
+       ${c_base_srcdir}/cstdbool \
+       ${c_base_srcdir}/cstddef \
+       ${c_base_srcdir}/cstdint \
+       ${c_base_srcdir}/cstdio \
+       ${c_base_srcdir}/cstdlib \
+       ${c_base_srcdir}/cstring \
+       ${c_base_srcdir}/ctgmath \
+       ${c_base_srcdir}/ctime \
+       ${c_base_srcdir}/cwchar \
+       ${c_base_srcdir}/cwctype
 
 # "C" compatibility headers.
 c_compatibility_srcdir = ${glibcxx_srcdir}/include/c_compatibility
 c_compatibility_builddir = .
+
+if GLIBCXX_C_HEADERS_C_STD
+c_compatibility_headers = 
+endif
+
+if GLIBCXX_C_HEADERS_C_GLOBAL
+c_compatibility_headers = \
+       ${c_compatibility_srcdir}/complex.h \
+       ${c_compatibility_srcdir}/fenv.h \
+       ${c_compatibility_srcdir}/tgmath.h \
+       ${c_compatibility_srcdir}/stdatomic.h 
+endif
+
+if GLIBCXX_C_HEADERS_C
 c_compatibility_headers = \
        ${c_compatibility_srcdir}/assert.h \
+       ${c_compatibility_srcdir}/complex.h \
        ${c_compatibility_srcdir}/ctype.h \
        ${c_compatibility_srcdir}/errno.h \
+       ${c_compatibility_srcdir}/fenv.h \
        ${c_compatibility_srcdir}/float.h \
+       ${c_compatibility_srcdir}/inttypes.h \
        ${c_compatibility_srcdir}/iso646.h \
        ${c_compatibility_srcdir}/limits.h \
        ${c_compatibility_srcdir}/locale.h \
@@ -675,13 +664,17 @@ c_compatibility_headers = \
        ${c_compatibility_srcdir}/setjmp.h \
        ${c_compatibility_srcdir}/signal.h \
        ${c_compatibility_srcdir}/stdarg.h \
+       ${c_compatibility_srcdir}/stdbool.h \
        ${c_compatibility_srcdir}/stddef.h \
+       ${c_compatibility_srcdir}/stdint.h \
        ${c_compatibility_srcdir}/stdio.h \
        ${c_compatibility_srcdir}/stdlib.h \
        ${c_compatibility_srcdir}/string.h \
+       ${c_compatibility_srcdir}/tgmath.h \
        ${c_compatibility_srcdir}/time.h \
        ${c_compatibility_srcdir}/wchar.h \
        ${c_compatibility_srcdir}/wctype.h
+endif
 
 # Debug mode headers
 debug_srcdir = ${glibcxx_srcdir}/include/debug
@@ -692,18 +685,13 @@ debug_headers = \
        ${debug_srcdir}/deque \
        ${debug_srcdir}/formatter.h \
        ${debug_srcdir}/functions.h \
-       ${debug_srcdir}/hash_map \
-       ${debug_srcdir}/hash_map.h \
-       ${debug_srcdir}/hash_multimap.h \
-       ${debug_srcdir}/hash_multiset.h \
-       ${debug_srcdir}/hash_set \
-       ${debug_srcdir}/hash_set.h \
        ${debug_srcdir}/list \
        ${debug_srcdir}/map \
        ${debug_srcdir}/macros.h \
        ${debug_srcdir}/map.h \
        ${debug_srcdir}/multimap.h \
        ${debug_srcdir}/multiset.h \
+       ${debug_srcdir}/safe_association.h \
        ${debug_srcdir}/safe_base.h \
        ${debug_srcdir}/safe_iterator.h \
        ${debug_srcdir}/safe_iterator.tcc \
@@ -711,12 +699,64 @@ debug_headers = \
        ${debug_srcdir}/set \
        ${debug_srcdir}/set.h \
        ${debug_srcdir}/string \
+       ${debug_srcdir}/unordered_map \
+       ${debug_srcdir}/unordered_set \
        ${debug_srcdir}/vector
 
+# Parallel mode headers
+parallel_srcdir = ${glibcxx_srcdir}/include/parallel
+parallel_builddir = ./parallel
+parallel_headers = \
+        ${parallel_srcdir}/algorithm \
+        ${parallel_srcdir}/algobase.h \
+        ${parallel_srcdir}/algo.h \
+        ${parallel_srcdir}/algorithm \
+        ${parallel_srcdir}/algorithmfwd.h \
+        ${parallel_srcdir}/balanced_quicksort.h \
+        ${parallel_srcdir}/base.h \
+        ${parallel_srcdir}/basic_iterator.h \
+        ${parallel_srcdir}/checkers.h \
+        ${parallel_srcdir}/compatibility.h \
+        ${parallel_srcdir}/compiletime_settings.h \
+        ${parallel_srcdir}/equally_split.h \
+        ${parallel_srcdir}/features.h \
+        ${parallel_srcdir}/find.h \
+        ${parallel_srcdir}/find_selectors.h \
+        ${parallel_srcdir}/for_each.h \
+        ${parallel_srcdir}/for_each_selectors.h \
+        ${parallel_srcdir}/iterator.h \
+        ${parallel_srcdir}/list_partition.h \
+        ${parallel_srcdir}/losertree.h \
+        ${parallel_srcdir}/merge.h \
+        ${parallel_srcdir}/multiseq_selection.h \
+        ${parallel_srcdir}/multiway_merge.h \
+        ${parallel_srcdir}/multiway_mergesort.h \
+        ${parallel_srcdir}/numeric \
+        ${parallel_srcdir}/numericfwd.h \
+        ${parallel_srcdir}/omp_loop.h \
+        ${parallel_srcdir}/omp_loop_static.h \
+        ${parallel_srcdir}/parallel.h \
+        ${parallel_srcdir}/par_loop.h \
+        ${parallel_srcdir}/partial_sum.h \
+        ${parallel_srcdir}/partition.h \
+        ${parallel_srcdir}/queue.h \
+        ${parallel_srcdir}/quicksort.h \
+        ${parallel_srcdir}/random_number.h \
+        ${parallel_srcdir}/random_shuffle.h \
+        ${parallel_srcdir}/search.h \
+        ${parallel_srcdir}/set_operations.h \
+        ${parallel_srcdir}/settings.h \
+        ${parallel_srcdir}/sort.h \
+        ${parallel_srcdir}/tags.h \
+        ${parallel_srcdir}/types.h \
+        ${parallel_srcdir}/unique_copy.h \
+        ${parallel_srcdir}/workstealing.h 
+
+
 # Some of the different "C" header models need extra files.
 # Some "C" header schemes require the "C" compatibility headers.
 # For --enable-cheaders=c_std
-if GLIBCXX_C_HEADERS_C_STD
+if GLIBCXX_C_HEADERS_EXTRA
 c_base_headers_extra = ${c_base_srcdir}/cmath.tcc
 else
 c_base_headers_extra =
@@ -738,7 +778,11 @@ host_headers = \
        ${host_srcdir}/os_defines.h \
        ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h \
        ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h \
-       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h   
+       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h \
+       ${glibcxx_srcdir}/$(ERROR_CONSTANTS_SRCDIR)/error_constants.h \
+       ${glibcxx_srcdir}/include/precompiled/stdc++.h \
+       ${glibcxx_srcdir}/include/precompiled/stdtr1c++.h \
+       ${glibcxx_srcdir}/include/precompiled/extc++.h 
 
 # Non-installed host_header files.
 COMPATIBILITY_H = config/abi/compatibility.h
@@ -790,20 +834,19 @@ pch_output_dirs = \
        ${pch1_output_builddir} ${pch2_output_builddir} ${pch3_output_builddir}
 pch_output_anchors = \
        ${pch1_output_anchor} ${pch2_output_anchor} ${pch3_output_anchor}
-PCHFLAGS=-Winvalid-pch -Wno-deprecated -x c++-header $(CXXFLAGS)
+PCHFLAGS=-Winvalid-pch -x c++-header $(CXXFLAGS)
 if GLIBCXX_BUILD_PCH
 pch_build = ${pch_output}
-pch_install = install-pch
 else
 pch_build =
-pch_install =
 endif
 
 # List of all timestamp files.  By keeping only one copy of this list, both
 # CLEANFILES and all-local are kept up-to-date.
 allstamped = \
-       stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
-       stamp-backward stamp-ext stamp-pb stamp-tr1 stamp-debug stamp-host
+       stamp-std stamp-bits stamp-c_base stamp-c_base_extra \
+       stamp-c_compatibility  stamp-backward stamp-ext stamp-pb \
+       stamp-tr1 stamp-tr1-impl stamp-debug stamp-parallel stamp-host
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -822,10 +865,7 @@ stamp-std: ${std_headers}
          mkdir -p ${std_builddir} ;\
        fi ;\
        if [ ! -f stamp-std ]; then \
-         (cd ${std_builddir} && for h in $?; do \
-           build_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           $(LN_S) $$h ./$${build_name} || true ;\
-         done) ;\
+         (cd ${std_builddir} && $(LN_S) $? . || true) ;\
        fi ;\
        $(STAMP) stamp-std
 
@@ -838,21 +878,24 @@ stamp-bits: ${bits_headers}
        fi ;\
        $(STAMP) stamp-bits
 
-stamp-c_base: stamp-bits ${c_base_headers} ${c_base_headers_extra}
+stamp-c_base: ${c_base_headers} 
        @if [ ! -d "${c_base_builddir}" ]; then \
          mkdir -p ${c_base_builddir} ;\
        fi ;\
        if [ ! -f stamp-c_base ]; then \
-         (cd ${c_base_builddir} && for h in ${c_base_headers}; do \
-           build_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           $(LN_S) $$h ./$${build_name} || true ;\
-         done) ;\
-         if [ ! -z "${c_base_headers_extra}" ]; then \
-         (cd ${bits_builddir} && $(LN_S) ${c_base_headers_extra}  . || true) ;\
-         fi ;\
+         (cd ${c_base_builddir} && $(LN_S) $? . || true) ;\
        fi ;\
        $(STAMP) stamp-c_base
 
+stamp-c_base_extra: ${c_base_headers_extra}
+       @if [ ! -d "${bits_builddir}" ]; then \
+         mkdir -p ${bits_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-c_base_extra ]; then \
+         (cd ${bits_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-c_base_extra
+
 stamp-c_compatibility: ${c_compatibility_headers_extra}
        @if [ ! -d "${c_compatibility_builddir}" ]; then \
          mkdir -p ${c_compatibility_builddir} ;\
@@ -942,6 +985,15 @@ stamp-tr1: ${tr1_headers}
        fi ;\
        $(STAMP) stamp-tr1
 
+stamp-tr1-impl: ${tr1_impl_headers}
+       @if [ ! -d "${tr1_impl_builddir}" ]; then \
+           mkdir -p ${tr1_impl_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-tr1-impl ]; then \
+         (cd ${tr1_impl_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-tr1-impl
+
 stamp-debug: ${debug_headers}
        @if [ ! -d "${debug_builddir}" ]; then \
          mkdir -p ${debug_builddir} ;\
@@ -951,6 +1003,15 @@ stamp-debug: ${debug_headers}
        fi ;\
        $(STAMP) stamp-debug
 
+stamp-parallel: ${parallel_headers}
+       @if [ ! -d "${parallel_builddir}" ]; then \
+         mkdir -p ${parallel_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-parallel ]; then \
+         (cd ${parallel_builddir} && @LN_S@ $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-parallel
+
 stamp-${host_alias}:
        @if [ ! -d ${host_builddir} ]; then \
          mkdir -p ${host_builddir} ;\
@@ -970,8 +1031,7 @@ stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
          $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H) . || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(COMPATIBILITY_H) . || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CMESSAGES_H) messages_members.h || true ;\
-         $(LN_S) ${glibcxx_srcdir}/$(CTIME_H) time_members.h || true ;\
-         $(LN_S) ${glibcxx_srcdir}/$(CCODECVT_H) codecvt_specializations.h || true);\
+         $(LN_S) ${glibcxx_srcdir}/$(CTIME_H) time_members.h || true);\
        fi ;\
        $(STAMP) stamp-host
 
@@ -992,6 +1052,8 @@ stamp-visibility:
        echo 0 > stamp-visibility
 endif
 
+# NB: The non-empty default ldbl_compat works around an AIX sed
+# oddity, see libstdc++/31957 for details.
 ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
                              ${glibcxx_srcdir}/include/bits/c++config \
                              stamp-${host_alias} \
@@ -1001,7 +1063,7 @@ ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
        @date=`cat ${toplevel_srcdir}/gcc/DATESTAMP` ;\
        nsa_version=`cat stamp-namespace-version` ;\
        visibility=`cat stamp-visibility` ;\
-       ldbl_compat='' ;\
+       ldbl_compat='s,g,g,' ;\
        grep "^[        ]*#[    ]*define[       ][      ]*_GLIBCXX_LONG_DOUBLE_COMPAT[  ][      ]*1[    ]*$$" \
        ${CONFIG_HEADER} > /dev/null 2>&1 \
        && ldbl_compat='s,^#undef _GLIBCXX_LONG_DOUBLE_COMPAT$$,#define _GLIBCXX_LONG_DOUBLE_COMPAT 1,' ;\
@@ -1014,10 +1076,11 @@ ${host_builddir}/c++config.h: ${CONFIG_HEADER} \
            -e 's/PACKAGE/_GLIBCXX_PACKAGE/g' \
            -e 's/VERSION/_GLIBCXX_VERSION/g' \
            -e 's/WORDS_/_GLIBCXX_WORDS_/g' \
+           -e 's/ICONV_CONST/_GLIBCXX_ICONV_CONST/g' \
            -e '/[      ]_GLIBCXX_LONG_DOUBLE_COMPAT[   ]/d' \
            < ${CONFIG_HEADER} >> $@ ;\
        echo "" >> $@ ;\
-       echo "#endif // _CXXCONFIG_" >> $@
+       echo "#endif // _GLIBCXX_CXX_CONFIG_H" >> $@
 
 # Host includes for threads
 uppercase = [ABCDEFGHIJKLMNOPQRSTUVWXYZ_]
@@ -1101,7 +1164,7 @@ ${pch3_output}: ${pch3_source} ${pch2_output}
 # the rest are taken from the original source tree.
 
 if GLIBCXX_HOSTED
-install-data-local: install-headers ${pch_install}
+install-data-local: install-headers 
 else
 install-data-local: install-freestanding-headers
 endif
@@ -1168,9 +1231,12 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_builddir}
        for file in ${tr1_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}
+       for file in ${tr1_impl_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_impl_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
-       for file in ${c_base_headers_rename}; do \
-         $(INSTALL_DATA) ${c_base_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done
+       for file in ${c_base_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done
        c_base_headers_extra_install='$(c_base_headers_extra)';\
        for file in $$c_base_headers_extra_install; do \
          $(INSTALL_DATA) $$file $(DESTDIR)${gxx_include_dir}/${bits_builddir}; done
@@ -1178,26 +1244,19 @@ install-headers:
        for file in $$c_compatibility_headers_install; do \
          $(INSTALL_DATA) $$file $(DESTDIR)${gxx_include_dir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${std_builddir}
-       for file in ${std_headers_rename}; do \
-         $(INSTALL_DATA) ${std_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${std_builddir}; done
+       for file in ${std_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${std_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
        for file in ${debug_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir}
+       for file in ${parallel_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${parallel_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${host_installdir}
        for file in ${host_headers} ${host_headers_extra} \
         ${thread_host_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${host_installdir}; done
 
-install-pch:
-       $(mkinstalldirs) $(DESTDIR)${pch1_output_installdir}
-       for file in ${pch1_output_builddir}/*; do \
-         $(INSTALL_DATA) $$file $(DESTDIR)${pch1_output_installdir}; done
-       $(mkinstalldirs) $(DESTDIR)${pch2_output_installdir}
-       for file in ${pch2_output_builddir}/*; do \
-         $(INSTALL_DATA) $$file $(DESTDIR)${pch2_output_installdir}; done
-       $(INSTALL_DATA) ${pch1_output_anchor} $(DESTDIR)${host_installdir}
-       $(INSTALL_DATA) ${pch2_output_anchor} $(DESTDIR)${host_installdir}
-
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = ${pch_output} ${pch_output_anchors}
 
@@ -1210,6 +1269,10 @@ clean-local:
 # developer tries to create them via make in the include build
 # directory. (This is more of an example of how this kind of rule can
 # be made.)
-.PRECIOUS: $(std_headers_rename) $(c_base_headers_rename)
-$(std_headers_rename): ; @:
-$(c_base_headers_rename): ; @:
+.PRECIOUS: $(std_headers) $(c_base_headers) $(tr1_headers) $(tr1_impl_headers)
+          $(ext_headers)
+$(std_headers): ; @:
+$(c_base_headers): ; @:
+$(tr1_headers): ; @:
+$(tr1_impl_headers): ; @:
+$(ext_headers): ; @: