OSDN Git Service

2005-11-05 Paolo Carlini <pcarlini@suse.de>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index f95c1a0..0120543 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -18,7 +18,7 @@
 
 ## You should have received a copy of the GNU General Public License along
 ## with this library; see the file COPYING.  If not, write to the Free
-## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+## Software Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
 ## USA.
 
 include $(top_srcdir)/fragment.am
@@ -92,6 +92,7 @@ bits_srcdir = ${glibcxx_srcdir}/include/bits
 bits_builddir = ./bits
 bits_headers = \
        ${bits_srcdir}/allocator.h \
+       ${bits_srcdir}/atomicity.h \
        ${bits_srcdir}/basic_ios.h \
        ${bits_srcdir}/basic_ios.tcc \
        ${bits_srcdir}/basic_string.h \
@@ -102,7 +103,6 @@ bits_headers = \
        ${bits_srcdir}/concept_check.h \
        ${bits_srcdir}/concurrence.h \
        ${bits_srcdir}/cpp_type_traits.h \
-       ${bits_srcdir}/demangle.h \
        ${bits_srcdir}/deque.tcc \
        ${bits_srcdir}/fstream.tcc \
        ${bits_srcdir}/functexcept.h \
@@ -145,13 +145,11 @@ bits_headers = \
        ${bits_srcdir}/stl_set.h \
        ${bits_srcdir}/stl_stack.h \
        ${bits_srcdir}/stl_tempbuf.h \
-       ${bits_srcdir}/stl_threads.h \
        ${bits_srcdir}/stl_tree.h \
        ${bits_srcdir}/stl_uninitialized.h \
        ${bits_srcdir}/stl_vector.h \
        ${bits_srcdir}/streambuf.tcc \
        ${bits_srcdir}/stringfwd.h \
-       ${bits_srcdir}/type_traits.h \
        ${bits_srcdir}/valarray_array.h \
        ${bits_srcdir}/valarray_array.tcc \
        ${bits_srcdir}/valarray_before.h \
@@ -198,17 +196,265 @@ backward_headers = \
        ${backward_srcdir}/strstream \
        ${backward_srcdir}/backward_warning.h
 
+
+assoc_srcdir = ${glibcxx_srcdir}/include/ext/pb_assoc
+assoc_builddir = ./ext/pb_assoc
+
+assoc_subdirs = \
+       ${assoc_builddir}/detail \
+       ${assoc_builddir}/detail/tree_assoc_cntnr \
+       ${assoc_builddir}/detail/basic_assoc_cntnr \
+       ${assoc_builddir}/detail/splay_tree_ \
+       ${assoc_builddir}/detail/typelist \
+       ${assoc_builddir}/detail/basic_hash_assoc_cntnr \
+       ${assoc_builddir}/detail/cc_ht_map_ \
+       ${assoc_builddir}/detail/gp_ht_map_ \
+       ${assoc_builddir}/detail/tree_policy \
+       ${assoc_builddir}/detail/resize_policy \
+       ${assoc_builddir}/detail/bin_search_tree_ \
+       ${assoc_builddir}/detail/basic_tree_assoc_cntnr \
+       ${assoc_builddir}/detail/cc_hash_assoc_cntnr \
+       ${assoc_builddir}/detail/value_type_adapter \
+       ${assoc_builddir}/detail/lu_policy \
+       ${assoc_builddir}/detail/gp_hash_assoc_cntnr \
+       ${assoc_builddir}/detail/unordered_iterator \
+       ${assoc_builddir}/detail/ov_tree_map_ \
+       ${assoc_builddir}/detail/lu_assoc_cntnr \
+       ${assoc_builddir}/detail/hash_fn \
+       ${assoc_builddir}/detail/eq_fn \
+       ${assoc_builddir}/detail/rb_tree_map_ \
+       ${assoc_builddir}/detail/lu_map_
+
+# The ability for make and the underlying host to deal with this
+# unweildy list as one entire entity is not a sure thing, and may
+# cause build errors. Thus, split one list into five smaller ones.
+assoc_headers1 = \
+       ${assoc_srcdir}/detail/tree_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/type_utils.hpp \
+       ${assoc_srcdir}/detail/order_statistics_imp.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/d_find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/d_insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/extract_key.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/iterators_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/d_extract_key.hpp \
+       ${assoc_srcdir}/detail/basic_assoc_cntnr/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/splay_tree_.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/node.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/splay_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/split_join_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/splay_tree_/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_transform.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_apply.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_filter.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_at_index.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_contains.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_append.hpp \
+       ${assoc_srcdir}/detail/typelist/typelist_typelist_append.hpp \
+       ${assoc_srcdir}/detail/ds_trait_imp.hpp \
+       ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/resize_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/constructors_destructor_fn_imps.hpp 
+
+assoc_headers2 = \
+       ${assoc_srcdir}/detail/cc_ht_map_/resize_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/find_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/erase_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/resize_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/debug_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/policy_access_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/cmp_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/insert_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/find_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/cond_key_dtor_entry_dealtor.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/entry_list_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/constructor_destructor_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/erase_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/cc_ht_map_.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/constructor_destructor_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/standard_policies.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/iterators_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/insert_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/size_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/debug_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_ht_map_/resize_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/resize_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/find_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/erase_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/resize_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/debug_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/policy_access_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/insert_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/find_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/constructor_destructor_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/erase_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/constructor_destructor_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/insert_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/gp_ht_map_.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/iterator_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/debug_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/resize_no_store_hash_fn_imps.hpp 
+
+assoc_headers3 = \
+       ${assoc_srcdir}/detail/tree_policy/order_statistics_imp.hpp \
+       ${assoc_srcdir}/detail/tree_policy/null_node_updator_imp.hpp \
+       ${assoc_srcdir}/detail/types_traits.hpp \
+       ${assoc_srcdir}/detail/mapping_level_imp.hpp \
+       ${assoc_srcdir}/detail/map_debug_base.hpp \
+       ${assoc_srcdir}/detail/resize_policy/ht_prime_size_policy_imp.hpp \
+       ${assoc_srcdir}/detail/resize_policy/hash_load_check_resize_trigger_imp.hpp \
+       ${assoc_srcdir}/detail/resize_policy/hash_prime_size_policy_imp.hpp \
+       ${assoc_srcdir}/detail/resize_policy/size_base.hpp \
+       ${assoc_srcdir}/detail/resize_policy/cc_hash_max_collision_resize_trigger_imp.hpp \
+       ${assoc_srcdir}/detail/resize_policy/hash_exponential_size_policy_imp.hpp \
+       ${assoc_srcdir}/detail/resize_policy/hash_standard_resize_policy_imp.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/cond_dtor_entry_dealtor.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/find_iterators.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/cond_key_dtor_entry_dealtor.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/node_iterators.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/bin_search_tree_.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/split_join_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/rotate_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/iterators_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/r_erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/bin_search_tree_/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/r_range_iteration_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/policy_access_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/split_join_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/r_erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/range_iteration_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/node_iteration_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp 
+
+assoc_headers4 = \
+       ${assoc_srcdir}/detail/assoc_cntnr_base.hpp \
+       ${assoc_srcdir}/detail/ms_category_imp.hpp \
+       ${assoc_srcdir}/detail/hash_types_traits.hpp \
+       ${assoc_srcdir}/detail/typelist.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/invalidation_guarantee_selector.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/iterator.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/constructor_destructor_and_related.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/value_type_traits.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/ref_pair.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/it_value_type_traits.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/erase_if_pred.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/value_type_adapter.hpp \
+       ${assoc_srcdir}/detail/value_type_adapter/iterator_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_policy/mtf_lu_policy_imp.hpp \
+       ${assoc_srcdir}/detail/lu_policy/counter_lu_policy_imp.hpp \
+       ${assoc_srcdir}/detail/lu_policy/counter_lu_metadata_imp.hpp \
+       ${assoc_srcdir}/detail/gp_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/unordered_iterator/find_iterator.hpp \
+       ${assoc_srcdir}/detail/unordered_iterator/iterator.hpp \
+       ${assoc_srcdir}/detail/unordered_iterator/const_iterator.hpp \
+       ${assoc_srcdir}/detail/unordered_iterator/const_find_iterator.hpp \
+       ${assoc_srcdir}/detail/standard_policies.hpp \
+       ${assoc_srcdir}/detail/standard_sizes.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/ov_tree_map_.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/node_iterators.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/split_join_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/cond_dtor.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/iterators_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/constructors_destructor_fn_imps.hpp
+
+assoc_headers5 = \
+       ${assoc_srcdir}/detail/lu_assoc_cntnr/policy_access_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/hash_fn/linear_probe_fn_imp.hpp \
+       ${assoc_srcdir}/detail/hash_fn/mod_based_range_hashing.hpp \
+       ${assoc_srcdir}/detail/hash_fn/direct_mod_range_hashing_imp.hpp \
+       ${assoc_srcdir}/detail/hash_fn/probe_fn_base.hpp \
+       ${assoc_srcdir}/detail/hash_fn/ranged_probe_fn.hpp \
+       ${assoc_srcdir}/detail/hash_fn/quadratic_probe_fn_imp.hpp \
+       ${assoc_srcdir}/detail/hash_fn/direct_mask_range_hashing_imp.hpp \
+       ${assoc_srcdir}/detail/hash_fn/ranged_hash_fn.hpp \
+       ${assoc_srcdir}/detail/hash_fn/mask_based_range_hashing.hpp \
+       ${assoc_srcdir}/detail/eq_fn/eq_by_less.hpp \
+       ${assoc_srcdir}/detail/eq_fn/hash_eq_fn.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/node.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/split_join_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/rb_tree_.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/rb_tree_map_/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/lu_map_.hpp \
+       ${assoc_srcdir}/detail/lu_map_/erase_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/policy_access_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/insert_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/find_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/info_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/iterators_fn_imps.hpp \
+       ${assoc_srcdir}/detail/lu_map_/debug_fn_imps.hpp \
+       ${assoc_srcdir}/detail/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ms_trait_imp.hpp \
+       ${assoc_srcdir}/detail/cond_dealtor.hpp \
+       ${assoc_srcdir}/hash_policy.hpp \
+       ${assoc_srcdir}/trivial_iterator_def.hpp \
+       ${assoc_srcdir}/ds_trait.hpp \
+       ${assoc_srcdir}/exception.hpp \
+       ${assoc_srcdir}/tree_policy.hpp \
+       ${assoc_srcdir}/lu_policy.hpp \
+       ${assoc_srcdir}/ms_trait.hpp \
+       ${assoc_srcdir}/assoc_cntnr.hpp \
+       ${assoc_srcdir}/data_type.hpp 
+
+
 ext_srcdir = ${glibcxx_srcdir}/include/ext
-ext_builddir = ./ext
+ext_builddir = ./ext 
 ext_headers = \
        ${ext_srcdir}/algorithm \
+       ${ext_srcdir}/array_allocator.h \
+       ${ext_srcdir}/bitmap_allocator.h \
+       ${ext_srcdir}/codecvt_specializations.h \
        ${ext_srcdir}/debug_allocator.h \
-       ${ext_srcdir}/enc_filebuf.h \
        ${ext_srcdir}/stdio_filebuf.h \
        ${ext_srcdir}/stdio_sync_filebuf.h \
        ${ext_srcdir}/functional \
        ${ext_srcdir}/hash_map \
        ${ext_srcdir}/hash_set \
+       ${ext_srcdir}/hash_fun.h \
+       ${ext_srcdir}/hashtable.h \
        ${ext_srcdir}/iterator \
        ${ext_srcdir}/malloc_allocator.h \
        ${ext_srcdir}/memory \
@@ -221,8 +467,38 @@ ext_headers = \
        ${ext_srcdir}/rope \
        ${ext_srcdir}/ropeimpl.h \
        ${ext_srcdir}/slist \
-       ${ext_srcdir}/hash_fun.h \
-       ${ext_srcdir}/hashtable.h
+       ${ext_srcdir}/typelist.h \
+       ${ext_srcdir}/rc_string_base.h \
+       ${ext_srcdir}/sso_string_base.h \
+       ${ext_srcdir}/vstring.h \
+       ${ext_srcdir}/vstring.tcc \
+       ${ext_srcdir}/vstring_fwd.h \
+       ${ext_srcdir}/vstring_util.h    
+
+
+tr1_srcdir = ${glibcxx_srcdir}/include/tr1
+tr1_builddir = ./tr1
+tr1_headers = \
+       ${tr1_srcdir}/array \
+       ${tr1_srcdir}/bind_repeat.h \
+       ${tr1_srcdir}/bind_iterate.h \
+       ${tr1_srcdir}/boost_shared_ptr.h \
+       ${tr1_srcdir}/mu_iterate.h \
+       ${tr1_srcdir}/functional \
+       ${tr1_srcdir}/functional_iterate.h \
+       ${tr1_srcdir}/memory \
+       ${tr1_srcdir}/ref_fwd.h \
+       ${tr1_srcdir}/ref_wrap_iterate.h \
+       ${tr1_srcdir}/repeat.h \
+       ${tr1_srcdir}/tuple \
+       ${tr1_srcdir}/tuple_iterate.h \
+       ${tr1_srcdir}/utility \
+       ${tr1_srcdir}/type_traits \
+       ${tr1_srcdir}/type_traits_fwd.h \
+       ${tr1_srcdir}/hashtable \
+       ${tr1_srcdir}/unordered_set \
+       ${tr1_srcdir}/unordered_map
+
 
 # This is the common subset of files that all three "C" header models use.
 c_base_srcdir = $(C_INCLUDE_DIR)
@@ -297,6 +573,7 @@ debug_headers = \
        ${debug_srcdir}/debug.h \
        ${debug_srcdir}/deque \
        ${debug_srcdir}/formatter.h \
+       ${debug_srcdir}/functions.h \
        ${debug_srcdir}/hash_map \
        ${debug_srcdir}/hash_map.h \
        ${debug_srcdir}/hash_multimap.h \
@@ -305,6 +582,7 @@ debug_headers = \
        ${debug_srcdir}/hash_set.h \
        ${debug_srcdir}/list \
        ${debug_srcdir}/map \
+       ${debug_srcdir}/macros.h \
        ${debug_srcdir}/map.h \
        ${debug_srcdir}/multimap.h \
        ${debug_srcdir}/multiset.h \
@@ -339,26 +617,31 @@ host_headers = \
        ${host_srcdir}/ctype_inline.h \
        ${host_srcdir}/ctype_noninline.h \
        ${host_srcdir}/os_defines.h \
-       ${glibcxx_srcdir}/$(ATOMICITY_INC_SRCDIR)/atomicity.h 
+       ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h \
+       ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h \
+       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h   
 
 # Non-installed host_header files.
+COMPATIBILITY_H = config/abi/compatibility.h
 host_headers_noinst = \
-       ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H)
+       ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H) \
+       ${glibcxx_srcdir}/$(COMPATIBILITY_H)
 
 # These host_headers_extra files are all built with ad hoc naming rules.
 host_headers_extra = \
        ${host_builddir}/basic_file.h \
        ${host_builddir}/c++config.h \
+       ${host_builddir}/c++allocator.h \
        ${host_builddir}/c++io.h \
        ${host_builddir}/c++locale.h \
        ${host_builddir}/messages_members.h \
-       ${host_builddir}/time_members.h \
-       ${host_builddir}/codecvt_specializations.h
+       ${host_builddir}/time_members.h 
 
 thread_host_headers = \
        ${host_builddir}/gthr.h \
        ${host_builddir}/gthr-single.h \
        ${host_builddir}/gthr-posix.h \
+       ${host_builddir}/gthr-tpf.h \
        ${host_builddir}/gthr-default.h
 
 pch_input = ${host_builddir}/stdc++.h
@@ -377,7 +660,7 @@ endif
 # CLEANFILES and all-local are kept up-to-date.
 allstamped = \
        stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
-       stamp-backward stamp-ext stamp-debug stamp-host
+       stamp-backward stamp-ext stamp-assoc stamp-tr1 stamp-debug stamp-host
 
 # List of all files that are created by explicit building, editing, or
 # catenation.
@@ -397,8 +680,8 @@ stamp-std: ${std_headers}
        fi ;\
        if [ ! -f stamp-std ]; then \
          (cd ${std_builddir} && for h in $?; do \
-           official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           $(LN_S) $$h ./$${official_name} || true ;\
+           build_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
+           $(LN_S) $$h ./$${build_name} || true ;\
          done) ;\
        fi ;\
        $(STAMP) stamp-std
@@ -418,8 +701,8 @@ stamp-c_base: stamp-bits ${c_base_headers} ${c_base_headers_extra}
        fi ;\
        if [ ! -f stamp-c_base ]; then \
          (cd ${c_base_builddir} && for h in ${c_base_headers}; do \
-           official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
-           $(LN_S) $$h ./$${official_name} || true ;\
+           build_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
+           $(LN_S) $$h ./$${build_name} || true ;\
          done) ;\
          if [ ! -z "${c_base_headers_extra}" ]; then \
          (cd ${bits_builddir} && $(LN_S) ${c_base_headers_extra}  . || true) ;\
@@ -456,6 +739,54 @@ stamp-ext: ${ext_headers}
        fi ;\
        $(STAMP) stamp-ext
 
+# Have to deal with nested include directories, gah! Strip off source
+# directory before making the link.
+# XXX check  ${assoc_headers}
+stamp-assoc:
+       @if [ ! -d "${assoc_builddir}" ]; then \
+           mkdir -p ${assoc_subdirs} ;\
+       fi 
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers1}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers2}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers3}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers4}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers5}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       $(STAMP) stamp-assoc
+
+stamp-tr1: ${tr1_headers}
+       @if [ ! -d "${tr1_builddir}" ]; then \
+           mkdir -p ${tr1_builddir} ;\
+       fi ;\
+       if [ ! -f stamp-tr1 ]; then \
+         (cd ${tr1_builddir} && $(LN_S) $? . || true) ;\
+       fi ;\
+       $(STAMP) stamp-tr1
+
 stamp-debug: ${debug_headers}
        @if [ ! -d "${debug_builddir}" ]; then \
          mkdir -p ${debug_builddir} ;\
@@ -478,9 +809,11 @@ stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
          (cd ${host_builddir} ;\
          $(LN_S) ${host_headers} . || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(BASIC_FILE_H) basic_file.h || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(ALLOCATOR_H) c++allocator.h || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CSTDIO_H) c++io.h || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_H) c++locale.h || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_INTERNAL_H) . || true ;\
+         $(LN_S) ${glibcxx_srcdir}/$(COMPATIBILITY_H) . || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CMESSAGES_H) messages_members.h || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CTIME_H) time_members.h || true ;\
          $(LN_S) ${glibcxx_srcdir}/$(CCODECVT_H) codecvt_specializations.h || true);\
@@ -490,8 +823,11 @@ stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
 # Host includes dynamic.
 ${host_builddir}/c++config.h: ${top_builddir}/config.h \
                                ${glibcxx_srcdir}/include/bits/c++config \
-                               stamp-${host_alias}
+                               stamp-${host_alias} \
+                               ${toplevel_srcdir}/gcc/DATESTAMP
        @cat ${glibcxx_srcdir}/include/bits/c++config > $@ ;\
+       sed -e 's/^/#define __GLIBCXX__ /' \
+            < ${toplevel_srcdir}/gcc/DATESTAMP >> $@ ;\
        sed -e 's/HAVE_/_GLIBCXX_HAVE_/g' \
            -e 's/PACKAGE/_GLIBCXX_PACKAGE/g' \
            -e 's/VERSION/_GLIBCXX_VERSION/g' \
@@ -503,7 +839,9 @@ ${host_builddir}/c++config.h: ${top_builddir}/config.h \
 uppercase = [ABCDEFGHIJKLMNOPQRSTUVWXYZ_]
 
 ${host_builddir}/gthr.h: ${toplevel_srcdir}/gcc/gthr.h stamp-${host_alias}
-       sed -e '/^#/s/\(${uppercase}${uppercase}*\)/_GLIBCXX_\1/g' \
+       sed -e '/^#pragma/b' \
+           -e '/^#/s/\(${uppercase}${uppercase}*\)/_GLIBCXX_\1/g' \
+           -e 's/_GLIBCXX_SUPPORTS_WEAK/__GXX_WEAK__/g' \
            -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
            < ${toplevel_srcdir}/gcc/gthr.h > $@
 
@@ -517,14 +855,24 @@ ${host_builddir}/gthr-posix.h: ${toplevel_srcdir}/gcc/gthr-posix.h \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
-           -e 's/\(${uppercase}*WEAK\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
            < ${toplevel_srcdir}/gcc/gthr-posix.h > $@
 
+${host_builddir}/gthr-tpf.h: ${toplevel_srcdir}/gcc/gthr-tpf.h \
+                                  stamp-${host_alias}
+       sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
+           -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
+           < ${toplevel_srcdir}/gcc/gthr-tpf.h > $@
+
 ${host_builddir}/gthr-default.h: ${toplevel_srcdir}/gcc/${glibcxx_thread_h} \
                                   stamp-${host_alias}
        sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
            -e 's/\(GCC${uppercase}*_H\)/_GLIBCXX_\1/g' \
-           -e 's/\(${uppercase}*WEAK\)/_GLIBCXX_\1/g' \
+           -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
+           -e 's/\(${uppercase}*USE_WEAK\)/_GLIBCXX_\1/g' \
            -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
            < ${toplevel_srcdir}/gcc/${glibcxx_thread_h} > $@
 
@@ -534,8 +882,8 @@ ${pch_input}: ${allstamped} ${host_builddir}/c++config.h ${pch_source}
        if [ ! -d "${pch_output_builddir}" ]; then \
          mkdir -p ${pch_output_builddir}; \
        fi; \
-       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O0 -g -o ${pch_output_builddir}/O0g; \
-       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O2 -g -o ${pch_output_builddir}/O2g;
+       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O0 -g -o ${pch_output_builddir}/O0g.gch; \
+       $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) ${pch_source} -O2 -g -o ${pch_output_builddir}/O2g.gch;
 
 # For robustness sake (in light of junk files or in-source
 # configuration), copy from the build or source tree to the install
@@ -580,6 +928,32 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${ext_builddir}
        for file in ${ext_headers}; do \
          $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${ext_builddir}; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${assoc_builddir}
+       for dir in ${assoc_subdirs}; do \
+         $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/$${dir} ; done
+       for file in ${assoc_headers1}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers2}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers3}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers4}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers5}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${tr1_builddir}
+       for file in ${tr1_headers}; do \
+         $(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${tr1_builddir}; done
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${c_base_builddir}
        for file in ${c_base_headers_rename}; do \
          $(INSTALL_DATA) ${c_base_builddir}/$${file} $(DESTDIR)${gxx_include_dir}/${c_base_builddir}; done