OSDN Git Service

2005-11-05 Paolo Carlini <pcarlini@suse.de>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index e4fa84d..0120543 100644 (file)
@@ -225,7 +225,10 @@ assoc_subdirs = \
        ${assoc_builddir}/detail/rb_tree_map_ \
        ${assoc_builddir}/detail/lu_map_
 
-assoc_headers = \
+# The ability for make and the underlying host to deal with this
+# unweildy list as one entire entity is not a sure thing, and may
+# cause build errors. Thus, split one list into five smaller ones.
+assoc_headers1 = \
        ${assoc_srcdir}/detail/tree_assoc_cntnr/constructor_destructor_fn_imps.hpp \
        ${assoc_srcdir}/detail/type_utils.hpp \
        ${assoc_srcdir}/detail/order_statistics_imp.hpp \
@@ -259,7 +262,9 @@ assoc_headers = \
        ${assoc_srcdir}/detail/ds_trait_imp.hpp \
        ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/resize_fn_imps.hpp \
        ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp \
-       ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/basic_hash_assoc_cntnr/constructors_destructor_fn_imps.hpp 
+
+assoc_headers2 = \
        ${assoc_srcdir}/detail/cc_ht_map_/resize_store_hash_fn_imps.hpp \
        ${assoc_srcdir}/detail/cc_ht_map_/find_store_hash_fn_imps.hpp \
        ${assoc_srcdir}/detail/cc_ht_map_/erase_no_store_hash_fn_imps.hpp \
@@ -308,7 +313,9 @@ assoc_headers = \
        ${assoc_srcdir}/detail/gp_ht_map_/gp_ht_map_.hpp \
        ${assoc_srcdir}/detail/gp_ht_map_/iterator_fn_imps.hpp \
        ${assoc_srcdir}/detail/gp_ht_map_/debug_no_store_hash_fn_imps.hpp \
-       ${assoc_srcdir}/detail/gp_ht_map_/resize_no_store_hash_fn_imps.hpp \
+       ${assoc_srcdir}/detail/gp_ht_map_/resize_no_store_hash_fn_imps.hpp 
+
+assoc_headers3 = \
        ${assoc_srcdir}/detail/tree_policy/order_statistics_imp.hpp \
        ${assoc_srcdir}/detail/tree_policy/null_node_updator_imp.hpp \
        ${assoc_srcdir}/detail/types_traits.hpp \
@@ -345,7 +352,9 @@ assoc_headers = \
        ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/range_iteration_fn_imps.hpp \
        ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/constructors_destructor_fn_imps.hpp \
        ${assoc_srcdir}/detail/basic_tree_assoc_cntnr/node_iteration_fn_imps.hpp \
-       ${assoc_srcdir}/detail/cc_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/cc_hash_assoc_cntnr/constructor_destructor_fn_imps.hpp 
+
+assoc_headers4 = \
        ${assoc_srcdir}/detail/assoc_cntnr_base.hpp \
        ${assoc_srcdir}/detail/ms_category_imp.hpp \
        ${assoc_srcdir}/detail/hash_types_traits.hpp \
@@ -383,7 +392,9 @@ assoc_headers = \
        ${assoc_srcdir}/detail/ov_tree_map_/info_fn_imps.hpp \
        ${assoc_srcdir}/detail/ov_tree_map_/iterators_fn_imps.hpp \
        ${assoc_srcdir}/detail/ov_tree_map_/debug_fn_imps.hpp \
-       ${assoc_srcdir}/detail/ov_tree_map_/constructors_destructor_fn_imps.hpp \
+       ${assoc_srcdir}/detail/ov_tree_map_/constructors_destructor_fn_imps.hpp
+
+assoc_headers5 = \
        ${assoc_srcdir}/detail/lu_assoc_cntnr/policy_access_fn_imps.hpp \
        ${assoc_srcdir}/detail/lu_assoc_cntnr/constructor_destructor_fn_imps.hpp \
        ${assoc_srcdir}/detail/hash_fn/linear_probe_fn_imp.hpp \
@@ -607,7 +618,8 @@ host_headers = \
        ${host_srcdir}/ctype_noninline.h \
        ${host_srcdir}/os_defines.h \
        ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h \
-       ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h
+       ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h \
+       ${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h   
 
 # Non-installed host_header files.
 COMPATIBILITY_H = config/abi/compatibility.h
@@ -729,16 +741,41 @@ stamp-ext: ${ext_headers}
 
 # Have to deal with nested include directories, gah! Strip off source
 # directory before making the link.
-stamp-assoc: ${assoc_headers}
+# XXX check  ${assoc_headers}
+stamp-assoc:
        @if [ ! -d "${assoc_builddir}" ]; then \
            mkdir -p ${assoc_subdirs} ;\
-       fi ;\
-       if [ ! -f stamp-assoc ]; then \
-         (cd ${assoc_builddir} && for h in $?; do \
-           build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
-           $(LN_S) $$h $${build_name} || true ;\
-         done) ;\
-       fi ;\
+       fi 
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers1}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers2}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers3}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers4}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
+       @if [ ! -f stamp-assoc ]; then \
+           cd ${assoc_builddir} && for h in ${assoc_headers5}; do \
+               build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+               $(LN_S) $$h $${build_name} || true ;\
+             done ;\
+       fi
        $(STAMP) stamp-assoc
 
 stamp-tr1: ${tr1_headers}
@@ -894,7 +931,23 @@ install-headers:
        $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${assoc_builddir}
        for dir in ${assoc_subdirs}; do \
          $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/$${dir} ; done
-       for file in ${assoc_headers}; do \
+       for file in ${assoc_headers1}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers2}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers3}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers4}; do \
+         install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
+         relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
+         $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done
+       for file in ${assoc_headers5}; do \
          install_base=$(DESTDIR)${gxx_include_dir}/${assoc_builddir} ; \
          relative_name=`echo $$file | sed -e "s|${assoc_srcdir}|.|g"` ;\
          $(INSTALL_DATA) $${file} $${install_base}/$${relative_name} ; done