OSDN Git Service

* configure.ac (gcc_cv_ld_eh_gc_sections): Redirect objdump errors
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 674782b..c7a22aa 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008, 2009
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -8,7 +9,7 @@
 ## This file is part of the GNU ISO C++ Library.  This library is free
 ## software; you can redistribute it and/or modify it under the
 ## terms of the GNU General Public License as published by the
-## Free Software Foundation; either version 2, or (at your option)
+## Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 
 ## This library is distributed in the hope that it will be useful,
 ## GNU General Public License for more details.
 
 ## You should have received a copy of the GNU General Public License along
-## with this library; see the file COPYING.  If not, write to the Free
-## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
-## USA.
+## with this library; see the file COPYING3.  If not see
+## <http://www.gnu.org/licenses/>.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE = v3
-gxx_include_dir=$(includedir)/g++
+if GLIBCXX_HOSTED
+  hosted_source = doc src po testsuite
+endif
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+## Note that python must come after src.
+SUBDIRS = include libsupc++ $(hosted_source) python
 
-SUBDIRS = math libio src
+ACLOCAL_AMFLAGS = -I . -I .. -I ../config
 
-check:  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 0 $(top_builddir) $(top_srcdir)
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
 
-check-install: $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 1 $(top_builddir) $(top_srcdir) $(prefix)
-
-#all-local:  stamp-rebuild
-
-# This has already been sanity-checked by configure to a certain extent
-#stamp-rebuild:  $(top_builddir)/config.status
-#      if test "$(GCC_OBJDIR)" != "no"; then \
-#      (cd "$(GCC_OBJDIR)/gcc" && \
-#       if test -f libgcc2.ready ; then \
-#         rm -f libgcc2.ready libgcc.a libgcc2.a ; \
-#         $(MAKE) libgcc2.a TARGET_LIBGCC2_CFLAGS='@NAMESPACES@' ; \
-#         $(MAKE) libgcc.a ; \
-#       else \
-#         echo '** There does not appear to be a previously-built' ; \
-#         echo '** library here.  Please see' ; \
-#         echo '** <http://sourceware.cygnus.com/libstdc++/install.html>' ; \
-#         echo '** In particular, the "Building and Installing' ; \
-#         echo '** the library (without GCC sources)" section.' ; \
-#         exit 1 ; \
-#       fi \
-#      ) \
-#      fi
-#      touch stamp-rebuild
+doc-%:
+       cd doc && $(MAKE) $@
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
+# All the machinations with string instantiations messes up the
+# automake-generated TAGS rule. Make a simple one here.
+TAGS: tags-recursive $(LISP)
 
 # Work around what appears to be a GNU make bug handling MAKEFLAGS
 # values defined in terms of make variables, as is the case for CC and
@@ -117,8 +69,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -126,22 +76,16 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
-       "LIBCFLAGS=$(LIBCFLAGS)" \
-       "PICFLAG=$(PICFLAG)" \
        "RANLIB=$(RANLIB)" \
        "NM=$(NM)" \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
-       "DESTDIR=$(DESTDIR)"
-
-
-
-
-
-
+       "DESTDIR=$(DESTDIR)" \
+       "WERROR=$(WERROR)"
 
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)