OSDN Git Service

2005-04-05 Kelley Cook <kcook@gcc.gnu.org>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index ac3cda6..bccacb6 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997, 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-SUBDIRS = include libio libmath libsupc++ src po testsuite 
+if GLIBCXX_HOSTED
+  hosted_source = libmath src po testsuite
+endif
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+SUBDIRS = include libsupc++ $(hosted_source)
 
-mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
+ACLOCAL_AMFLAGS = -I . -I .. -I ../config
 
-# These two special 'check-script' rules use the bash script 'mkcheck'
-# to do testing. This script is not as portable as the dejagnu test
-# harness, and is thus off by default. It does produce interesting
-# output however, including various performance analysis items like
-# compile time, execution time, and binary size.
-check-script: $(top_builddir)/mkcheck
-       -(chmod + $(top_builddir)/mkcheck; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; \
-         @glibcpp_builddir@/mkcheck 0)
-
-check-script-install: $(top_builddir)/mkcheck
-       -(chmod + $(top_builddir)/mkcheck; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; \
-         @glibcpp_builddir@/mkcheck 1)
-
-# These two rules might seem messy, but are hella worth it.
+# These rules are messy, but are hella worth it.
 doxygen:
-       -(srcdir=`cd ${top_srcdir}; pwd`; \
-         outdir=`pwd`; \
-         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
-                   --mode=user $${srcdir} $${outdir})
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=user $${srcdir} $${builddir})
 
 doxygen-maint:
-       -(srcdir=`cd ${top_srcdir}; pwd`; \
-         outdir=`pwd`; \
-         ${srcdir}/docs/doxygen/run_doxygen --mode=maint $${srcdir} $${outdir})
-
-.PHONY: doxygen doxygen-maint
-
-# Multilib support.
-MAKEOVERRIDES=
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=maint $${srcdir} $${builddir})
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
+doxygen-man:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=man $${srcdir} $${builddir})
 
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
+.PHONY: doxygen doxygen-maint doxygen-man
 
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
 
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
+# Multilib support.
+MAKEOVERRIDES=
 
 # All the machinations with string instantiations messes up the
 # automake-generated TAGS rule. Make a simple one here.
@@ -128,14 +97,16 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
        "LD=$(LD)" \
-       "LIBCFLAGS=$(LIBCFLAGS)" \
-       "PICFLAG=$(PICFLAG)" \
        "RANLIB=$(RANLIB)" \
        "NM=$(NM)" \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)" 
+       "WERROR=$(WERROR)"
+
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)