OSDN Git Service

2005-04-05 Kelley Cook <kcook@gcc.gnu.org>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index a4362ac..bccacb6 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE = v3
-gxx_include_dir=$(includedir)/g++
+if GLIBCXX_HOSTED
+  hosted_source = libmath src po testsuite
+endif
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+SUBDIRS = include libsupc++ $(hosted_source)
 
-SUBDIRS = libio libmath libsupc++ src
+ACLOCAL_AMFLAGS = -I . -I .. -I ../config
 
+# These rules are messy, but are hella worth it.
+doxygen:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=user $${srcdir} $${builddir})
 
-# Compile flags that should be constant throughout the build, both for
-# SUBDIRS and for libstdc++-v3 in general.
-# Optimization flags that are probably a good idea for thrill-seekers. Just
-# uncomment the lines below and make, everything else is ready to go... 
-# OPTIMIZE_CXXFLAGS = -O3 -fstrict-aliasing -fvtable-gc 
-OPTIMIZE_CXXFLAGS = 
+doxygen-maint:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=maint $${srcdir} $${builddir})
 
-# Warning flags to use.
-WARN_CXXFLAGS = \
-       -Wall -Wno-format -W -Wwrite-strings -Winline \
-       $(WERROR) @WFMT_FLAGS@
+doxygen-man:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --host_alias=${host_alias} \
+                   --mode=man $${srcdir} $${builddir})
 
-# These bits are all figured out from configure. Look in acinclude.m4
-# or configure.in to see how they are set.
-# NB: DEBUGFLAGS have to be at the end so that -O2 can be overridden.
-CONFIG_CXXFLAGS = \
-       @EXTRA_CXX_FLAGS@ \
-       @SECTION_FLAGS@ @CSHADOWFLAGS@ @DEBUG_FLAGS@ 
+.PHONY: doxygen doxygen-maint doxygen-man
 
-
-# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check:  $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 0 `pwd` $(top_srcdir)
-
-check-install: $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 1 `pwd` $(top_srcdir) $(prefix)
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
-
 # All the machinations with string instantiations messes up the
 # automake-generated TAGS rule. Make a simple one here.
 TAGS: tags-recursive $(LISP)
@@ -125,8 +90,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -134,25 +97,16 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
-       "LIBCFLAGS=$(LIBCFLAGS)" \
-       "PICFLAG=$(PICFLAG)" \
        "RANLIB=$(RANLIB)" \
        "NM=$(NM)" \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)" \
-       "OPTIMIZE_CXXFLAGS=$(OPTIMIZE_CXXFLAGS)" \
-       "WARN_CXXFLAGS=$(WARN_CXXFLAGS)" \
-       "CONFIG_CXXFLAGS=$(CONFIG_CXXFLAGS)" 
-
-
-
-
-
+       "WERROR=$(WERROR)"
 
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)