OSDN Git Service

* Makefile.am (install-html, install-pdf): Add dummy targets.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index aab3dc1..7ab27f0 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 
 ## You should have received a copy of the GNU General Public License along
 ## with this library; see the file COPYING.  If not, write to the Free
-## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+## Software Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-SUBDIRS = libio libmath libsupc++ src
+if GLIBCXX_HOSTED
+  hosted_source = libmath doc src po testsuite
+endif
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+SUBDIRS = include libsupc++ $(hosted_source)
 
-# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check: $(top_builddir)/mkcheck
-       -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
+ACLOCAL_AMFLAGS = -I . -I .. -I ../config
 
-check-install: $(top_builddir)/mkcheck
-       -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; \
-         $${builddir}/mkcheck 1 $${builddir} $${srcdir} $(prefix))
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
+
+doc-%:
+       cd doc && $(MAKE) $@
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
-
 # All the machinations with string instantiations messes up the
 # automake-generated TAGS rule. Make a simple one here.
 TAGS: tags-recursive $(LISP)
@@ -104,8 +69,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -113,16 +76,20 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
-       "LIBCFLAGS=$(LIBCFLAGS)" \
-       "PICFLAG=$(PICFLAG)" \
        "RANLIB=$(RANLIB)" \
        "NM=$(NM)" \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)" 
+       "WERROR=$(WERROR)"
+
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)
+
+.PHONY: install-html install-pdf
+install-html:
+install-pdf: