OSDN Git Service

2006-06-21 Frank Ch. Eigler <fche@redhat.com>
[pf3gnuchains/gcc-fork.git] / libmudflap / configure.ac
index 039ff4e..ff356f2 100644 (file)
@@ -1,10 +1,11 @@
 # Process this file with autoconf to produce a configure script, like so:
-# aclocal && autoconf && autoheader && automake
+# aclocal -I .. -I ../config && autoconf && autoheader && automake
 
 AC_PREREQ(2.59)
 AC_INIT(libmudflap, 1.0)
 AC_CONFIG_SRCDIR(mf-runtime.c)
 AC_CANONICAL_SYSTEM
+ACX_NONCANONICAL_TARGET
 
 AM_INIT_AUTOMAKE
 
@@ -175,6 +176,9 @@ esac
 AC_SUBST(toolexecdir)
 AC_SUBST(toolexeclibdir)
 
+includedir=${toolexecdir}/include
+AC_SUBST(includedir)
+
 pthread_create_version='""'
 if test "x$enable_shared" = "xyes" && test "x$posix_threads" != "x"; then
   # NB: don't check for -lpthread here, because then it would be
@@ -241,7 +245,7 @@ AC_SUBST(SECTION_FLAGS)
 AC_CACHE_CHECK([for the name of the symbol used for the entry point],
   [mudflap_cv_entry_point], [
 for name in _start __start unknown; do
-  AC_LINK_IFELSE([AC_LANG_PROGRAM([extern char $name;], [$name = 0;])],
+  AC_LINK_IFELSE([AC_LANG_PROGRAM([extern char $name@<:@@:>@;], [$name@<:@0@:>@ = 0;])],
                 [break])
 done
 mudflap_cv_entry_point="$name"])