OSDN Git Service

2004-07-23 Thomas Fitzsimmons <fitzsim@redhat.com>
[pf3gnuchains/gcc-fork.git] / libjava / configure.in
index d787120..47773fe 100644 (file)
@@ -1,6 +1,50 @@
 dnl Process this with autoconf to create configure
+AC_PREREQ(2.13)
 AC_INIT(java/lang/System.java)
 
+dnl We use these options to decide which functions to include.
+AC_ARG_WITH(target-subdir,
+[  --with-target-subdir=SUBDIR
+                           configuring in a subdirectory])
+
+dnl We may get other options which we don't document:
+dnl --with-target-subdir, --with-multisrctop, --with-multisubdir
+
+# When building with srcdir == objdir, links to the source files will
+# be created in directories within the target_subdir.  We have to
+# adjust toplevel_srcdir accordingly, so that configure finds
+# install-sh and other auxiliary files that live in the top-level
+# source directory.
+if test "${srcdir}" = "."; then
+  if test -z "${with_target_subdir}"; then
+    toprel=".."
+  else
+    if test "${with_target_subdir}" != "."; then
+      toprel="${with_multisrctop}../.."
+    else
+      toprel="${with_multisrctop}.."
+    fi
+  fi
+else
+  toprel=".."
+fi
+
+libgcj_basedir=$srcdir/$toprel/./libjava
+AC_SUBST(libgcj_basedir)
+
+AC_CONFIG_AUX_DIR(${srcdir}/$toprel)
+if :; then :; else
+  # This overrides the previous occurrence for automake, but not for
+  # autoconf, which is exactly what we want.
+  AC_CONFIG_AUX_DIR(..)
+fi
+
+AC_CANONICAL_SYSTEM
+_GCC_TOPLEV_NONCANONICAL_BUILD
+_GCC_TOPLEV_NONCANONICAL_TARGET
+
+AC_SUBST(target_noncanonical)
+
 # This works around the fact that libtool configuration may change LD
 # for this particular configuration, but some shells, instead of
 # keeping the changes in LD private, export them just because LD is
@@ -9,17 +53,121 @@ ORIGINAL_LD_FOR_MULTILIBS=$LD
 
 AC_PROG_LN_S
 
-dnl We use these options to decide which functions to include.
-AC_ARG_WITH(target-subdir,
-[  --with-target-subdir=SUBDIR
-                           configuring in a subdirectory])
+# This works around an automake problem.
+mkinstalldirs="`cd $ac_aux_dir && ${PWDCMD-pwd}`/mkinstalldirs"
+AC_SUBST(mkinstalldirs)
+
 AC_ARG_WITH(cross-host,
 [  --with-cross-host=HOST  configuring with a cross compiler])
 
 AC_ARG_WITH(newlib,
 [  --with-newlib           Configuring with newlib])
 
-LIBGCJ_CONFIGURE(.)
+AC_ARG_ENABLE(version-specific-runtime-libs,
+[  --enable-version-specific-runtime-libs    
+   specify that runtime libraries should be installed in a compiler-specific
+   directory ],
+    [case "$enableval" in
+      yes) version_specific_libs=yes ;;
+      no)  version_specific_libs=no ;;
+      *)   AC_MSG_ERROR([Unknown argument to enable/disable version-specific libs]);;
+     esac],
+    [version_specific_libs=no]
+)
+
+dnl Default to --enable-multilib
+AC_ARG_ENABLE(multilib,
+[  --enable-multilib       build many library versions (default)],
+[case "${enableval}" in
+  yes) multilib=yes ;;
+  no)  multilib=no ;;
+  *)   AC_MSG_ERROR(bad value ${enableval} for multilib option) ;;
+ esac], [multilib=yes])dnl
+
+dnl This shouldn't be needed, as long as top-level dependencies are
+dnl defined correctly and shared-library paths are set up so that
+dnl execution tests succeed.  FIXME.
+define([AC_PROG_CC_WORKS],[])
+define([AC_PROG_CXX_WORKS],[])
+
+AC_PROG_CC
+
+# We use the libstdc++-v3 version of LIB_AC_PROG_CXX, but use
+# glibjava_CXX instead of glibcpp_CXX.  That's because we're passed a
+# different definition of CXX than other directories, since we don't
+# depend on libstdc++-v3 having already been built.
+AC_DEFUN(LIB_AC_PROG_CXX,
+[AC_BEFORE([$0], [AC_PROG_CXXCPP])dnl
+dnl Fool anybody using AC_PROG_CXX.
+AC_PROVIDE([AC_PROG_CXX])
+# Use glibjava_CXX so that we do not cause CXX to be cached with the
+# flags that come in CXX while configuring libjava.  They're different
+# from those used for all other target libraries.  If CXX is set in
+# the environment, respect that here.
+glibjava_CXX=$CXX
+AC_CHECK_PROGS(glibjava_CXX, $CCC c++ g++ gcc CC cxx cc++, gcc)
+AC_SUBST(CXX)
+CXX=$glibjava_CXX
+test -z "$glibjava_CXX" && AC_MSG_ERROR([no acceptable c++ found in \$PATH])
+
+AC_PROG_CXX_GNU
+
+if test $ac_cv_prog_gxx = yes; then
+  GXX=yes
+dnl Check whether -g works, even if CXXFLAGS is set, in case the package
+dnl plays around with CXXFLAGS (such as to build both debugging and
+dnl normal versions of a library), tasteless as that idea is.
+  ac_test_CXXFLAGS="${CXXFLAGS+set}"
+  ac_save_CXXFLAGS="$CXXFLAGS"
+  CXXFLAGS=
+  AC_PROG_CXX_G
+  if test "$ac_test_CXXFLAGS" = set; then
+    CXXFLAGS="$ac_save_CXXFLAGS"
+  elif test $ac_cv_prog_cxx_g = yes; then
+    CXXFLAGS="-g -O2"
+  else
+    CXXFLAGS="-O2"
+  fi
+else
+  GXX=
+  test "${CXXFLAGS+set}" = set || CXXFLAGS="-g"
+fi
+])
+
+LIB_AC_PROG_CXX
+
+dnl version is pulled out to make it a bit easier to change using sed.
+version=0.0.7
+dnl Still use "libjava" here to placate dejagnu.
+AM_INIT_AUTOMAKE(libjava, $version)
+
+AC_CHECK_TOOL(AS, as)
+AC_CHECK_TOOL(AR, ar)
+AC_CHECK_TOOL(RANLIB, ranlib, :)
+
+AC_PROG_INSTALL
+
+AM_MAINTAINER_MODE
+
+AC_EXEEXT
+
+# configure.host sets the following important variables
+#      libgcj_cflags    - host specific C compiler flags
+#      libgcj_cxxflags  - host specific C++ compiler flags
+#      libgcj_javaflags - host specific Java compiler flags
+
+libgcj_cflags=
+libgcj_cxxflags=
+libgcj_javaflags=
+
+. [$]{srcdir}/configure.host
+
+LIBGCJ_CFLAGS="[$]{libgcj_cflags}"
+LIBGCJ_CXXFLAGS="[$]{libgcj_cxxflags}"
+LIBGCJ_JAVAFLAGS="[$]{libgcj_javaflags}"
+AC_SUBST(LIBGCJ_CFLAGS)
+AC_SUBST(LIBGCJ_CXXFLAGS)
+AC_SUBST(LIBGCJ_JAVAFLAGS)
 
 AM_CONFIG_HEADER(include/config.h gcj/libgcj-config.h)
 
@@ -28,7 +176,7 @@ if test "x${with_newlib}" = "x" || test "x${with_newlib}" = "xno"; then
    AC_LIBLTDL_CONVENIENCE
    AC_LIBTOOL_DLOPEN
    DIRLTDL=libltdl
-   AC_DEFINE(USE_LTDL)
+   AC_DEFINE(USE_LTDL, 1, [Define if libltdl is in use.])
    # Sigh.  Libtool's macro doesn't do the right thing.
    INCLTDL="-I\$(top_srcdir)/libltdl $INCLTDL"
    # FIXME: this is a hack.
@@ -62,7 +210,8 @@ if test -z "$enable_getenv_properties"; then
    enable_getenv_properties=${enable_getenv_properties_default-yes}
 fi
 if test "$enable_getenv_properties" = no; then
-   AC_DEFINE(DISABLE_GETENV_PROPERTIES)
+   AC_DEFINE(DISABLE_GETENV_PROPERTIES, 1,
+     [Define if system properties shouldn't be read from getenv("GCJ_PROPERTIES").])
 fi
 
 dnl Whether we should use arguments to main()
@@ -70,7 +219,7 @@ if test -z "$enable_main_args"; then
    enable_main_args=${enable_main_args_default-yes}
 fi
 if test "$enable_main_args" = no; then
-   AC_DEFINE(DISABLE_MAIN_ARGS)
+   AC_DEFINE(DISABLE_MAIN_ARGS, 1, [Define if we should ignore arguments to main().])
 fi
 
 
@@ -79,16 +228,48 @@ dnl Currently works only for Linux X86/ia64
 dnl Typically faster and more space-efficient
 AC_ARG_ENABLE(hash-synchronization,
 [  --enable-hash-synchronization
-                          Use global hash table for monitor locks])
+                          use global hash table for monitor locks])
 
 if test -z "$enable_hash_synchronization"; then
    enable_hash_synchronization=$enable_hash_synchronization_default
 fi
 
+# Do we allow intermodule optimizations (i.e. compiling many files at once)?
+AC_ARG_ENABLE(libgcj-multifile,
+[  --enable-libgcj-multifile
+                          allow compilation of several files at once],
+[case "${enableval}" in
+  yes) enable_libgcj_multifile=yes ;;
+  no)  enable_libgcj_multifile=no ;;
+  *) AC_MSG_ERROR(bad value ${enableval} for --enable-libgcj-multifile) ;;
+esac],[enable_libgcj_multifile=no])
+AM_CONDITIONAL(ONESTEP, test "$enable_libgcj_multifile" = yes)
+
+# What is the native OS API for MinGW?
+AC_ARG_WITH(win32-nlsapi,
+changequote(<<,>>)dnl
+<<  --with-win32-nlsapi=ansi, unicows or unicode
+                          native MinGW libgcj Win32 OS API [ansi]>>,
+changequote([,])
+[case "${withval}" in
+  ansi) with_win32_nlsapi=ansi ;;
+  unicows) with_win32_nlsapi=unicows ;;
+  unicode) with_win32_nlsapi=unicode ;;
+  *) AC_MSG_ERROR(Bad value ${withval} for --with-win32-nlsapi.) ;;
+esac],[with_win32_nlsapi=ansi])
+
+case "${with_win32_nlsapi}" in
+  unicows | unicode) 
+    AC_DEFINE(MINGW_LIBGCJ_UNICODE, 1,
+      [Define if MinGW libgcj uses the Windows UNICODE OS API.])
+    ;;
+esac
+
 dnl configure.host sets slow_pthread_self if the synchronization code should 
 dnl try to avoid pthread_self calls by caching thread IDs in a hashtable.
 if test "${slow_pthread_self}" = "yes"; then
-  AC_DEFINE(SLOW_PTHREAD_SELF)
+  AC_DEFINE(SLOW_PTHREAD_SELF, 1,
+    [Define if if the synchronization code should try to avoid pthread_self calls by caching thread IDs in a hashtable.])
 fi
 
 
@@ -98,7 +279,7 @@ AC_SUBST(LIBGCJDEBUG)
 AC_ARG_ENABLE(libgcj-debug,
 [  --enable-libgcj-debug   enable runtime debugging code],
   if test "$enable_libgcj_debug" = yes; then
-    AC_DEFINE(DEBUG)
+    AC_DEFINE(DEBUG, 1, [Define this if you want runtime debugging enabled.])
     LIBGCJDEBUG="true"
   fi)
 
@@ -113,7 +294,7 @@ AC_ARG_ENABLE(interpreter,
   fi)
 
 if test "$libgcj_interpreter" = yes; then
-   AC_DEFINE(INTERPRETER)
+   AC_DEFINE(INTERPRETER, 1, [Define if you want a bytecode interpreter.])
 fi
 INTERPRETER="$libgcj_interpreter"
 AC_SUBST(INTERPRETER)
@@ -182,7 +363,7 @@ if test -z "$enable_java_net"; then
    enable_java_net=${enable_java_net_default-yes}
 fi
 if test "$enable_java_net" = no; then
-   AC_DEFINE(DISABLE_JAVA_NET)
+   AC_DEFINE(DISABLE_JAVA_NET, 1, [Define if java.net native functions should be stubbed out.])
 fi
 
 dnl See if the user wants to configure without libffi.  Some
@@ -194,7 +375,7 @@ AC_ARG_WITH(libffi,
 LIBFFI=
 LIBFFIINCS=
 if test "$with_libffi" != no; then
-   AC_DEFINE(USE_LIBFFI)
+   AC_DEFINE(USE_LIBFFI, 1, [Define if we're to use libffi.])
    LIBFFI=../libffi/libffi_convenience.la
    LIBFFIINCS='-I$(top_srcdir)/../libffi/include -I../libffi/include'
 fi
@@ -206,7 +387,7 @@ AC_ARG_ENABLE(jvmpi,
 [  --disable-jvmpi         disable JVMPI support])
 
 if test "$enable_jvmpi" != no; then
-    AC_DEFINE(ENABLE_JVMPI)
+    AC_DEFINE(ENABLE_JVMPI, 1, [Define if you are using JVMPI.])
 fi
 
 dnl If the target is an eCos system, use the appropriate eCos
@@ -219,6 +400,9 @@ AC_ARG_WITH(ecos,
 TARGET_ECOS="$with_ecos"
 )
 
+EXTRA_CC_FILES=
+AC_SUBST(EXTRA_CC_FILES)
+
 PLATFORMOBJS=
 case "$TARGET_ECOS" in
    no) case "$host" in
@@ -240,7 +424,7 @@ case "$TARGET_ECOS" in
    *)
       PLATFORM=Ecos
       PLATFORMNET=NoNet
-      AC_DEFINE(ECOS)
+      AC_DEFINE(ECOS, 1, [Define if you're running eCos.])
       PLATFORMOBJS=posix.lo
       PLATFORMH=posix.h
       ;;
@@ -248,24 +432,29 @@ esac
 AC_SUBST(PLATFORMOBJS)
 AC_LINK_FILES(include/$PLATFORMH, include/platform.h)
 
-AC_EGREP_HEADER(uint32_t, stdint.h, AC_DEFINE(HAVE_INT32_DEFINED))
-AC_EGREP_HEADER(uint32_t, inttypes.h, AC_DEFINE(HAVE_INT32_DEFINED))
-AC_EGREP_HEADER(u_int32_t, sys/types.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED))
-AC_EGREP_HEADER(u_int32_t, sys/config.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED))
+AC_EGREP_HEADER(uint32_t, stdint.h, AC_DEFINE(HAVE_INT32_DEFINED, 1,
+                                      [Define if you have int32_t and uint32_t.]))
+AC_EGREP_HEADER(uint32_t, inttypes.h, AC_DEFINE(HAVE_INT32_DEFINED, 1,
+                                        [Define if you have int32_t and uint32_t.]))
+AC_EGREP_HEADER(u_int32_t, sys/types.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED, 1,
+                                          [Define if you have u_int32_t]))
+AC_EGREP_HEADER(u_int32_t, sys/config.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED, 1,
+                                           [Define if you have u_int32_t]))
 
 
 dnl These may not be defined in a non-ANS conformant embedded system.
 dnl FIXME: Should these case a runtime exception in that case?
-AC_EGREP_HEADER(mktime, time.h, AC_DEFINE(HAVE_MKTIME))
-AC_EGREP_HEADER(localtime, time.h, AC_DEFINE(HAVE_LOCALTIME))
+AC_EGREP_HEADER(mktime, time.h, AC_DEFINE(HAVE_MKTIME, 1,
+                                  [Define is you have 'mktime' in <time.h>]))
+AC_EGREP_HEADER(localtime, time.h, AC_DEFINE(HAVE_LOCALTIME, 1,
+                                  [Define is you have 'localtime' in <time.h>]))
 
-dnl Create the subdirectory for natFileDescriptor.cc, or the attempt
+dnl Create the subdirectory for natFile.cc, or the attempt
 dnl to create the link will fail.
 test -d java || mkdir java
 test -d java/io || mkdir java/io
 test -d gnu || mkdir gnu
 AC_LINK_FILES(java/io/natFile${FILE-${PLATFORM}}.cc, java/io/natFile.cc)
-AC_LINK_FILES(java/io/natFileDescriptor${FILE-${PLATFORM}}.cc, java/io/natFileDescriptor.cc)
 
 dnl Likewise for ConcreteProcess.java and natConcreteProcess.cc.
 test -d java/lang || mkdir java/lang
@@ -277,15 +466,25 @@ test -d java/net || mkdir java/net
 AC_LINK_FILES(java/net/natInetAddress${PLATFORMNET}.cc, java/net/natInetAddress.cc)
 AC_LINK_FILES(java/net/natNetworkInterface${PLATFORMNET}.cc, java/net/natNetworkInterface.cc)
 
-dnl Likewise for natPlainSocketImpl.cc and natPlainDatagramSocketImpl.ca.c
+dnl Likewise for natPlainSocketImpl.cc and natPlainDatagramSocketImpl.cc.
 test -d gnu/java || mkdir gnu/java
 test -d gnu/java/net || mkdir gnu/java/net
 AC_LINK_FILES(gnu/java/net/natPlainSocketImpl${PLATFORMNET}.cc, gnu/java/net/natPlainSocketImpl.cc)
 AC_LINK_FILES(gnu/java/net/natPlainDatagramSocketImpl${PLATFORMNET}.cc, gnu/java/net/natPlainDatagramSocketImpl.cc)
 
+dnl Likewise for natPipeImpl.cc and natSelectorImpl.cc.
+test -d gnu/java/nio || mkdir gnu/java/nio
+AC_LINK_FILES(gnu/java/nio/natPipeImpl${PLATFORM}.cc, gnu/java/nio/natPipeImpl.cc)
+AC_LINK_FILES(gnu/java/nio/natSelectorImpl${PLATFORM}.cc, gnu/java/nio/natSelectorImpl.cc)
+test -d gnu/java/nio/channels || mkdir gnu/java/nio/channels
+AC_LINK_FILES(gnu/java/nio/channels/natFileChannel${FILE-${PLATFORM}}.cc, gnu/java/nio/channels/natFileChannelImpl.cc)
+
 case "${host}" in
     *mingw*)
       SYSTEMSPEC="-lgdi32 -lwsock32 -lws2_32"
+      if test "${with_win32_nlsapi}" = "unicows"; then
+        SYSTEMSPEC="-lunicows $SYSTEMSPEC"
+      fi
     ;;
     *)
       SYSTEMSPEC=
@@ -355,6 +554,18 @@ done
 AM_CONDITIONAL(XLIB_AWT, test "$use_xlib_awt" = yes)
 AM_CONDITIONAL(GTK_AWT, test "$use_gtk_awt" = yes)
 
+dnl determine whether to enable the cairo GTK Graphics2D backend
+AC_ARG_ENABLE(gtk-cairo, [  --enable-gtk-cairo       build the cairo Graphics2D implementation on GTK])
+AM_CONDITIONAL(GTK_CAIRO, test "x${enable_gtk_cairo}" = xyes)
+if test "x${enable_gtk_cairo}" = xyes
+then
+       PKG_CHECK_MODULES(CAIRO, cairo)
+       PKG_CHECK_MODULES(PANGOFT2, pangoft2)
+fi
+AC_SUBST(CAIRO_LIBS)
+AC_SUBST(CAIRO_CFLAGS)
+AC_SUBST(PANGOFT2_LIBS)
+AC_SUBST(PANGOFT2_CFLAGS)
 
 dnl FIXME: this should be _libs on some hosts.
 libsubdir=.libs
@@ -387,7 +598,7 @@ case "$GC" in
     GCOBJS=boehm.lo
     GCHDR=boehm-gc.h
     dnl The POSIX thread support needs to know this.
-    AC_DEFINE(HAVE_BOEHM_GC)
+    AC_DEFINE(HAVE_BOEHM_GC, 1, [Define if Boehm GC in use.])
     ;;
  no)
     AC_MSG_RESULT(none)
@@ -420,7 +631,7 @@ case "$THREADS" in
     THREADS=posix
     case "$host" in
      *-*-linux*)
-       AC_DEFINE(LINUX_THREADS)
+       AC_DEFINE(LINUX_THREADS, 1, [Define if using POSIX threads on Linux.])
        ;;
     esac
     ;;
@@ -485,7 +696,7 @@ changequote([,])
     # MIT pthreads doesn't seem to have the mutexattr functions.
     # But for now we don't check for it.  We just assume you aren't
     # using MIT pthreads.
-    AC_DEFINE(HAVE_PTHREAD_MUTEXATTR_INIT)
+    AC_DEFINE(HAVE_PTHREAD_MUTEXATTR_INIT, 1, [Define if using POSIX threads that have the mutexattr functions.])
 
     # If we're using the Boehm GC, then we happen to know that it
     # defines _REENTRANT, so we don't bother.  Eww.
@@ -528,10 +739,6 @@ AC_SUBST(HASH_SYNC_SPEC)
 
 AM_CONDITIONAL(USING_GCC, test "$GCC" = yes)
 
-CANADIAN=no
-NULL_TARGET=no
-NATIVE=yes
-
 # We're in the tree with gcc, and need to include some of its headers.
 GCC_UNWIND_INCLUDE='-I$(libgcj_basedir)/../gcc'
 
@@ -540,7 +747,7 @@ changequote(,)dnl
 gcc_version_trigger=${libgcj_basedir}/../gcc/version.c
 gcc_version_full=`grep version_string ${gcc_version_trigger} | sed -e 's/.*\"\([^\"]*\)\".*/\1/'`
 gcc_version=`echo ${gcc_version_full} | sed -e 's/\([^ ]*\) .*/\1/'`
-tool_include_dir='$(libdir)/gcc/$(target_alias)/'${gcc_version}/include
+tool_include_dir='$(libdir)/gcc/$(target_noncanonical)/'${gcc_version}/include
 changequote([,])dnl
 AC_SUBST(tool_include_dir)
 AC_SUBST(gcc_version)
@@ -552,19 +759,20 @@ if test "x${with_newlib}" = "xyes"; then
 
    # We assume newlib.  This lets us hard-code the functions we know
    # we'll have.
-   AC_DEFINE(HAVE_MEMMOVE)
-   AC_DEFINE(HAVE_MEMCPY)
-   AC_DEFINE(HAVE_STRERROR)
-   AC_DEFINE(HAVE_TIME)
-   AC_DEFINE(HAVE_GMTIME_R)
-   AC_DEFINE(HAVE_LOCALTIME_R)
+   AC_DEFINE(HAVE_MEMMOVE, 1, [Define if you have memmove.])
+   AC_DEFINE(HAVE_MEMCPY, 1, [Define if you have memcpy.])
+   AC_DEFINE(HAVE_STRERROR, 1, [Define if you have strerror.])
+   AC_DEFINE(HAVE_TIME, 1, [Define if you have time.])
+   AC_DEFINE(HAVE_GMTIME_R, 1, [Define if you have the 'gmtime_r' function])
+   AC_DEFINE(HAVE_LOCALTIME_R, 1, [Define if you have the 'localtime_r' function.])
+   AC_DEFINE(HAVE_USLEEP_DECL, 1, [Define if usleep is declared in <unistd.h>.])
    dnl This is only for POSIX threads.
-   AC_DEFINE(HAVE_PTHREAD_MUTEXATTR_INIT)
+   AC_DEFINE(HAVE_PTHREAD_MUTEXATTR_INIT, 1, [Define if using POSIX threads that have the mutexattr functions.])
    dnl We also assume we are using gcc, which provides alloca.
    AC_DEFINE(HAVE_ALLOCA)
 
    dnl Assume we do not have getuid and friends.
-   AC_DEFINE(NO_GETUID)
+   AC_DEFINE(NO_GETUID, 1, [Define if getuid() and friends are missing.])
    PLATFORMNET=NoNet
 else
    AC_CHECK_FUNCS(strerror ioctl select fstat open fsync sleep opendir)
@@ -580,28 +788,43 @@ else
        ia64-*-linux*)
         # Has broken backtrace()
         ;;
+       mips*-*-linux*)
+         # Has broken backtrace(), but we supply our own.
+         if test -d sysdep; then true; else mkdir -p sysdep; fi
+         EXTRA_CC_FILES="${EXTRA_CC_FILES} sysdep/dwarf2-backtrace.cc"
+         AC_DEFINE(HAVE_BACKTRACE, 1,
+           [Define if your platform has a working backtrace() function.])
+         ;;
        *)
-         AC_DEFINE(HAVE_BACKTRACE)
+         AC_DEFINE(HAVE_BACKTRACE, 1,
+           [Define if your platform has a working backtrace() function.])
         ;;
      esac
    ], [
      case "$host" in
        *mingw*)
          # Has backtrace() defined in libgcj itself
-         AC_DEFINE(HAVE_BACKTRACE)
+         AC_DEFINE(HAVE_BACKTRACE, 1,
+           [Define if your platform has a working backtrace() function.])
          ;;
      esac
    ])
 
    AC_CHECK_LIB(dl, dladdr, [
-     AC_DEFINE(HAVE_DLADDR)])
+     if test "x${disable_dladdr}" = "xyes"; then
+       #Broken dladdr().
+       true
+     else
+       AC_DEFINE(HAVE_DLADDR, 1, [Define if you have dladdr()])
+     fi
+   ])
    if test x"$build" = x"$host"; then
      AC_CHECK_FILES(/proc/self/exe, [
-       AC_DEFINE(HAVE_PROC_SELF_EXE)])
+       AC_DEFINE(HAVE_PROC_SELF_EXE, 1, [Define if you have /proc/self/exe])])
    else
      case $host in
      *-linux*)
-       AC_DEFINE(HAVE_PROC_SELF_EXE)
+       AC_DEFINE(HAVE_PROC_SELF_EXE, 1, [Define if you have /proc/self/exe])
        ;;
      esac
    fi
@@ -611,12 +834,13 @@ else
    AC_STRUCT_TIMEZONE
 
    AC_CHECK_FUNCS(gethostbyname_r, [
-     AC_DEFINE(HAVE_GETHOSTBYNAME_R)
+     AC_DEFINE(HAVE_GETHOSTBYNAME_R, 1,
+       [Define if you have the 'gethostbyname_r' function.])
      # There are two different kinds of gethostbyname_r.
      # We look for the one that returns `int'.
      # Hopefully this check is robust enough.
      AC_EGREP_HEADER(int.*gethostbyname_r, netdb.h, [
-       AC_DEFINE(GETHOSTBYNAME_R_RETURNS_INT)])
+       AC_DEFINE(GETHOSTBYNAME_R_RETURNS_INT, 1, [Define if gethostbyname_r returns 'int'.])])
 
      case " $GCINCS " in
      *" -D_REENTRANT "*) ;;
@@ -666,21 +890,26 @@ else
    # linkage check is enough, yet C++ code requires proper prototypes.)
    AC_EGREP_HEADER(gethostbyaddr_r, netdb.h, [
    AC_CHECK_FUNCS(gethostbyaddr_r, [
-     AC_DEFINE(HAVE_GETHOSTBYADDR_R)
+     AC_DEFINE(HAVE_GETHOSTBYADDR_R, 1,
+       [Define if you have the 'gethostbyaddr_r' function.])
      # There are two different kinds of gethostbyaddr_r.
      # We look for the one that returns `int'.
      # Hopefully this check is robust enough.
      AC_EGREP_HEADER(int.*gethostbyaddr_r, netdb.h, [
-       AC_DEFINE(GETHOSTBYADDR_R_RETURNS_INT)])])])
+       AC_DEFINE(GETHOSTBYADDR_R_RETURNS_INT, 1,
+         [Define if gethostbyaddr_r returns 'int'.])])])])
 
    AC_CHECK_FUNCS(gethostname, [
-     AC_DEFINE(HAVE_GETHOSTNAME)
+     AC_DEFINE(HAVE_GETHOSTNAME, 1,
+       [Define if you have the 'gethostname' function.])
      AC_EGREP_HEADER(gethostname, unistd.h, [
-       AC_DEFINE(HAVE_GETHOSTNAME_DECL)])])
+       AC_DEFINE(HAVE_GETHOSTNAME_DECL, 1,
+         [Define if gethostname is declared in <unistd.h>.])])])
 
    AC_CHECK_FUNCS(usleep, [
      AC_EGREP_HEADER(usleep, unistd.h, [
-       AC_DEFINE(HAVE_USLEEP_DECL)])])
+       AC_DEFINE(HAVE_USLEEP_DECL, 1,
+          [Define if usleep is declared in <unistd.h>.])])])
 
    # Look for these functions in the thread library, but only bother
    # if using POSIX threads.
@@ -708,10 +937,12 @@ else
       # or __m_count.  This is a nice hack for Linux.
       AC_TRY_COMPILE([#include <pthread.h>], [
           extern pthread_mutex_t *mutex; int q = mutex->m_count;
-        ], AC_DEFINE(PTHREAD_MUTEX_HAVE_M_COUNT), [
+        ], AC_DEFINE(PTHREAD_MUTEX_HAVE_M_COUNT, 1,
+             [Define if pthread_mutex_t has m_count member.]), [
        AC_TRY_COMPILE([#include <pthread.h>], [
            extern pthread_mutex_t *mutex; int q = mutex->__m_count;
-         ], AC_DEFINE(PTHREAD_MUTEX_HAVE___M_COUNT))])
+         ], AC_DEFINE(PTHREAD_MUTEX_HAVE___M_COUNT, 1,
+            [Define if pthread_mutex_t has __m_count member.]))])
    fi
 
    # We require a way to get the time.
@@ -789,11 +1020,17 @@ else
 
    # Test for Gtk stuff, if asked for.
    if test "$use_gtk_awt" = yes; then
-      AM_PATH_GTK_2_0(2.0.0,,exit 1)
-      AM_PATH_GLIB_2_0(2.0.0,,exit 1,gthread)
-      dnl XXX Fix me when libart.m4 has the compile test fixed!
-      enable_libarttest=no
-      AM_PATH_LIBART(2.1.0,,exit 1)
+      PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.2)
+      AC_SUBST(GTK_CFLAGS)
+      AC_SUBST(GTK_LIBS)
+
+      PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.2 gthread-2.0 >= 2.2)
+      AC_SUBST(GLIB_CFLAGS)
+      AC_SUBST(GLIB_LIBS)
+
+      PKG_CHECK_MODULES(LIBART, libart-2.0 >= 2.1)
+      AC_SUBST(LIBART_CFLAGS)
+      AC_SUBST(LIBART_LIBS)
    fi
 
    # On Solaris, and maybe other architectures, the Boehm collector
@@ -811,6 +1048,8 @@ changequote(<<,>>)
 changequote([,])
 fi
 
+NATIVE=yes
+
 # Which gcj do we use?
 which_gcj=default
 built_gcc_dir="`cd ${builddotdot}/../../gcc && ${PWDCMD-pwd}`"
@@ -825,7 +1064,7 @@ if test -n "${with_cross_host}"; then
      ;;
   esac
   if test -x "${built_gcc_dir}/gcj${cross_host_exeext}"; then
-     if test x"$build_alias" = x"$with_cross_host"; then
+     if test x"$build_noncanonical" = x"$with_cross_host"; then
         # Ordinary cross (host!=target and host=build)
         which_gcj=built
      else
@@ -852,27 +1091,32 @@ fi
 case "${which_gcj}" in
    built)
       GCJ="$built_gcc_dir/gcj -B`${PWDCMD-pwd}`/ -B$built_gcc_dir/"
+      GCJH='$(MULTIBUILDTOP)../$(COMPPATH)/gcc/gcjh'
+      ZIP='$(MULTIBUILDTOP)../$(COMPPATH)/fastjar/fastjar'
    ;;
    cross)
-      # See the comment in Makefile.am about CANADIAN being a misnomer
-      CANADIAN=yes
-      NULL_TARGET=no
       if test "x${with_newlib}" = "xyes"; then
          # FIXME (comment): Why is this needed?
          GCC_UNWIND_INCLUDE=
-         GCJ="${target_alias}-gcj"
+         GCJ="${target_noncanonical}-gcj"
       else
-         GCJ="${target_alias}-gcj -B`${PWDCMD-pwd}`/"
+         GCJ="${target_noncanonical}-gcj -B`${PWDCMD-pwd}`/"
       fi
+      ZIP=jar
+      GCJH='$(target_noncanonical)-gcjh'
    ;;
    path)
-      # See the comment in Makefile.am about CANADIAN being a misnomer
-      CANADIAN=yes
-      NULL_TARGET=yes
       GCJ="gcj -B`${PWDCMD-pwd}`/"
+      ## In this case, gcj is found outside the build tree.  However, zip is
+      ## found in the build tree.
+      ZIP='$(MULTIBUILDTOP)../$(COMPPATH)/fastjar/fastjar'
+      GCJH=gcjh
    ;;
 esac
 
+AC_SUBST(GCJH)
+AC_SUBST(ZIP)
+
 # Create it, so that compile/link tests don't fail
 test -f libgcj.spec || touch libgcj.spec
 
@@ -924,24 +1168,38 @@ AC_SUBST(CHECKREFSPEC)
 AC_SUBST(EXCEPTIONSPEC)
 AC_SUBST(IEEESPEC)
 
-AM_CONDITIONAL(CANADIAN, test "$CANADIAN" = yes)
-AM_CONDITIONAL(NULL_TARGET, test "$NULL_TARGET" = yes)
-AM_CONDITIONAL(NATIVE, test "$NATIVE" = yes || test "$NULL_TARGET" = yes)
+AM_CONDITIONAL(NATIVE, test "$NATIVE" = yes)
 AM_CONDITIONAL(NEEDS_DATA_START, test "$NEEDS_DATA_START" = yes && test "$NATIVE" = yes)
 AC_SUBST(GCC_UNWIND_INCLUDE)
 
-if test -n "$with_cross_host" &&
-   test x"$with_cross_host" != x"no"; then
-  toolexecdir='$(exec_prefix)/$(target_alias)'
-  toolexecmainlibdir='$(toolexecdir)/lib'
-else
-  toolexecdir='$(libdir)/gcc-lib/$(target_alias)'
-  toolexecmainlibdir='$(libdir)'
-fi
-multi_os_directory=`$CC -print-multi-os-directory`
-case $multi_os_directory in
-  .) toolexeclibdir=$toolexecmainlibdir ;; # Avoid trailing /.
-  *) toolexeclibdir=$toolexecmainlibdir/$multi_os_directory ;;
+# Process the option "--enable-version-specific-runtime-libs"
+# Calculate toolexeclibdir
+case ${version_specific_libs} in
+  yes)
+    # Need the gcc compiler version to know where to install libraries
+    # and header files if --enable-version-specific-runtime-libs option
+    # is selected.
+    includedir='${libdir}/gcc/${target_noncanonical}/'$gcc_version/include/
+    toolexecdir='$(libdir)/gcc/$(target_noncanonical)'
+    toolexecmainlibdir='$(toolexecdir)/'${gcc_version}'$(MULTISUBDIR)'
+    toolexeclibdir=$toolexecmainlibdir
+    ;;
+  no)
+    if test -n "$with_cross_host" &&
+       test x"$with_cross_host" != x"no"; then
+      # Install a library built with a cross compiler in tooldir, not libdir.
+      toolexecdir='$(exec_prefix)/$(target_noncanonical)'
+      toolexecmainlibdir='$(toolexecdir)/lib'
+    else
+      toolexecdir='$(libdir)/gcc-lib/$(target_noncanonical)'
+      toolexecmainlibdir='$(libdir)'
+    fi
+    multi_os_directory=`$CC -print-multi-os-directory`
+    case $multi_os_directory in
+      .) toolexeclibdir=$toolexecmainlibdir ;; # Avoid trailing /.
+      *) toolexeclibdir=$toolexecmainlibdir/$multi_os_directory ;;
+    esac
+    ;;
 esac
 AC_SUBST(toolexecdir)
 AC_SUBST(toolexecmainlibdir)
@@ -955,16 +1213,6 @@ GCJVERSION=$gcjversion
 AC_SUBST(GCJVERSION)
 AC_DEFINE_UNQUOTED(GCJVERSION, "$GCJVERSION", [Short GCJ version ID])
 
-dnl Work around a g++ bug.  Reported to gcc-bugs@gcc.gnu.org on Jan 22, 2000.
-AC_MSG_CHECKING([for g++ -ffloat-store bug])
-save_CFLAGS="$CFLAGS"
-CFLAGS="-x c++ -O2 -ffloat-store"
-AC_TRY_COMPILE([#include <math.h>], , 
-  [AC_MSG_RESULT(no)],
-  [AC_DEFINE(__NO_MATH_INLINES)
-   AC_MSG_RESULT(yes)])
-CFLAGS="$save_CFLAGS"
-
 dnl We check for sys/filio.h because Solaris 2.5 defines FIONREAD there.
 dnl On that system, sys/ioctl.h will not include sys/filio.h unless
 dnl BSD_COMP is defined; just including sys/filio.h is simpler.
@@ -989,25 +1237,29 @@ AC_TRY_COMPILE([#include <sys/types.h>
 #if HAVE_NETINET_IN_H
 #include <netinet/in.h>
 #endif], [in_addr_t foo;],
-  [AC_DEFINE([HAVE_IN_ADDR_T])
+  [AC_DEFINE(HAVE_IN_ADDR_T, 1,
+     [Define to 1 if 'in_addr_t' is defined in sys/types.h or netinet/in.h.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)])
 
 AC_MSG_CHECKING([whether struct ip_mreq is in netinet/in.h])
 AC_TRY_COMPILE([#include <netinet/in.h>], [struct ip_mreq mreq;],
-  [AC_DEFINE(HAVE_STRUCT_IP_MREQ)
+  [AC_DEFINE(HAVE_STRUCT_IP_MREQ, 1,
+     [Define if struct ip_mreq is defined in netinet/in.h.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)])
 
 AC_MSG_CHECKING([whether struct ipv6_mreq is in netinet/in.h])
 AC_TRY_COMPILE([#include <netinet/in.h>], [struct ipv6_mreq mreq6;],
-  [AC_DEFINE(HAVE_STRUCT_IPV6_MREQ)
+  [AC_DEFINE(HAVE_STRUCT_IPV6_MREQ, 1,
+     [Define if struct ipv6_mreq is defined in netinet/in.h.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)])
 
 AC_MSG_CHECKING([whether struct sockaddr_in6 is in netinet/in.h])
 AC_TRY_COMPILE([#include <netinet/in.h>], [struct sockaddr_in6 addr6;],
-  [AC_DEFINE(HAVE_INET6)
+  [AC_DEFINE(HAVE_INET6, 1,
+     [Define if inet6 structures are defined in netinet/in.h.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)])
 
@@ -1015,13 +1267,13 @@ AC_MSG_CHECKING([for socklen_t in sys/socket.h])
 AC_TRY_COMPILE([#define _POSIX_PII_SOCKET
 #include <sys/types.h>
 #include <sys/socket.h>], [socklen_t x = 5;],
-  [AC_DEFINE(HAVE_SOCKLEN_T)
+  [AC_DEFINE(HAVE_SOCKLEN_T, 1, [Define it socklen_t typedef is in sys/socket.h.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)])
 
 AC_MSG_CHECKING([for tm_gmtoff in struct tm])
 AC_TRY_COMPILE([#include <time.h>], [struct tm tim; tim.tm_gmtoff = 0;],
-  [AC_DEFINE(STRUCT_TM_HAS_GMTOFF)
+  [AC_DEFINE(STRUCT_TM_HAS_GMTOFF, 1, [Define if struct tm has tm_gmtoff field.])
    AC_MSG_RESULT(yes)],
   [AC_MSG_RESULT(no)
    AC_MSG_CHECKING([for global timezone variable])
@@ -1030,13 +1282,14 @@ AC_TRY_COMPILE([#include <time.h>], [struct tm tim; tim.tm_gmtoff = 0;],
    dnl the header file will mention timezone if it exists.
    dnl Don't find the win32 function timezone
    AC_TRY_COMPILE([#include <time.h>], [void i(){long z2 = 2*timezone;}],
-     [AC_DEFINE(HAVE_TIMEZONE)
+     [AC_DEFINE(HAVE_TIMEZONE, 1, [Define if global 'timezone' exists.])
       AC_MSG_RESULT(yes)],
      [AC_MSG_RESULT(no)
        AC_MSG_CHECKING([for global _timezone variable])
        dnl FIXME: As above, don't want link check
        AC_TRY_COMPILE([#include <time.h>], [long z2 = _timezone;],
-         [AC_DEFINE(HAVE_UNDERSCORE_TIMEZONE)
+         [AC_DEFINE(HAVE_UNDERSCORE_TIMEZONE, 1,
+            [Define if your platform has the global _timezone variable.])
           AC_MSG_RESULT(yes)],
           [AC_MSG_RESULT(no)])])])
 
@@ -1046,6 +1299,7 @@ AC_FUNC_MMAP
 AC_CHECK_PROGS(PERL, perl, false)
 
 SYSDEP_SOURCES=
+SIGNAL_HANDLER_AUX=
 
 case "${host}" in
  i?86-*-linux*)
@@ -1058,10 +1312,13 @@ case "${host}" in
 #    SYSDEP_SOURCES=sysdep/ia64.c
 #    test -d sysdep || mkdir sysdep
 #    ;;
+ hppa*-*-linux*)
+    SIGNAL_HANDLER=include/pa-signal.h
+    ;;
  ia64-*-linux*)
     SIGNAL_HANDLER=include/dwarf2-signal.h
     ;;
- powerpc-*-linux*)
+ powerpc*-*-linux*)
     SIGNAL_HANDLER=include/powerpc-signal.h
     ;;
  alpha*-*-linux*)
@@ -1072,6 +1329,7 @@ case "${host}" in
     ;;
  x86_64*-*-linux*)
     SIGNAL_HANDLER=include/x86_64-signal.h
+    SIGNAL_HANDLER_AUX=include/i386-signal.h
     ;;
  sparc*-*-linux*)
     SIGNAL_HANDLER=include/dwarf2-signal.h
@@ -1082,6 +1340,12 @@ case "${host}" in
  *mingw*)
     SIGNAL_HANDLER=include/win32-signal.h
     ;;
+ mips*-*-linux*)
+    SIGNAL_HANDLER=include/mips-signal.h
+    ;;
+ *-*-darwin*)
+    SIGNAL_HANDLER=include/darwin-signal.h
+    ;;
  *)
     SIGNAL_HANDLER=include/default-signal.h
     ;;
@@ -1090,12 +1354,13 @@ esac
 # If we're using sjlj exceptions, forget what we just learned.
 if test "$enable_sjlj_exceptions" = yes; then
    SIGNAL_HANDLER=include/default-signal.h
+   SIGNAL_HANDLER_AUX=
 fi
 
 # Define here any compiler flags that you need in order to make backtrace() work.
 BACKTRACESPEC=
 case "${host}" in
- x86_64*-*-linux*)
+ x86_64*-*-linux*|i?86-*)
     BACKTRACESPEC=-fno-omit-frame-pointer
     ;;
 esac
@@ -1103,7 +1368,12 @@ AC_SUBST(BACKTRACESPEC)
 
 AC_SUBST(SYSDEP_SOURCES)
 
-AC_LINK_FILES($SIGNAL_HANDLER, include/java-signal.h)
+if test -z "$SIGNAL_HANDLER_AUX"; then
+  SIGNAL_HANDLER_AUX=$SIGNAL_HANDLER
+fi
+
+AC_LINK_FILES($SIGNAL_HANDLER $SIGNAL_HANDLER_AUX,
+             include/java-signal.h include/java-signal-aux.h)
 
 if test "${multilib}" = "yes"; then
   multilib_arg="--enable-multilib"