OSDN Git Service

2007-03-13 Thomas Fitzsimmons <fitzsim@redhat.com>
[pf3gnuchains/gcc-fork.git] / libjava / classpath / configure.ac
index 43efe58..c9e03ab 100644 (file)
@@ -710,6 +710,28 @@ AC_SUBST(INIT_LOAD_LIBRARY)
 
 
 dnl -----------------------------------------------------------
+dnl Specify the jar file containing the Eclipse Java Compiler.  If
+dnl this option is not specified then the com.sun.tools.javac
+dnl implementation will not be included in tools.zip.
+dnl -----------------------------------------------------------
+dnl GCJ LOCAL: default to $multi_basedir/ecj.jar
+dnl In the default case where $multi_basedir/ecj.jar is found
+dnl $(jardir)/ecj.jar will not expand properly in GNU Classpath's
+dnl gnu/classpath/Configuration.java.  That is OK though since libjava's
+dnl gnu/classpath/Configuration.java overrides GNU Classpath's and
+dnl ECJ_JAR_FILE will be properly expanded in libjava's
+dnl gnu/classpath/natConfiguration.cc.
+AC_ARG_WITH([ecj-jar],
+           [AS_HELP_STRING([--with-ecj-jar=ABS.PATH],
+           [specify jar file containing the Eclipse Java Compiler])],
+           [ECJ_JAR=$withval],
+           [if test -f $multi_basedir/ecj.jar; then
+              ECJ_JAR='$(jardir)/ecj.jar'
+            fi])
+AC_SUBST(ECJ_JAR)
+AM_CONDITIONAL(FOUND_ECJ_JAR, test "$ECJ_JAR" != "")
+
+dnl -----------------------------------------------------------
 dnl Should the VM explicitly run class initialization subfunctions for
 dnl java.lang.System?   (default is false -- the subfunctions will be run 
 dnl automatically by the class initializer)