OSDN Git Service

libiberty:
[pf3gnuchains/gcc-fork.git] / libiberty / configure.in
index ee82459..6ad054a 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script
 
-AC_PREREQ(2.5)
+AC_PREREQ(2.13)
 AC_INIT(pexecute.c)
 
 dnl We use these options to decide which functions to include.
@@ -55,6 +55,7 @@ AC_PROG_CC_GNU
 
 if test $ac_cv_prog_gcc = yes; then
   GCC=yes
+  ac_libiberty_warn_cflags='-W -Wall -Wtraditional -pedantic'
 dnl Check whether -g works, even if CFLAGS is set, in case the package
 dnl plays around with CFLAGS (such as to build both debugging and
 dnl normal versions of a library), tasteless as that idea is.
@@ -71,9 +72,11 @@ dnl normal versions of a library), tasteless as that idea is.
   fi
 else
   GCC=
+  ac_libiberty_warn_cflags=
   test "${CFLAGS+set}" = set || CFLAGS="-g"
 fi
 ])
+AC_SUBST(ac_libiberty_warn_cflags)
 
 LIB_AC_PROG_CC
 
@@ -93,7 +96,7 @@ AC_CONFIG_HEADER(config.h:config.in)
 
 dnl When we start using automake:
 dnl AM_MAINTAINER_MODE
-dnl AM_EXEEXT
+dnl AC_EXEEXT
 
 dnl When we start using automake:
 dnl AM_PROG_INSTALL
@@ -106,7 +109,8 @@ AC_SUBST_FILE(host_makefile_frag)
 # It's OK to check for header files.  Although the compiler may not be
 # able to link anything, it had better be able to at least compile
 # something.
-AC_CHECK_HEADERS(sys/file.h sys/param.h stdlib.h string.h unistd.h strings.h sys/time.h)
+AC_CHECK_HEADERS(sys/file.h sys/param.h stdlib.h string.h unistd.h strings.h sys/time.h sys/resource.h sys/stat.h sys/mman.h fcntl.h)
+AC_HEADER_SYS_WAIT
 
 # This is the list of functions which libiberty will provide if they
 # are not available on the host.
@@ -117,6 +121,7 @@ funcs="$funcs basename"
 funcs="$funcs bcmp"
 funcs="$funcs bcopy"
 funcs="$funcs bzero"
+funcs="$funcs calloc"
 funcs="$funcs clock"
 funcs="$funcs getcwd"
 funcs="$funcs getpagesize"
@@ -127,9 +132,12 @@ funcs="$funcs memcmp"
 funcs="$funcs memcpy"
 funcs="$funcs memmove"
 funcs="$funcs memset"
+funcs="$funcs mkstemps"
+funcs="$funcs putenv"
 funcs="$funcs random"
 funcs="$funcs rename"
 funcs="$funcs rindex"
+funcs="$funcs setenv"
 funcs="$funcs sigsetmask"
 funcs="$funcs strcasecmp"
 funcs="$funcs strchr"
@@ -151,20 +159,21 @@ funcs="$funcs waitpid"
 
 vars="sys_errlist sys_nerr sys_siglist"
 
-checkfuncs="getrusage on_exit psignal strerror strsignal sysconf times"
+checkfuncs="getrusage on_exit psignal strerror strsignal sysconf times sbrk gettimeofday"
 
 # These are neither executed nor required, but they help keep
 # autoheader happy without adding a bunch of text to acconfig.h.
 if test "x" = "y"; then
-  AC_CHECK_FUNCS(asprintf atexit basename bcmp bcopy bzero clock getcwd)
-  AC_CHECK_FUNCS(getpagesize index insque memchr memcmp memcpy memmove)
-  AC_CHECK_FUNCS(memset random rename rindex sigsetmask strcasecmp)
-  AC_CHECK_FUNCS(strchr strdup strncasecmp strrchr strstr strtod strtol)
+  AC_CHECK_FUNCS(asprintf atexit basename bcmp bcopy bzero calloc clock getcwd)
+  AC_CHECK_FUNCS(getpagesize index insque mkstemps memchr memcmp memcpy memmove)
+  AC_CHECK_FUNCS(memset putenv random rename rindex sigsetmask strcasecmp)
+  AC_CHECK_FUNCS(setenv strchr strdup strncasecmp strrchr strstr strtod strtol)
   AC_CHECK_FUNCS(strtoul tmpnam vasprintf vfprintf vprintf vsprintf waitpid)
   AC_DEFINE(HAVE_SYS_ERRLIST)
   AC_DEFINE(HAVE_SYS_NERR)
   AC_DEFINE(HAVE_SYS_SIGLIST)
   AC_CHECK_FUNCS(getrusage on_exit psignal strerror strsignal sysconf times)
+  AC_CHECK_FUNCS(sbrk gettimeofday)
 fi
 
 # For each of these functions, if the host does not provide the
@@ -173,6 +182,7 @@ fi
 # if the host does not provide alloca, we set ALLOCA to alloca.o
 
 setobjs=
+CHECK=
 if test -n "${with_target_subdir}"; then
 
   # We are being configured as a target library.  AC_REPLACE_FUNCS
@@ -207,8 +217,16 @@ if test -n "${with_target_subdir}"; then
     setobjs=yes
 
   fi
+
+else
+
+   # Not a target library, so we set things up to run the test suite.
+   CHECK=check-cplus-dem
+
 fi
 
+AC_SUBST(CHECK)
+
 if test -z "${setobjs}"; then
   case "${host}" in
 
@@ -247,10 +265,10 @@ if test -z "${setobjs}"; then
 
   case "${host}" in
 
-  *-*-cygwin32*)
-    # The cygwin32 library actually uses a couple of files from
+  *-*-cygwin*)
+    # The Cygwin library actually uses a couple of files from
     # libiberty when it is built.  If we are building a native
-    # cygwin32, and we run the tests, we will appear to have these
+    # Cygwin, and we run the tests, we will appear to have these
     # files.  However, when we go on to build winsup, we will wind up
     # with a library which does not have the files, since they should
     # have come from libiberty.
@@ -273,13 +291,46 @@ if test -z "${setobjs}"; then
     AC_DEFINE(HAVE_SYS_ERRLIST)
     ;;
 
+  *-*-uwin*)
+    # Under some versions of uwin, vfork is notoriously buggy and the test 
+    # can hang configure; on other versions, vfork exists just as a stub.
+    # FIXME: This should be removed once vfork in uwin's runtime is fixed.
+    ac_cv_func_vfork_works=no
+    # Under uwin 2.0+, sys_nerr and sys_errlist exist, but they are
+    # macros (actually, these are imported from a DLL, but the end effect 
+    # is the same), so the test below won't find them.
+    AC_DEFINE(HAVE_SYS_NERR)
+    AC_DEFINE(HAVE_SYS_ERRLIST)
+    ;;
+
   esac
 
   # We haven't set the list of objects yet.  Use the standard autoconf
   # tests.  This will only work if the compiler works.
   AC_PROG_CC_WORKS
   AC_REPLACE_FUNCS($funcs)
-  AC_FUNC_ALLOCA
+
+  case "${host}" in
+  *-*-interix)
+    # On Interix, it wrongly concludes that the MSVC compiler supports alloca.
+    # (MSVC does on Win32, not on Interix.)
+    # This should be temporary.
+
+    ac_cv_header_alloca_h=no
+    ac_cv_func_alloca_works=no
+    ALLOCA=alloca.o
+    cat >> confdefs.h <<\EOF
+#define C_ALLOCA 1
+EOF
+    cat >> confdefs.h <<EOF
+#define STACK_DIRECTION -1
+EOF
+    ;;
+  *)
+    AC_FUNC_ALLOCA
+    ;;
+  esac
+
   AC_FUNC_VFORK
   if test $ac_cv_func_vfork_works = no; then
     LIBOBJS="$LIBOBJS vfork.o"
@@ -301,6 +352,8 @@ if test -z "${setobjs}"; then
   AC_CHECK_FUNCS($checkfuncs)
 fi
 
+libiberty_AC_FUNC_STRNCMP
+
 # Install a library built with a cross compiler in $(tooldir) rather
 # than $(libdir).
 if test -z "${with_cross_host}"; then
@@ -311,7 +364,7 @@ fi
 AC_SUBST(INSTALL_DEST)
 
 # We need multilib support, but only if configuring for the target.
-AC_OUTPUT(Makefile,
+AC_OUTPUT(Makefile testsuite/Makefile,
 [test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
 if test -n "$CONFIG_FILES"; then
   if test -n "${with_target_subdir}"; then