OSDN Git Service

PR other/46840
[pf3gnuchains/gcc-fork.git] / libgo / configure.ac
index db74974..d2cc290 100644 (file)
@@ -187,6 +187,11 @@ if test "$ac_cv_libgo_linker_supports_split_stack" = yes; then
            [Define if the linker support split stack adjustments])
 fi
 
            [Define if the linker support split stack adjustments])
 fi
 
+dnl Test for the -lm library.
+MATH_LIBS=
+AC_CHECK_LIB([m], [sqrt], MATH_LIBS=-lm)
+AC_SUBST(MATH_LIBS)
+
 dnl Test whether the compiler supports the -pthread option.
 AC_CACHE_CHECK([whether -pthread is supported],
 [ac_cv_libgo_pthread_supported],
 dnl Test whether the compiler supports the -pthread option.
 AC_CACHE_CHECK([whether -pthread is supported],
 [ac_cv_libgo_pthread_supported],