OSDN Git Service

PR 47571 Weakref trickery for clock_gettime()
[pf3gnuchains/gcc-fork.git] / libgfortran / configure.ac
index ed1e2cc..8161659 100644 (file)
@@ -486,11 +486,11 @@ AC_CHECK_LIB([m],[feenableexcept],[have_feenableexcept=yes AC_DEFINE([HAVE_FEENA
 
 # At least for glibc, clock_gettime is in librt.  But don't pull that
 # in if it still doesn't give us the function we want.
-# This test is copied from libgomp.
+# This test is copied from libgomp, and modified to not link in -lrt
+# as libgfortran calls clock_gettime via a weak reference.
 if test $ac_cv_func_clock_gettime = no; then
   AC_CHECK_LIB(rt, clock_gettime,
-    [LIBS="-lrt $LIBS"  
-     AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
+    [AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
                [Define to 1 if you have the `clock_gettime' function.])])
 fi