OSDN Git Service

gcc:
[pf3gnuchains/gcc-fork.git] / libcpp / configure.ac
index e9d57dc..aa93f65 100644 (file)
@@ -4,14 +4,31 @@
 AC_PREREQ(2.59)
 AC_INIT(cpplib, [ ], gcc-bugs@gcc.gnu.org, cpplib)
 AC_CONFIG_SRCDIR(ucnid.h)
+AC_CONFIG_MACRO_DIR(../config)
 AC_CANONICAL_SYSTEM
-AM_INIT_AUTOMAKE(foreign)
-AM_MAINTAINER_MODE
 
 # Checks for programs.
+AC_PROG_MAKE_SET
+AC_PROG_INSTALL
 AC_PROG_CC
 AC_PROG_RANLIB
 
+MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing
+AC_CHECK_PROGS([ACLOCAL], [aclocal], [$MISSING aclocal])
+AC_CHECK_PROGS([AUTOCONF], [autoconf], [$MISSING autoconf])
+AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
+
+# Figure out what compiler warnings we can enable.
+# See config/warnings.m4 for details.
+
+ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
+                         -Wmissing-prototypes -Wold-style-definition])
+ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
+
+# Only enable with --enable-werror-always until existing warnings are
+# corrected.
+ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual])
+
 # Checks for header files.
 AC_HEADER_TIME
 ACX_HEADER_STRING
@@ -29,7 +46,7 @@ AC_CHECK_SIZEOF(int)
 AC_CHECK_SIZEOF(long)
 AC_CHECK_FUNCS(putc_unlocked fputc_unlocked fputs_unlocked \
         fwrite_unlocked fprintf_unlocked)
-AC_CHECK_DECLS([abort, errno, putc_unlocked, fputc_unlocked,
+AC_CHECK_DECLS([abort, basename, errno, getopt, putc_unlocked, fputc_unlocked,
         fputs_unlocked, fwrite_unlocked, fprintf_unlocked])
 
 # Checks for library functions.
@@ -40,8 +57,7 @@ ZW_GNU_GETTEXT_SISTER_DIR
 
 AC_CACHE_CHECK(for uchar, gcc_cv_type_uchar,
 [AC_TRY_COMPILE([
-#include "ansidecl.h"
-#include "system.h"
+#include <sys/types.h>
 ],
 [if ((uchar *)0) return 0;
  if (sizeof(uchar)) return 0;],
@@ -52,7 +68,30 @@ if test $ac_cv_type_uchar = yes; then
 fi
 
 AM_ICONV
-AM_CONDITIONAL(ENABLE_NLS, [test "x$enable_nls" != xno])
+
+# More defines and substitutions.
+PACKAGE="$PACKAGE_TARNAME"
+AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Define to the name of this package.])
+AC_SUBST(PACKAGE)
+
+if test "x$enable_nls" != xno; then
+  USED_CATALOGS='$(CATALOGS)'
+else
+  USED_CATALOGS=
+fi
+AC_SUBST(USED_CATALOGS)
+
+AC_ARG_ENABLE(maintainer-mode,
+[  --enable-maintainer-mode enable rules only needed by maintainers],,
+enable_maintainer_mode=no)
+
+if test "x$enable_maintainer_mode" = xno; then
+  MAINT='#'
+else
+  MAINT=
+fi
+AC_SUBST(MAINT)
+
 AC_ARG_ENABLE(checking,
 [  --enable-checking      enable expensive run-time checks],,
 enable_checking=no)
@@ -70,6 +109,7 @@ case $target in
        x86_64-*-* | \
        ia64-*-* | \
        hppa*64*-*-* | parisc*64*-*-* | \
+       i[34567]86-*-solaris2.1[0-9]* | \
        mips*-*-* | \
        mmix-*-* | \
        powerpc*-*-* | \
@@ -77,7 +117,7 @@ case $target in
        s390*-*-* | \
        sparc64*-*-* | ultrasparc-*-freebsd* | \
        sparcv9-*-solaris2* | \
-       sparc-*-solaris2.[789] | sparc-*-solaris2.1[0-9] | \
+       sparc-*-solaris2.[789] | sparc-*-solaris2.1[0-9]* | \
        sh[123456789l]*-*-*)
                need_64bit_hwint=yes ;;
        *)
@@ -94,6 +134,8 @@ AC_DEFINE_UNQUOTED(HOST_WIDE_INT, $host_wide_int,
 [Define to the widest efficient host integer type at least
    as wide as the target's size_t type.])
 
-AC_CONFIG_HEADERS(config.h:config.in)
+# Output.
+
+AC_CONFIG_HEADERS(config.h:config.in, [echo timestamp > stamp-h1])
 AC_CONFIG_FILES(Makefile)
 AC_OUTPUT