OSDN Git Service

Daily bump.
[pf3gnuchains/gcc-fork.git] / libcpp / configure.ac
index 1250f49..6d525ec 100644 (file)
@@ -14,6 +14,9 @@ AC_PROG_CC
 AC_PROG_CXX
 AC_PROG_RANLIB
 
+AC_USE_SYSTEM_EXTENSIONS
+AC_SYS_LARGEFILE
+
 # See if we are building gcc with C++.
 # Do this early so setting lang to C++ affects following tests
 AC_ARG_ENABLE(build-with-cxx,
@@ -30,12 +33,16 @@ AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
 # Figure out what compiler warnings we can enable.
 # See config/warnings.m4 for details.
 
-ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings \
+ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wno-narrowing -Wwrite-strings \
                          -Wmissing-format-attribute], [warn])
 ACX_PROG_CC_WARNING_OPTS([-Wstrict-prototypes -Wmissing-prototypes \
                          -Wold-style-definition -Wc++-compat], [c_warn])
 ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
 
+# Disable exceptions and RTTI if building with g++
+ACX_PROG_CC_WARNING_OPTS(
+       m4_quote(m4_do([-fno-exceptions -fno-rtti])), [noexception_flags])
+
 # Only enable with --enable-werror-always until existing warnings are
 # corrected.
 ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual])
@@ -56,18 +63,8 @@ fi
 AC_HEADER_TIME
 ACX_HEADER_STRING
 
-# AC_CHECK_HEADERS is repeated to work around apparent autoconf 2.59 bug.  If
-# AC_CHECK_HEADERS comes after the if clause, the last AC_LANG call gets used,
-# no matter which branch is taken.
-if test "$ENABLE_BUILD_WITH_CXX" = "no"; then
-   AC_LANG(C)
-   AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
+AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
        stdlib.h strings.h string.h sys/file.h unistd.h)
-else
-   AC_LANG(C++)
-   AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
-       stdlib.h strings.h string.h sys/stat.h sys/file.h unistd.h)
-fi
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_C_BIGENDIAN
@@ -109,7 +106,13 @@ if test $ac_cv_type_uchar = yes; then
   [Define if <sys/types.h> defines \`uchar'.])
 fi
 
-AM_ICONV
+# g++ on Solaris 10+ defines _XOPEN_SOURCE=600, which exposes a different
+# iconv() prototype.
+AS_IF([test "$ENABLE_BUILD_WITH_CXX" = "yes"],
+  [AC_LANG_PUSH([C++])
+   AM_ICONV
+   AC_LANG_POP([C++])],
+  [AM_ICONV])
 
 # More defines and substitutions.
 PACKAGE="$PACKAGE_TARNAME"
@@ -147,13 +150,12 @@ m4_changequote(,)
 case $target in
        alpha*-*-* | \
        arm*-*-*eabi* | \
+       arm*-*-rtems[.0-9]* | \
        arm*-*-symbianelf* | \
        x86_64-*-* | \
        ia64-*-* | \
        hppa*64*-*-* | \
-       i[34567]86-*-darwin* | \
-       i[34567]86-*-solaris2.1[0-9]* | \
-       i[34567]86-w64-mingw* | \
+       i[34567]86-*-* | x86_64-*-solaris2.1[0-9]* | \
        mips*-*-* | \
        mmix-*-* | \
        powerpc*-*-* | \
@@ -161,15 +163,9 @@ case $target in
        s390*-*-* | \
        sparc*-*-* | \
        spu-*-* | \
-       sh[123456789lbe]*-*-* | sh-*-*)
+       sh[123456789lbe]*-*-* | sh-*-* | \
+       tilegx-*-* | tilepro-*-* )
                need_64bit_hwint=yes ;;
-       i[34567]86-*-linux*)
-               if test "x$enable_targets" = xall; then
-                       need_64bit_hwint=yes
-               else
-                       need_64bit_hwint=no
-               fi
-               ;;
        *)
                need_64bit_hwint=no ;;
 esac
@@ -184,6 +180,13 @@ AC_DEFINE_UNQUOTED(HOST_WIDE_INT, $host_wide_int,
 [Define to the widest efficient host integer type at least
    as wide as the target's size_t type.])
 
+case $target in
+  i?86-* | x86_64-*)
+    AC_TRY_COMPILE([], [asm ("pcmpestri %0, %%xmm0, %%xmm1" : : "i"(0))],
+      [AC_DEFINE([HAVE_SSE4], [1],
+                [Define to 1 if you can assemble SSE4 insns.])])
+esac
+
 # Output.
 
 AC_CONFIG_HEADERS(config.h:config.in, [echo timestamp > stamp-h1])