OSDN Git Service

contrib:
[pf3gnuchains/gcc-fork.git] / gcc / configure.in
index 0dae0e0..b3355e1 100644 (file)
@@ -1,7 +1,7 @@
 # configure.in for GNU CC
 # Process this file with autoconf to generate a configuration script.
 
-# Copyright (C) 1997, 1998, 1999, 2000 Free Software Foundation, Inc.
+# Copyright (C) 1997, 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
 
 #This file is part of GNU CC.
 
@@ -188,7 +188,7 @@ if test x${gcc_gxx_include_dir} = x; then
   else
     topsrcdir=${srcdir}/.. . ${srcdir}/../config.if
 changequote(<<, >>)dnl
-    gcc_gxx_include_dir="\$(libsubdir)/\$(unlibsubdir)/..\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/g++"-${libstdcxx_interface}
+    gcc_gxx_include_dir="\$(libsubdir)/\$(unlibsubdir)/..\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/"${libstdcxx_incdir}
 changequote([, ])dnl
   fi
 fi
@@ -271,21 +271,6 @@ elif test x$withval != xno; then
   cpp_install_dir=$withval
 fi])
 
-# Link cpplib into the compiler proper, for C/C++/ObjC.  Defaults to on.
-maybe_cpplib=libcpp.a
-AC_ARG_ENABLE(c-cpplib,
-[  --enable-c-cpplib       link cpplib directly into C and C++ compilers
-                           (HIGHLY EXPERIMENTAL).],
-[if test x$enable_c_cpplib != xyes; then
-  maybe_cpplib=
-fi]
-)
-if test x$maybe_cpplib != x ; then
-  AC_DEFINE(USE_CPPLIB, 1,
-  [Define if you want the preprocessor merged into the C and C++ compilers.])
-fi
-AC_SUBST(maybe_cpplib)
-
 # Enable Multibyte Characters for C/C++
 AC_ARG_ENABLE(c-mbchar,
 [  --enable-c-mbchar       Enable multibyte characters for C and C++.],
@@ -461,6 +446,9 @@ AC_CHECK_HEADER(pthread.h, [have_pthread_h=yes], [have_pthread_h=])
 # See if GNAT has been installed
 AC_CHECK_PROG(gnat, gnatbind, yes, no)
 
+# See if we have the mktemp command.
+AC_CHECK_PROG(have_mktemp_command, mktemp, yes, no)
+
 # Do we have a single-tree copy of texinfo?
 if test -f $srcdir/../texinfo/Makefile.in; then
   MAKEINFO='$(objdir)/../texinfo/makeinfo/makeinfo'
@@ -471,18 +459,26 @@ else
   # that we can use it.
   gcc_AC_CHECK_PROG_VER(MAKEINFO, makeinfo, --version,
   [GNU texinfo.* \([0-9][0-9.]*\)],
-  [3.1[2-9] | 3.[2-9][0-9] | 4.* | 1.6[89] | 1.7[0-9]])
+  [4.*])
 fi
 
 if test $gcc_cv_prog_makeinfo_modern = no; then
   AC_MSG_WARN([
 *** Makeinfo is missing or too old.
-*** Info documentation will not be built or installed.])
+*** Info documentation will not be built.])
   BUILD_INFO=
-  INSTALL_INFO=
 else
   BUILD_INFO=info              AC_SUBST(BUILD_INFO)
-  INSTALL_INFO=install-info    AC_SUBST(INSTALL_INFO)
+fi
+
+# Is pod2man recent enough to regenerate manpages?
+AC_MSG_CHECKING([for recent Pod::Man])
+if perl -e 'use 1.10 Pod::Man' >/dev/null 2>&1; then
+  AC_MSG_RESULT(yes)
+  GENERATED_MANPAGES=generated-manpages                AC_SUBST(GENERATED_MANPAGES)
+else
+  AC_MSG_RESULT(no)
+  GENERATED_MANPAGES=
 fi
 
 # How about lex?
@@ -545,7 +541,7 @@ fi
 AC_CHECK_FUNCS(strtoul bsearch putenv popen bcopy \
        strchr strrchr kill getrlimit setrlimit atoll atoq \
        sysconf isascii gettimeofday strsignal putc_unlocked fputc_unlocked \
-       fputs_unlocked getrusage valloc iconv nl_langinfo)
+       fputs_unlocked getrusage iconv nl_langinfo)
 
 AC_CHECK_TYPE(ssize_t, int)
 
@@ -574,10 +570,9 @@ gcc_AC_FUNC_PRINTF_PTR
 
 case "${host}" in
 *-*-uwin*)
-  # Under some versions of uwin, vfork is notoriously buggy and the test 
-  # can hang configure; on other versions, vfork exists just as a stub.
-  # FIXME: This should be removed once vfork in uwin's runtime is fixed.
-  ac_cv_func_vfork_works=no
+  AC_MSG_ERROR([
+*** UWIN may not be used as a host platform because
+*** linking with posix.dll is not allowed by the GNU GPL])
   ;;
 esac
 AC_FUNC_VFORK
@@ -638,7 +633,7 @@ extra_objs="${host_extra_objs} ${extra_objs}"
 if test x"$tm_file" = x
 then tm_file=$cpu_type/$cpu_type.h; fi
 
-if test x$extra_headers = x
+if test x"$extra_headers" = x
 then extra_headers=; fi
 
 if test x"$xm_file" = x
@@ -750,7 +745,7 @@ else
        mkdir $tempdir
        cd $tempdir
        case ${srcdir} in
-       /*) realsrcdir=${srcdir};;
+       /* | [A-Za-z]:[\\/]* ) realsrcdir=${srcdir};;
        *) realsrcdir=../${srcdir};;
        esac
        CC=${CC_FOR_BUILD} ${realsrcdir}/configure \
@@ -815,6 +810,15 @@ do
                echo "#define $def" >>$link
                echo "#endif" >>$link
        done
+
+       if test $link = tm.h
+       then
+               # Include insn-codes.h last, because it includes machmode.h,
+               # and we want EXTRA_CC_MODES to be taken into account.
+               echo "#ifndef GENERATOR_FILE" >>$link
+               echo "#include \"insn-codes.h\"" >>$link
+               echo "#endif" >>$link
+       fi
 done
 
 # Truncate the target if necessary
@@ -856,7 +860,7 @@ AC_DEFINE_UNQUOTED(VERSION, "$VERSION",
 AC_SUBST(PACKAGE)
 AC_SUBST(VERSION)
 
-ALL_LINGUAS="en_GB"
+ALL_LINGUAS="sv"
 
 # Enable NLS support by default
 AC_ARG_ENABLE(nls,
@@ -1077,20 +1081,6 @@ else
        maybe_use_collect2="-DUSE_COLLECT2"
 fi
 
-# NEED TO CONVERT
-# Set MD_DEPS if the real md file is in md.pre-cpp.
-# Set MD_CPP to the cpp to pass the md file through.  Md files use ';'
-# for line oriented comments, so we must always use a GNU cpp.  If
-# building gcc with a cross compiler, use the cross compiler just
-# built.  Otherwise, we can use the cpp just built.
-md_file_sub=
-if test "x$md_cppflags" = x
-then
-       md_file_sub=$srcdir/config/$md_file
-else
-       md_file=md
-fi
-
 # If we have gas in the build tree, make a link to it.
 if test -f ../gas/Makefile; then
        rm -f as; $symbolic_link ../gas/as-new$host_exeext as$host_exeext 2>/dev/null
@@ -1466,7 +1456,7 @@ gcc_cv_as_dwarf2_debug_line=no
 # ??? Once 2.11 is released, probably need to add first known working
 # version to the per-target configury.
 case "$target" in
-  i?86*-*-* | mips*-*-* | alpha*-*-*)
+  i?86*-*-* | mips*-*-* | alpha*-*-* | powerpc*-*-* | sparc*-*-*)
     insn="nop"
     ;;
   ia64*-*-*)
@@ -1524,23 +1514,19 @@ changequote(,)dnl
        ${srcdir}/[*]/config-lang.in) ;;
        *)
          lang_alias=`sed -n -e 's,^language=['"'"'"'"]\(.*\)["'"'"'"'].*$,\1,p' -e 's,^language=\([^   ]*\).*$,\1,p' $lang`
+         this_lang_libs=`sed -n -e 's,^target_libs=['"'"'"'"]\(.*\)["'"'"'"'].*$,\1,p' -e 's,^target_libs=\([^         ]*\).*$,\1,p' $lang`
+         build_by_default=`sed -n -e 's,^build_by_default=['"'"'"'"]\(.*\)["'"'"'"'].*$,\1,p' -e 's,^build_by_default=\([^     ]*\).*$,\1,p' $lang`
          if test "x$lang_alias" = x
          then
                echo "$lang doesn't set \$language." 1>&2
                exit 1
          fi
-         if test x"${enable_languages}" = xall && test x"${lang_alias}" != xCHILL; then
-               add_this_lang=yes
-         else
-               case "${enable_languages}" in
-                   ${lang_alias} | "${lang_alias},"* | *",${lang_alias},"* | *",${lang_alias}" )
-                       add_this_lang=yes
-                       ;;
-                   * )
-                       add_this_lang=no
-                       ;;
-               esac
-         fi
+         case ${build_by_default},${enable_languages}, in
+         *,$lang_alias,*) add_this_lang=yes ;;
+         no,*) add_this_lang=no ;;
+         *,all,*) add_this_lang=yes ;;
+         *) add_this_lang=no ;;
+         esac
          if test x"${add_this_lang}" = xyes; then
                case $lang in
                    ${srcdir}/ada/config-lang.in)
@@ -1579,12 +1565,7 @@ AC_ARG_WITH(gc,
     AC_MSG_ERROR([$withval is an invalid option to --with-gc])
     ;;
 esac],
-[if test $ac_cv_func_mmap_anywhere = yes \
-    || test $ac_cv_func_valloc = yes; then
-  GGC=ggc-page
-else
-  GGC=ggc-simple
-fi])
+[GGC=ggc-page])
 AC_SUBST(GGC)
 echo "Using $GGC for garbage collection."
 
@@ -1605,11 +1586,16 @@ AC_ARG_ENABLE(new-gxx-abi,
                          select the new abi for g++. You must select an ABI
                          at configuration time, so that the correct runtime
                          support is built. You cannot mix ABIs.],
-[AC_DEFINE(ENABLE_NEW_GXX_ABI, 1,
-       [Define if you want to always select the new-abi for g++.])
-GXX_ABI_FLAG='-fnew-abi'
-echo "Building a new-abi g++ compiler."
-])
+   ,
+  enable_new_gxx_abi=yes)
+
+if test x$enable_new_gxx_abi = xyes; then
+  AC_DEFINE(ENABLE_NEW_GXX_ABI, 1,
+           [Define if you want to always select the new-abi for g++.])
+  GXX_ABI_FLAG='-fnew-abi'
+else
+  GXX_ABI_FLAG=
+fi
 AC_SUBST(GXX_ABI_FLAG)
 
 AC_DEFINE_UNQUOTED(ENABLE_STD_NAMESPACE, $ac_esn,
@@ -1810,6 +1796,24 @@ fi
 AC_SUBST(gcc_tooldir)
 AC_SUBST(dollar)
 
+# Find a directory in which to install a shared libgcc.
+
+AC_ARG_ENABLE(version-specific-runtime-libs,
+[  --enable-version-specific-runtime-libs    Specify that runtime libraries shou
+ld be installed in a compiler-specific directory ])
+
+AC_ARG_WITH(slibdir,
+[  --with-slibdir=DIR      shared libraries in DIR [LIBDIR]],
+slibdir="$with_slibdir",
+if test "${enable_version_specific_runtime_libs+set}" = set; then
+  slibdir='$(libsubdir)'
+elif test "$host" != "$target"; then
+  slibdir='$(build_tooldir)/lib'
+else
+  slibdir='$(libdir)'
+fi)
+AC_SUBST(slibdir)
+
 # Nothing to do for FLOAT_H, float_format already handled.
 objdir=`pwd`
 AC_SUBST(objdir)
@@ -1844,6 +1848,7 @@ AC_SUBST(extra_programs)
 AC_SUBST(float_h_file)
 AC_SUBST(gcc_config_arguments)
 AC_SUBST(gcc_gxx_include_dir)
+AC_SUBST(libstdcxx_incdir)
 AC_SUBST(gcc_version)
 AC_SUBST(gcc_version_full)
 AC_SUBST(gcc_version_trigger)
@@ -1865,6 +1870,8 @@ AC_SUBST(symbolic_link)
 AC_SUBST(thread_file)
 AC_SUBST(tm_file_list)
 AC_SUBST(will_use_collect2)
+AC_SUBST(c_target_objs)
+AC_SUBST(cxx_target_objs)
 
 
 AC_SUBST_FILE(target_overrides)