OSDN Git Service

* configure.in (m68*-*-rtemscoff*): New target, formal name for
[pf3gnuchains/gcc-fork.git] / gcc / configure.in
index 52cfbc5..1cb5bdb 100644 (file)
@@ -1,7 +1,7 @@
 # configure.in for GNU CC
 # Process this file with autoconf to generate a configuration script.
 
-# Copyright (C) 1997, 1998, 1999 Free Software Foundation, Inc.
+# Copyright (C) 1997, 1998, 1999, 2000 Free Software Foundation, Inc.
 
 #This file is part of GNU CC.
 
@@ -513,6 +513,9 @@ changequote([,])dnl
        mips*-*-*)
                cpu_type=mips
                ;;
+       pj*-*-*)
+               cpu_type=pj
+               ;;
        powerpc*-*-*)
                cpu_type=rs6000
                ;;
@@ -2269,13 +2272,13 @@ changequote([,])dnl
                extra_headers=math-68881.h
                float_format=m68k
                ;;
-       m68k-*-rtemscoff*|m68k-*-rtems*)
+       m68k-*-rtemscoff*)
                tmake_file="m68k/t-m68kbare t-rtems"
                tm_file=m68k/rtems.h
                extra_headers=math-68881.h
                float_format=m68k
                ;;
-       m68k-*-rtemself*)
+       m68k-*-rtemself*|m68k-*-rtems*)
                tmake_file="m68k/t-m68kbare t-rtems m68k/t-crtstuff"
                tm_file=m68k/rtemself.h
                extra_headers=math-68881.h
@@ -2808,7 +2811,6 @@ changequote([,])dnl
                ;;
        mips64orion-*-rtems*)
                tm_file="mips/elforion.h mips/elf64.h mips/rtems64.h"
-                tm_file="mips/elforion.h mips/elf64.h mips/rtems64.h"
                tmake_file="mips/t-elf t-rtems"
                ;;
        mipstx39el-*-elf*)
@@ -2835,6 +2837,7 @@ changequote([,])dnl
                fi
                ;;
        mn10200-*-*)
+               float_format=i32
                cpu_type=mn10200
                tm_file="mn10200/mn10200.h"
                if test x$stabs = xyes
@@ -2910,6 +2913,16 @@ changequote([,])dnl
 #              xmake_file=pyr/x-pyr
 #              use_collect2=yes
 #              ;;
+
+       pj*-linux*)
+               tm_file="svr4.h pj/linux.h ${tm_file}"
+               ;;
+       pj-*)
+               ;;
+       pjl-*)
+               tm_file="svr4.h pj/pjl.h ${tm_file}"
+               ;;
+
        romp-*-aos*)
                use_collect2=yes
                ;;
@@ -3257,6 +3270,9 @@ changequote([,])dnl
                tmake_file=sparc/t-sunos41
                xmake_file=x-lynx
                ;;
+       sparc-*-rtemsaout*)
+               tmake_file="sparc/t-sparcbare t-rtems"
+               tm_file=sparc/rtems.h
        sparc-*-rtems*|sparc-*-rtemself*)
                tm_file="sparc/rtemself.h"
                tmake_file="sparc/t-elf t-rtems"
@@ -3264,9 +3280,6 @@ changequote([,])dnl
                #float_format=i128
                float_format=i64
                ;;
-       sparc-*-rtemsaout*)
-               tmake_file="sparc/t-sparcbare t-rtems"
-               tm_file=sparc/rtems.h
                ;;
        sparcv9-*-solaris2*)
                if test x$gnu_ld = xyes
@@ -3496,6 +3509,17 @@ changequote([,])dnl
 #              cpu_type=gmicro
 #              use_collect2=yes
 #              ;;
+       v850-*-rtems*)
+               cpu_type=v850
+               tm_file="v850/rtems.h"
+               xm_file="v850/xm-v850.h"
+               tmake_file="v850/t-v850 t-rtems"
+               if test x$stabs = xyes
+               then
+                       tm_file="${tm_file} dbx.h"
+               fi
+               use_collect2=no
+               ;;
        v850-*-*)
                target_cpu_default="TARGET_CPU_generic"
                cpu_type=v850