OSDN Git Service

* config.gcc (extra_options): New variable for listing option files.
[pf3gnuchains/gcc-fork.git] / gcc / configure.ac
index f1295d4..dedb800 100644 (file)
@@ -100,6 +100,8 @@ AC_MSG_ERROR([
 *** and run configure again.])
 fi
 
+TL_AC_GCC_VERSION([$srcdir/..])
+
 # -----------
 # Directories
 # -----------
@@ -137,7 +139,7 @@ if test x${gcc_gxx_include_dir} = x; then
   if test x${enable_version_specific_runtime_libs} = xyes; then
     gcc_gxx_include_dir='${libsubdir}/include/c++'
   else
-    topsrcdir=${srcdir}/.. . ${srcdir}/../config.if
+    libstdcxx_incdir=c++/${gcc_version}
 changequote(<<, >>)dnl
     gcc_gxx_include_dir="\$(libsubdir)/\$(unlibsubdir)/..\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/"${libstdcxx_incdir}
 changequote([, ])dnl
@@ -269,7 +271,7 @@ rm -f a.out a.exe b.out
 
 # Find the native compiler
 AC_PROG_CC
-AC_PROG_CC_C_O
+AM_PROG_CC_C_O
 # autoconf is lame and doesn't give us any substitution variable for this.
 if eval "test \"`echo '$ac_cv_prog_cc_'${ac_cc}_c_o`\" = no"; then
   NO_MINUS_C_MINUS_O=yes
@@ -289,15 +291,15 @@ AC_C_INLINE
 gcc_AC_C_LONG_LONG
 
 # sizeof(char) is 1 by definition.
-AC_COMPILE_CHECK_SIZEOF(void *)
-AC_COMPILE_CHECK_SIZEOF(short)
-AC_COMPILE_CHECK_SIZEOF(int)
-AC_COMPILE_CHECK_SIZEOF(long)
+AC_CHECK_SIZEOF(void *)
+AC_CHECK_SIZEOF(short)
+AC_CHECK_SIZEOF(int)
+AC_CHECK_SIZEOF(long)
 if test $ac_cv_c_long_long = yes; then
-  AC_COMPILE_CHECK_SIZEOF(long long)
+  AC_CHECK_SIZEOF(long long)
 fi
 if test $ac_cv_c___int64 = yes; then
-  AC_COMPILE_CHECK_SIZEOF(__int64)
+  AC_CHECK_SIZEOF(__int64)
 fi
 
 # ---------------------
@@ -392,52 +394,53 @@ AC_ARG_ENABLE(checking,
 [  --enable-checking[=LIST]
                          enable expensive run-time checks.  With LIST,
                          enable only specific categories of checks.
-                         Categories are: none,assert,fold,gc,gcac,misc,
-                         rtlflag,rtl,tree,valgrind;
-                         default is assert,gc,misc,rtlflag,tree],
-[ac_checking=
+                         Categories are: assert,fold,gc,gcac,misc,
+                         rtlflag,rtl,tree,valgrind,release,yes,all;],
+[ac_checking_flags="${enableval}"],[
+# Determine the default checks.
+if test x$is_release = x ; then
+  ac_checking_flags=yes
+else
+  ac_checking_flags=release
+fi])
+ac_assert_checking=1
+ac_checking=
 ac_tree_checking=
 ac_rtl_checking=
 ac_rtlflag_checking=
 ac_gc_checking=
 ac_gc_always_collect=
 ac_fold_checking=
-ac_assert_checking=
-case "${enableval}" in
-yes)   ac_checking=1 ; ac_tree_checking=1 ; ac_gc_checking=1 ;
-       ac_rtlflag_checking=1 ; ac_assert_checking=1 ;;
-no)    ;;
-*)     IFS="${IFS=     }"; ac_save_IFS="$IFS"; IFS="$IFS,"
-       set fnord $enableval; shift
-       IFS="$ac_save_IFS"
-       ac_assert_checking=1
-       for check
-       do
-               case $check in
-               assert) ac_assert_checking=1 ;;
-               fold)   ac_fold_checking=1 ;;
-               gc)     ac_gc_checking=1 ;;
-               gcac)   ac_gc_always_collect=1 ;;
-               misc)   ac_checking=1 ;;
-               rtlflag)        ac_rtlflag_checking=1 ;;
-               rtl)    ac_rtl_checking=1 ;;
-               tree)   ac_tree_checking=1 ;;
-               valgrind)       ac_checking_valgrind=1 ;;
-               *)      AC_MSG_ERROR(unknown check category $check) ;;
-               esac
-       done
-       ;;
-esac
-], [
-# Determine the default checks.
-if test x$is_release = x ; then
-  # Enable some checks for development versions of GCC
-  ac_assert_checking=1;
-  ac_checking=1; ac_tree_checking=1; ac_gc_checking=1; ac_rtlflag_checking=1;
-else
-  # Disable all but assertions for release versions of GCC.
-  ac_assert_checking=1;
-fi])
+IFS="${IFS=    }"; ac_save_IFS="$IFS"; IFS="$IFS,"
+for check in $ac_checking_flags
+do
+       case $check in
+       yes)            ac_assert_checking=1 ; ac_checking=1 ;
+                       ac_tree_checking=1 ; ac_gc_checking=1 ;
+                       ac_rtlflag_checking=1 ;;
+       no)             ac_assert_checking= ; ac_checking= ;
+                       ac_tree_checking= ; ac_rtl_checking= ;
+                       ac_rtlflag_checking= ; ac_gc_checking= ;
+                       ac_gc_always_collect= ; ac_fold_checking= ;;
+       all)            ac_assert_checking=1 ; ac_checking=1 ;
+                       ac_tree_checking=1 ; ac_rtl_checking=1 ;
+                       ac_rtlflag_checking=1 ; ac_gc_checking=1 ;
+                       ac_gc_always_collect=1 ; ac_fold_checking=1 ;;
+        release)       ac_assert_checking=1 ;;
+       assert)         ac_assert_checking=1 ;;
+       fold)           ac_fold_checking=1 ;;
+       gc)             ac_gc_checking=1 ;;
+       gcac)           ac_gc_always_collect=1 ;;
+       misc)           ac_checking=1 ;;
+       rtlflag)        ac_rtlflag_checking=1 ;;
+       rtl)            ac_rtl_checking=1 ;;
+       tree)           ac_tree_checking=1 ;;
+       valgrind)       ac_checking_valgrind=1 ;;
+       *)      AC_MSG_ERROR(unknown check category $check) ;;
+       esac
+done
+IFS="$ac_save_IFS"
+
 nocommon_flag=""
 if test x$ac_checking != x ; then
   AC_DEFINE(ENABLE_CHECKING, 1,
@@ -862,7 +865,7 @@ AC_HEADER_STDC
 AC_HEADER_TIME
 ACX_HEADER_STRING
 AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(limits.h stddef.h string.h strings.h stdlib.h time.h \
+AC_CHECK_HEADERS(limits.h stddef.h string.h strings.h stdlib.h time.h iconv.h \
                 fcntl.h unistd.h sys/file.h sys/time.h sys/mman.h \
                 sys/resource.h sys/param.h sys/times.h sys/stat.h \
                 direct.h malloc.h langinfo.h ldfcn.h locale.h wchar.h)
@@ -1023,6 +1026,8 @@ AC_SUBST(LIBICONV_DEP)
 
 AM_LC_MESSAGES
 
+AM_LANGINFO_CODESET
+
 # We will need to find libiberty.h and ansidecl.h
 saved_CFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS -I${srcdir} -I${srcdir}/../include"
@@ -1050,10 +1055,16 @@ AC_TRY_COMPILE([
 ],[rlim_t l = 0;],,[AC_DEFINE([rlim_t],[long],
 [Define to \`long' if <sys/resource.h> doesn't define.])])
 
+# On AIX 5.2, <ldfcn.h> conflicts with <fcntl.h>, as both define incompatible
+# FREAD and FWRITE macros.  Fortunately, for GCC's single usage of ldgetname
+# in collect2.c, <fcntl.h> isn't visible, but the configure test below needs
+# to undef these macros to get the correct value for HAVE_DECL_LDGETNAME.
 gcc_AC_CHECK_DECLS(ldgetname, , ,[
 #include "ansidecl.h"
 #include "system.h"
 #ifdef HAVE_LDFCN_H
+#undef FREAD
+#undef FWRITE
 #include <ldfcn.h>
 #endif
 ])
@@ -1114,20 +1125,10 @@ AC_ARG_ENABLE(sjlj-exceptions,
 AC_DEFINE_UNQUOTED(CONFIG_SJLJ_EXCEPTIONS, $sjlj,
   [Define 0/1 to force the choice for exception handling model.])])
 
-if test x$host = x$target; then
-   AC_CHECK_LIB(unwind, main, use_libunwind_default=yes, use_libunwind_default=no)
-else
-   use_libunwind_default=no
-fi
-# Use libunwind based exception handling.
-AC_ARG_ENABLE(libunwind-exceptions,
-[  --enable-libunwind-exceptions  force use libunwind for exceptions],
-use_libunwind_exceptions=$enableval,
-use_libunwind_exceptions=$use_libunwind_default)
-if test x"$use_libunwind_exceptions" = xyes; then
-   AC_DEFINE(USE_LIBUNWIND_EXCEPTIONS, 1,
-       [Define if gcc should use -lunwind.])
-fi
+# For platforms with the unwind ABI which includes an unwind library,
+# libunwind, we can choose to use the system libunwind.
+AC_ARG_WITH(system-libunwind,
+[  --with-system-libunwind use installed libunwind])
 
 # --------------------------------------------------------
 # Build, host, and target specific configuration fragments
@@ -1273,7 +1274,7 @@ case ${enable_threads} in
     # default
     target_thread_file='single'
     ;;
-  aix | dce | gnat | irix | posix | rtems | \
+  aix | dce | gnat | irix | posix | posix95 | rtems | \
   single | solaris | vxworks | win32 )
     target_thread_file=${enable_threads}
     ;;
@@ -1302,15 +1303,24 @@ AC_SUBST(gthread_flags)
 # UNSORTED
 # --------
 
+use_cxa_atexit=no
 if test x$enable___cxa_atexit = xyes || \
    test x$enable___cxa_atexit = x -a x$default_use_cxa_atexit = xyes; then
-   AC_CHECK_FUNC(__cxa_atexit,
-       [AC_DEFINE(DEFAULT_USE_CXA_ATEXIT, 1,
-       [Define if you want to use __cxa_atexit, rather than atexit, to
-       register C++ destructors for local statics and global objects.
-       This is essential for fully standards-compliant handling of
-       destructors, but requires __cxa_atexit in libc.])],
-       echo "__cxa_atexit can't be enabled on this target")
+  if test x$host = x$target; then
+    AC_CHECK_FUNC(__cxa_atexit,[use_cxa_atexit=yes],
+       [echo "__cxa_atexit can't be enabled on this target"])
+  else
+    # We can't check for __cxa_atexit when building a cross, so assume
+    # it is available 
+    use_cxa_atexit=yes
+  fi
+  if test x$use_cxa_atexit = xyes; then
+    AC_DEFINE(DEFAULT_USE_CXA_ATEXIT, 1,
+      [Define if you want to use __cxa_atexit, rather than atexit, to
+      register C++ destructors for local statics and global objects.
+      This is essential for fully standards-compliant handling of
+      destructors, but requires __cxa_atexit in libc.])
+  fi
 fi
 
 # Look for a file containing extra machine modes.
@@ -1322,6 +1332,13 @@ if test -n "$extra_modes" && test -f $srcdir/config/$extra_modes; then
    for this architecture.])
 fi
 
+# Convert extra_options into a form suitable for Makefile use.
+extra_opt_files=
+for f in $extra_options; do
+  extra_opt_files="$extra_opt_files \$(srcdir)/config/$f"
+done
+AC_SUBST(extra_opt_files)
+
 # auto-host.h is the file containing items generated by autoconf and is
 # the first file included by config.h.
 # If host=build, it is correct to have bconfig include auto-host.h
@@ -1330,7 +1347,6 @@ fi
 if test x$host = x$build
 then
        build_auto=auto-host.h
-       FORBUILD=..
 else
        # We create a subdir, then run autoconf in the subdir.
        # To prevent recursion we set host and build for the new
@@ -1357,9 +1373,8 @@ else
        cd ..
        rm -rf $tempdir
        build_auto=auto-build.h
-       FORBUILD=../${build_subdir}
 fi
-AC_SUBST(FORBUILD)
+AC_SUBST(build_subdir)
 
 tm_file="${tm_file} defaults.h"
 tm_p_file="${tm_p_file} tm-preds.h"
@@ -1373,16 +1388,7 @@ xm_file="ansidecl.h ${xm_file}"
 # UNSORTED
 # --------
 
-# Get the version trigger filename from the toplevel
-if test "${with_gcc_version_trigger+set}" = set; then
-       gcc_version_trigger=$with_gcc_version_trigger
-else
-       gcc_version_trigger=${srcdir}/version.c
-fi
 changequote(,)dnl
-gcc_version_full=`grep version_string ${gcc_version_trigger} | sed -e 's/.*"\([^"]*\)".*/\1/'`
-gcc_version=`echo ${gcc_version_full} | sed -e 's/\([^ ]*\) .*/\1/'`
-
 # Compile in configure arguments.
 if test -f configargs.h ; then
        # Being re-configured.
@@ -1501,37 +1507,33 @@ do
 done
 tmake_file="${tmake_file_}"
 
-symbolic_link='ln -s'
-
 # If the host doesn't support symlinks, modify CC in
 # FLAGS_TO_PASS so CC="stage1/xgcc -Bstage1/" works.
 # Otherwise, we can use "CC=$(CC)".
 rm -f symtest.tem
-if $symbolic_link $srcdir/gcc.c symtest.tem 2>/dev/null
-then
-       cc_set_by_configure="\$(CC)"
-       quoted_cc_set_by_configure="\$(CC)"
-       stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
-       quoted_stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
-else
-       rm -f symtest.tem
-       if cp -p $srcdir/gcc.c symtest.tem 2>/dev/null
-       then
-               symbolic_link="cp -p"
-       else
-               symbolic_link="cp"
-       fi
-       cc_set_by_configure="\`case '\$(CC)' in stage*) echo '\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\$(CC)';; esac\`"
-       quoted_cc_set_by_configure="\\\`case '\\\$(CC)' in stage*) echo '\\\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(CC)';; esac\\\`"
-       stage_prefix_set_by_configure="\`case '\$(STAGE_PREFIX)' in stage*) echo '\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\$(STAGE_PREFIX)';; esac\`"
-       quoted_stage_prefix_set_by_configure="\\\`case '\\\$(STAGE_PREFIX)' in stage*) echo '\\\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(STAGE_PREFIX)';; esac\\\`"
-fi
-rm -f symtest.tem
+case "$LN_S" in
+       *-s*)
+               cc_set_by_configure="\$(CC)"
+               quoted_cc_set_by_configure="\$(CC)"
+               stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
+               quoted_stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
+               ;;
+       *)
+               cc_set_by_configure="\`case '\$(CC)' in stage*) echo '\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\$(CC)';; esac\`"
+               quoted_cc_set_by_configure="\\\`case '\\\$(CC)' in stage*) echo '\\\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(CC)';; esac\\\`"
+               stage_prefix_set_by_configure="\`case '\$(STAGE_PREFIX)' in stage*) echo '\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\$(STAGE_PREFIX)';; esac\`"
+               quoted_stage_prefix_set_by_configure="\\\`case '\\\$(STAGE_PREFIX)' in stage*) echo '\\\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(STAGE_PREFIX)';; esac\\\`"
+               ;;
+esac
+
+# This is a terrible hack which will go away some day.
+host_cc_for_libada=${CC}
+AC_SUBST(host_cc_for_libada)
 
 out_object_file=`basename $out_file .c`.o
 
-tm_file_list=
-tm_include_list=
+tm_file_list="options.h"
+tm_include_list="options.h"
 for f in $tm_file; do
   case $f in
     defaults.h )
@@ -1692,18 +1694,12 @@ then
     BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
 
     if test "x$TARGET_SYSTEM_ROOT" = x; then
-       STMP_FIXINC=
-       STMP_FIXPROTO=
+       if [ "x$STMP_FIXPROTO" != x ] ; then
+         STMP_FIXPROTO=stmp-install-fixproto
+       fi
     fi
 fi
 
-# When bootstrapping from the toplevel, only run fixincludes during stage1
-if test -d ../prev-gcc
-then
-    STMP_FIXINC=
-    cp -R ../prev-gcc/include include
-fi
-
 # Expand extra_headers to include complete path.
 # This substitutes for lots of t-* files.
 extra_headers_list=
@@ -1753,9 +1749,9 @@ gcc_cv_gas_minor_version=
 gcc_cv_as_gas_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/gas
 if test -x "$DEFAULT_ASSEMBLER"; then
        gcc_cv_as="$DEFAULT_ASSEMBLER"
-elif test -x as$host_exeext; then
+elif test -x as$build_exeext; then
        # Build using assembler in the current directory.
-       gcc_cv_as=./as$host_exeext
+       gcc_cv_as=./as$build_exeext
 elif test -f $gcc_cv_as_gas_srcdir/configure.in \
      && test -f ../gas/Makefile \
      && test x$build = x$host; then
@@ -1764,8 +1760,8 @@ elif test -f $gcc_cv_as_gas_srcdir/configure.in \
   # we'll use what we're building after installation anyway.
   in_tree_gas=yes
   _gcc_COMPUTE_GAS_VERSION
-  rm -f as$host_exeext
-  $symbolic_link ../gas/as-new$host_exeext as$host_exeext 2>/dev/null
+  rm -f as$build_exeext
+  $LN_S ../gas/as-new$build_exeext as$build_exeext 2>/dev/null
   in_tree_gas_is_elf=no
   if grep 'obj_format = elf' ../gas/Makefile > /dev/null \
      || (grep 'obj_format = multi' ../gas/Makefile \
@@ -1803,22 +1799,28 @@ if test "x$gcc_cv_as" = x; then
        fi
 
        # If the loop below does not find an assembler, then use whatever
-       # one we can find in the users's path.
-       # user's path.
+       # one we can find in the users's path.  We are looking for a
+       # ${build} -> ${target} assembler.
        if test "x$program_prefix" != xNONE; then
-               gcc_cv_as=${program_prefix}as$host_exeext
+               gcc_cv_as=${program_prefix}as$build_exeext
+       elif test x$build != x$host && test x$build != x$target; then
+               gcc_cv_as=${target_noncanonical}-as$build_exeext
        else
-               gcc_cv_as=`echo as | sed "${program_transform_name}"`$host_exeext
+               gcc_cv_as=`echo as | sed "${program_transform_name}"`$build_exeext
        fi
 
-       test_dirs="$test_prefix/libexec/gcc/$target_noncanonical/$gcc_version \
-                  $test_prefix/libexec/gcc/$target_noncanonical \
-                  /usr/lib/gcc/$target_noncanonical/$gcc_version \
-                  /usr/lib/gcc/$target_noncanonical \
-                  $test_prefix/$target_noncanonical/bin/$target_noncanonical/$gcc_version \
-                  $test_prefix/$target_noncanonical/bin"
+       if test x$host = x$build; then
+           test_dirs="$test_prefix/libexec/gcc/$target_noncanonical/$gcc_version \
+                      $test_prefix/libexec/gcc/$target_noncanonical \
+                      /usr/lib/gcc/$target_noncanonical/$gcc_version \
+                      /usr/lib/gcc/$target_noncanonical \
+                      $test_prefix/$target_noncanonical/bin/$target_noncanonical/$gcc_version \
+                      $test_prefix/$target_noncanonical/bin"
+       else
+           test_dirs=
+       fi
 
-       if test x$host = x$target; then
+       if test x$build = x$target; then
            test_dirs="$test_dirs \
                   /usr/libexec \
                   /usr/ccs/gcc \
@@ -1833,8 +1835,8 @@ if test "x$gcc_cv_as" = x; then
        fi
 
        for dir in $test_dirs; do
-               if test -x $dir/as$host_exeext; then
-                       gcc_cv_as=$dir/as$host_exeext
+               if test -x $dir/as$build_exeext; then
+                       gcc_cv_as=$dir/as$build_exeext
                        break;
                fi
        done
@@ -1864,9 +1866,9 @@ gcc_cv_ld_gld_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/ld
 gcc_cv_ld_bfd_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/bfd
 if test -x "$DEFAULT_LINKER"; then
        gcc_cv_ld="$DEFAULT_LINKER"
-elif test -x collect-ld$host_exeext; then
+elif test -x collect-ld$build_exeext; then
        # Build using linker in the current directory.
-       gcc_cv_ld=./collect-ld$host_exeext
+       gcc_cv_ld=./collect-ld$build_exeext
 elif test -f $gcc_cv_ld_gld_srcdir/configure.in \
      && test -f ../ld/Makefile \
      && test x$build = x$host; then
@@ -1876,13 +1878,14 @@ elif test -f $gcc_cv_ld_gld_srcdir/configure.in \
        in_tree_ld=yes
        in_tree_ld_is_elf=no
        if (grep 'EMUL = .*elf' ../ld/Makefile \
-           || grep 'EMUL = .*linux' ../ld/Makefile) > /dev/null; then
+           || grep 'EMUL = .*linux' ../ld/Makefile \
+           || grep 'EMUL = .*lynx' ../ld/Makefile) > /dev/null; then
          in_tree_ld_is_elf=yes
        fi
        for f in $gcc_cv_ld_bfd_srcdir/configure $gcc_cv_ld_gld_srcdir/configure $gcc_cv_ld_gld_srcdir/configure.in $gcc_cv_ld_gld_srcdir/Makefile.in
        do
 changequote(,)dnl
-               gcc_cv_gld_version=`grep '^VERSION=[0-9]*\.[0-9]*' $f`
+               gcc_cv_gld_version=`sed -n -e 's/^[     ]*\(VERSION=[0-9]*\.[0-9]*.*\)/\1/p' < $f`
 changequote([,])dnl
                if test x$gcc_cv_gld_version != x; then
                        break
@@ -1892,9 +1895,8 @@ changequote(,)dnl
        gcc_cv_gld_major_version=`expr "$gcc_cv_gld_version" : "VERSION=\([0-9]*\)"`
        gcc_cv_gld_minor_version=`expr "$gcc_cv_gld_version" : "VERSION=[0-9]*\.\([0-9]*\)"`
 changequote([,])dnl
-       rm -f collect-ld$host_exeext
-       $symbolic_link ../ld/ld-new$host_exeext collect-ld$host_exeext \
-               2>/dev/null
+       rm -f collect-ld$build_exeext
+       $LN_S ../ld/ld-new$build_exeext collect-ld$build_exeext 2>/dev/null
 elif test -x "$LD_FOR_TARGET"; then
         gcc_cv_ld="$LD_FOR_TARGET"
 elif test -x "$LD" && test x$host = x$target; then
@@ -1923,23 +1925,29 @@ if test "x$gcc_cv_ld" = x; then
                test_prefix=$exec_prefix
        fi
 
-       # If the loop below does not find an linker, then use whatever
-       # one we can find in the users's path.
-       # user's path.
+       # If the loop below does not find a linker, then use whatever
+       # one we can find in the users's path.  We are looking for a
+       # ${build} -> ${target} linker.
        if test "x$program_prefix" != xNONE; then
-               gcc_cv_ld=${program_prefix}ld$host_exeext
+               gcc_cv_ld=${program_prefix}ld$build_exeext
+       elif test x$build != x$host && test x$build != x$target; then
+               gcc_cv_ld=${target_noncanonical}-ld$build_exeext
        else
-               gcc_cv_ld=`echo ld | sed "${program_transform_name}"`$host_exeext
+               gcc_cv_ld=`echo ld | sed "${program_transform_name}"`$build_exeext
        fi
 
-       test_dirs="$test_prefix/libexec/gcc/$target_noncanonical/$gcc_version \
-                  $test_prefix/libexec/gcc/$target_noncanonical \
-                  /usr/lib/gcc/$target_noncanonical/$gcc_version \
-                  /usr/lib/gcc/$target_noncanonical \
-                  $test_prefix/$target_noncanonical/bin/$target_noncanonical/$gcc_version \
-                  $test_prefix/$target_noncanonical/bin"
+       if test x$host = x$build; then
+           test_dirs="$test_prefix/libexec/gcc/$target_noncanonical/$gcc_version \
+                      $test_prefix/libexec/gcc/$target_noncanonical \
+                      /usr/lib/gcc/$target_noncanonical/$gcc_version \
+                      /usr/lib/gcc/$target_noncanonical \
+                      $test_prefix/$target_noncanonical/bin/$target_noncanonical/$gcc_version \
+                      $test_prefix/$target_noncanonical/bin"
+       else
+           test_dirs=
+       fi
 
-       if test x$host = x$target; then
+       if test x$build = x$target; then
            test_dirs="$test_dirs \
                   /usr/libexec \
                   /usr/ccs/gcc \
@@ -1954,8 +1962,8 @@ if test "x$gcc_cv_ld" = x; then
        fi
 
        for dir in $test_dirs; do
-               if test -x $dir/ld$host_exeext; then
-                       gcc_cv_ld=$dir/ld$host_exeext
+               if test -x $dir/ld$build_exeext; then
+                       gcc_cv_ld=$dir/ld$build_exeext
                        break;
                fi
        done
@@ -1973,19 +1981,21 @@ esac
 gcc_cv_binutils_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/binutils
 AC_MSG_CHECKING(what nm to use)
 in_tree_nm=no
-if test -x nm$host_exeext; then
-       gcc_cv_nm=./nm$host_exeext
+if test -x nm$build_exeext; then
+       gcc_cv_nm=./nm$build_exeext
 elif test -f $gcc_cv_binutils_srcdir/configure.in \
      && test -f ../binutils/Makefile; then
        # Single tree build which includes binutils.
        in_tree_nm=yes
-       gcc_cv_nm=./nm$host_exeext
-       rm -f nm$host_exeext
-       $symbolic_link ../binutils/nm-new$host_exeext nm$host_exeext 2>/dev/null
+       gcc_cv_nm=./nm$build_exeext
+       rm -f nm$build_exeext
+       $LN_S ../binutils/nm-new$build_exeext nm$build_exeext 2>/dev/null
 elif test "x$program_prefix" != xNONE; then
-       gcc_cv_nm=${program_prefix}nm$host_exeext
+       gcc_cv_nm=${program_prefix}nm$build_exeext
+elif test x$build != x$host && test x$build != x$target; then
+       gcc_cv_nm=${target_noncanonical}-nm$build_exeext
 else
-       gcc_cv_nm=`echo nm | sed "${program_transform_name}"`$host_exeext
+       gcc_cv_nm=`echo nm | sed "${program_transform_name}"`$build_exeext
 fi
 case $in_tree_nm in
   yes) AC_MSG_RESULT("newly built nm") ;;
@@ -1995,21 +2005,22 @@ esac
 # Figure out what objdump we will be using.
 AC_MSG_CHECKING(what objdump to use)
 in_tree_objdump=no
-if test -x objdump$host_exeext; then
-       gcc_cv_objdump=./objdump$host_exeext
+if test -x objdump$build_exeext; then
+       gcc_cv_objdump=./objdump$build_exeext
 elif test -f $gcc_cv_binutils_srcdir/configure.in \
      && test -f ../binutils/Makefile; then
        # Single tree build which includes binutils.
        in_tree_objdump=yes
-       gcc_cv_objdump=./objdump$host_exeext
-       rm -f objdump$host_exeext
-       $symbolic_link ../binutils/objdump$host_exeext \
-               objdump$host_exeext 2>/dev/null
+       gcc_cv_objdump=./objdump$build_exeext
+       rm -f objdump$build_exeext
+       $LN_S ../binutils/objdump$build_exeext objdump$build_exeext 2>/dev/null
 elif test "x$program_prefix" != xNONE; then
-       gcc_cv_objdump=${program_prefix}objdump$host_exeext
+       gcc_cv_objdump=${program_prefix}objdump$build_exeext
+elif test x$build != x$host && test x$build != x$target; then
+       gcc_cv_objdump=${target_noncanonical}-objdump$build_exeext
 else
        gcc_cv_objdump=`echo objdump | \
-               sed "${program_transform_name}"`$host_exeext
+               sed "${program_transform_name}"`$build_exeext
 fi
 case $in_tree_objdump in
   yes) AC_MSG_RESULT("newly built objdump") ;;
@@ -2055,6 +2066,12 @@ gcc_GAS_CHECK_FEATURE([.weak], gcc_cv_as_weak,
  [     .weak foobar],,
 [AC_DEFINE(HAVE_GAS_WEAK, 1, [Define if your assembler supports .weak.])])
 
+gcc_GAS_CHECK_FEATURE([.nsubspa comdat], gcc_cv_as_nsubspa_comdat,
+ [2,15,91],,
+ [     .SPACE $TEXT$
+       .NSUBSPA $CODE$,COMDAT],,
+[AC_DEFINE(HAVE_GAS_NSUBSPA_COMDAT, 1, [Define if your assembler supports .nsubspa comdat option.])])
+
 # .hidden needs to be supported in both the assembler and the linker,
 # because GNU LD versions before 2.12.1 have buggy support for STV_HIDDEN.
 # This is irritatingly difficult to feature test for; we have to check the
@@ -2228,10 +2245,29 @@ fi
 gcc_GAS_CHECK_FEATURE(section merging support, gcc_cv_as_shf_merge,
  [elf,2,12,0], [--fatal-warnings],
  [.section .rodata.str, "aMS", @progbits, 1])
+if test $gcc_cv_as_shf_merge = no; then
+  gcc_GAS_CHECK_FEATURE(section merging support, gcc_cv_as_shf_merge,
+    [elf,2,12,0], [--fatal-warnings],
+    [.section .rodata.str, "aMS", %progbits, 1])
+fi
 AC_DEFINE_UNQUOTED(HAVE_GAS_SHF_MERGE,
   [`if test $gcc_cv_as_shf_merge = yes; then echo 1; else echo 0; fi`],
 [Define 0/1 if your assembler supports marking sections with SHF_MERGE flag.])
 
+gcc_GAS_CHECK_FEATURE(COMDAT group support, gcc_cv_as_comdat_group,
+ [elf,2,15,91], [--fatal-warnings],
+ [.section .text,"axG",@progbits,.foo,comdat])
+if test $gcc_cv_as_comdat_group = yes; then
+  gcc_cv_as_comdat_group_percent=no
+else
+ gcc_GAS_CHECK_FEATURE(COMDAT group support, gcc_cv_as_comdat_group_percent,
+   [elf,2,15,91], [--fatal-warnings],
+   [.section .text,"axG",%progbits,.foo,comdat])
+fi
+AC_DEFINE_UNQUOTED(HAVE_GAS_COMDAT_GROUP,
+  [`if test $gcc_cv_as_comdat_group = yes || test $gcc_cv_as_comdat_group_percent = yes; then echo 1; else echo 0; fi`],
+[Define 0/1 if your assembler supports COMDAT group.])
+
 # Thread-local storage - the check is heavily parametrized.
 conftest_s=
 tls_first_major=
@@ -2262,6 +2298,15 @@ foo:     .long   25
        tls_first_minor=13
        tls_as_opt=--fatal-warnings
        ;;
+  frv*-*-*)
+    conftest_s='
+       .section ".tdata","awT",@progbits
+x:      .long   25
+        .text
+        call    #gettlsoff(x)'
+       tls_first_major=2
+       tls_first_minor=14
+       ;;
   i[34567]86-*-*)
     conftest_s='
        .section ".tdata","awT",@progbits
@@ -2315,6 +2360,23 @@ foo:     data8   25
        tls_first_minor=13
        tls_as_opt=--fatal-warnings
        ;;
+  mips*-*-*)
+    conftest_s='
+       .section .tdata,"awT",@progbits
+x:
+       .word 2
+       .text
+       addiu $4, $28, %tlsgd(x)
+       addiu $4, $28, %tlsldm(x)
+       lui $4, %dtprel_hi(x)
+       addiu $4, $4, %dtprel_lo(x)
+       lw $4, %gottprel(x)($28)
+       lui $4, %tprel_hi(x)
+       addiu $4, $4, %tprel_lo(x)'
+       tls_first_major=2
+       tls_first_minor=16
+       tls_as_opt='-32 --fatal-warnings'
+       ;;
   powerpc-*-*)
     conftest_s='
        .section ".tdata","awT",@progbits
@@ -2501,6 +2563,25 @@ fi
 
 # Target-specific assembler checks.
 
+AC_MSG_CHECKING(linker -Bstatic/-Bdynamic option)
+gcc_cv_ld_static_dynamic=no
+if test $in_tree_ld = yes ; then
+  if test "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -ge 10; then
+    gcc_cv_ld_static_dynamic=yes
+  fi
+elif test x$gcc_cv_ld != x; then
+       # Check if linker supports -Bstatic/-Bdynamic option
+       if $gcc_cv_ld --help 2>/dev/null | grep -- -Bstatic > /dev/null \
+         && $gcc_cv_ld --help 2>/dev/null | grep -- -Bdynamic > /dev/null; then
+               gcc_cv_ld_static_dynamic=yes
+       fi
+fi
+if test x"$gcc_cv_ld_static_dynamic" = xyes; then
+       AC_DEFINE(HAVE_LD_STATIC_DYNAMIC, 1,
+[Define if your linker supports -Bstatic/-Bdynamic option.])
+fi
+AC_MSG_RESULT($gcc_cv_ld_static_dynamic)
+
 if test x"$demangler_in_ld" = xyes; then
   AC_MSG_CHECKING(linker --demangle support)
   gcc_cv_ld_demangle=no
@@ -2617,7 +2698,7 @@ foo:
       [if test x$gcc_cv_objdump != x \
        && $gcc_cv_objdump -s -j .text conftest.o 2> /dev/null \
           | grep ' 82106000 82106000' > /dev/null 2>&1; then
-        gcc_cv_as_offsetable_lo10=yes
+        gcc_cv_as_sparc_offsetable_lo10=yes
        fi],
        [AC_DEFINE(HAVE_AS_OFFSETABLE_LO10, 1,
                 [Define if your assembler supports offsetable %lo().])])
@@ -2688,9 +2769,19 @@ foo:     nop
     case $target in
       *-*-aix*) conftest_s='   .csect .text[[PR]]
        mfcr 3,128';;
-      *-*-darwin*) conftest_s='        .text
+      *-*-darwin*)
+       gcc_GAS_CHECK_FEATURE([.machine directive support],
+         gcc_cv_as_machine_directive,,,
+         [     .machine ppc7400])
+       if test x$gcc_cv_as_machine_directive != xyes; then
+         echo "*** This target requires an assembler supporting \".machine\"" >&2
+         echo you can get it from: ftp://gcc.gnu.org/pub/gcc/infrastructure/cctools-528.5.dmg >&2
+         test x$build = x$target && exit 1
+       fi
+       conftest_s='    .text
        mfcr r3,128';;
-      *)       conftest_s='    .text
+      *) conftest_s='  .machine power4
+       .text
        mfcr 3,128';;
     esac
 
@@ -2748,8 +2839,9 @@ if test x"$insn" != x; then
  gcc_GAS_CHECK_FEATURE([dwarf2 debug_line support],
   gcc_cv_as_dwarf2_debug_line,
   [elf,2,11,0],, [$conftest_s],
-  [# ??? This fails with non-gnu grep.  Maybe use objdump?
-   if grep debug_line conftest.o > /dev/null 2>&1; then
+  [if test x$gcc_cv_objdump != x \
+   && $gcc_cv_objdump -h conftest.o 2> /dev/null \
+      | grep debug_line > /dev/null 2>&1; then
      gcc_cv_as_dwarf2_debug_line=yes
    fi])
 
@@ -2942,8 +3034,12 @@ AC_ARG_WITH(gc,
 [  --with-gc={page,zone}   choose the garbage collection mechanism to use
                           with the compiler],
 [case "$withval" in
-  page | zone)
+  page)
+    GGC=ggc-$withval
+    ;;
+  zone)
     GGC=ggc-$withval
+    AC_DEFINE(GGC_ZONE, 1, [Define if the zone collector is in use])
     ;;
   *)
     AC_MSG_ERROR([$withval is an invalid option to --with-gc])
@@ -2984,28 +3080,6 @@ else
 fi
 AC_SUBST(MAINT)dnl
 
-AC_MSG_CHECKING([whether to use libbanshee for points-to alias analysis])
-AC_ARG_WITH(libbanshee,
-[  --with-libbanshee     enable libbanshee],
-libbanshee="$with_libbanshee",
-libbanshee=no)
-
-if test x"$libbanshee" = xyes; then
-       BANSHEELIB="../libbanshee/points-to/libandersen.a ../libbanshee/engine/libbansheeengine.a ../libbanshee/libcompat/libbansheecompat.a "
-       BANSHEEINC="-I\$(srcdir)/../libbanshee/libcompat -I\$(srcdir)/../libbanshee -I\$(srcdir)/../libbanshee/points-to"
-       ANDER="tree-alias-ander.o"
-       AC_DEFINE(HAVE_BANSHEE, 1, [Define if BANSHEE is available])
-else
-       BANSHEELIB=""
-       BANSHEEINC=""
-       ANDER=""
-fi
-AC_MSG_RESULT($with_libbanshee)
-
-AC_SUBST(ANDER)
-AC_SUBST(BANSHEEINC)
-AC_SUBST(BANSHEELIB)
-
 # --------------
 # Language hooks
 # --------------
@@ -3035,7 +3109,7 @@ all_languages=
 all_boot_languages=
 all_compilers=
 all_stagestuff=
-all_outputs='Makefile fixinc/Makefile gccbug mklibgcc mkheaders libada-mk'
+all_outputs='Makefile gccbug mklibgcc libada-mk'
 # List of language makefile fragments.
 all_lang_makefrags=
 # List of language subdirectory makefiles.  Deprecated.
@@ -3240,9 +3314,6 @@ AC_SUBST(float_h_file)
 AC_SUBST(gcc_config_arguments)
 AC_SUBST(gcc_gxx_include_dir)
 AC_SUBST(libstdcxx_incdir)
-AC_SUBST(gcc_version)
-AC_SUBST(gcc_version_full)
-AC_SUBST(gcc_version_trigger)
 AC_SUBST(host_exeext)
 AC_SUBST(host_xm_file_list)
 AC_SUBST(host_xm_include_list)
@@ -3259,7 +3330,6 @@ AC_SUBST(out_file)
 AC_SUBST(out_object_file)
 AC_SUBST(stage_prefix_set_by_configure)
 AC_SUBST(quoted_stage_prefix_set_by_configure)
-AC_SUBST(symbolic_link)
 AC_SUBST(thread_file)
 AC_SUBST(tm_file_list)
 AC_SUBST(tm_include_list)
@@ -3275,13 +3345,7 @@ AC_SUBST(target_cpu_default)
 
 AC_SUBST_FILE(language_hooks)
 
-# If it doesn't already exist, create document directory
-echo "checking for the document directory." 1>&2
-if test -d doc ; then
-  true
-else
-  mkdir doc 
-fi
+TL_AC_GNU_MAKE_GCC_LIB_PATH
 
 # Echo link setup.
 if test x${build} = x${host} ; then
@@ -3318,7 +3382,7 @@ case ${CONFIG_HEADERS} in
   echo > cstamp-h ;;
 esac
 # Make sure all the subdirs exist.
-for d in $subdirs
+for d in $subdirs doc build
 do
     test -d $d || mkdir $d
 done
@@ -3328,20 +3392,20 @@ done
 # FLAGS_TO_PASS has been modified to solve the problem there.
 # This is virtually a duplicate of what happens in configure.lang; we do
 # an extra check to make sure this only happens if ln -s can be used.
-if test "$symbolic_link" = "ln -s"; then
- for d in ${subdirs} fixinc ; do
+case "$LN_S" in
+  *-s*)
+    for d in ${subdirs} ; do
        STARTDIR=`${PWDCMD-pwd}`
        cd $d
        for t in stage1 stage2 stage3 stage4 stageprofile stagefeedback include
        do
                rm -f $t
-               $symbolic_link ../$t $t 2>/dev/null
+               $LN_S ../$t $t 2>/dev/null
        done
        cd $STARTDIR
- done
-else true ; fi
+    done
+  ;;
+esac
 ], 
-[subdirs='$subdirs'
-symbolic_link='$symbolic_link'
-])
+[subdirs='$subdirs'])
 AC_OUTPUT