OSDN Git Service

* config.gcc (extra_options): New variable for listing option files.
[pf3gnuchains/gcc-fork.git] / gcc / configure.ac
index 739d959..dedb800 100644 (file)
@@ -100,6 +100,8 @@ AC_MSG_ERROR([
 *** and run configure again.])
 fi
 
+TL_AC_GCC_VERSION([$srcdir/..])
+
 # -----------
 # Directories
 # -----------
@@ -137,7 +139,7 @@ if test x${gcc_gxx_include_dir} = x; then
   if test x${enable_version_specific_runtime_libs} = xyes; then
     gcc_gxx_include_dir='${libsubdir}/include/c++'
   else
-    topsrcdir=${srcdir}/.. . ${srcdir}/../config.if
+    libstdcxx_incdir=c++/${gcc_version}
 changequote(<<, >>)dnl
     gcc_gxx_include_dir="\$(libsubdir)/\$(unlibsubdir)/..\`echo \$(exec_prefix) | sed -e 's|^\$(prefix)||' -e 's|/[^/]*|/..|g'\`/include/"${libstdcxx_incdir}
 changequote([, ])dnl
@@ -1024,6 +1026,8 @@ AC_SUBST(LIBICONV_DEP)
 
 AM_LC_MESSAGES
 
+AM_LANGINFO_CODESET
+
 # We will need to find libiberty.h and ansidecl.h
 saved_CFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS -I${srcdir} -I${srcdir}/../include"
@@ -1051,10 +1055,16 @@ AC_TRY_COMPILE([
 ],[rlim_t l = 0;],,[AC_DEFINE([rlim_t],[long],
 [Define to \`long' if <sys/resource.h> doesn't define.])])
 
+# On AIX 5.2, <ldfcn.h> conflicts with <fcntl.h>, as both define incompatible
+# FREAD and FWRITE macros.  Fortunately, for GCC's single usage of ldgetname
+# in collect2.c, <fcntl.h> isn't visible, but the configure test below needs
+# to undef these macros to get the correct value for HAVE_DECL_LDGETNAME.
 gcc_AC_CHECK_DECLS(ldgetname, , ,[
 #include "ansidecl.h"
 #include "system.h"
 #ifdef HAVE_LDFCN_H
+#undef FREAD
+#undef FWRITE
 #include <ldfcn.h>
 #endif
 ])
@@ -1264,7 +1274,7 @@ case ${enable_threads} in
     # default
     target_thread_file='single'
     ;;
-  aix | dce | gnat | irix | posix | rtems | \
+  aix | dce | gnat | irix | posix | posix95 | rtems | \
   single | solaris | vxworks | win32 )
     target_thread_file=${enable_threads}
     ;;
@@ -1293,15 +1303,24 @@ AC_SUBST(gthread_flags)
 # UNSORTED
 # --------
 
+use_cxa_atexit=no
 if test x$enable___cxa_atexit = xyes || \
    test x$enable___cxa_atexit = x -a x$default_use_cxa_atexit = xyes; then
-   AC_CHECK_FUNC(__cxa_atexit,
-       [AC_DEFINE(DEFAULT_USE_CXA_ATEXIT, 1,
-       [Define if you want to use __cxa_atexit, rather than atexit, to
-       register C++ destructors for local statics and global objects.
-       This is essential for fully standards-compliant handling of
-       destructors, but requires __cxa_atexit in libc.])],
-       echo "__cxa_atexit can't be enabled on this target")
+  if test x$host = x$target; then
+    AC_CHECK_FUNC(__cxa_atexit,[use_cxa_atexit=yes],
+       [echo "__cxa_atexit can't be enabled on this target"])
+  else
+    # We can't check for __cxa_atexit when building a cross, so assume
+    # it is available 
+    use_cxa_atexit=yes
+  fi
+  if test x$use_cxa_atexit = xyes; then
+    AC_DEFINE(DEFAULT_USE_CXA_ATEXIT, 1,
+      [Define if you want to use __cxa_atexit, rather than atexit, to
+      register C++ destructors for local statics and global objects.
+      This is essential for fully standards-compliant handling of
+      destructors, but requires __cxa_atexit in libc.])
+  fi
 fi
 
 # Look for a file containing extra machine modes.
@@ -1313,6 +1332,13 @@ if test -n "$extra_modes" && test -f $srcdir/config/$extra_modes; then
    for this architecture.])
 fi
 
+# Convert extra_options into a form suitable for Makefile use.
+extra_opt_files=
+for f in $extra_options; do
+  extra_opt_files="$extra_opt_files \$(srcdir)/config/$f"
+done
+AC_SUBST(extra_opt_files)
+
 # auto-host.h is the file containing items generated by autoconf and is
 # the first file included by config.h.
 # If host=build, it is correct to have bconfig include auto-host.h
@@ -1362,16 +1388,7 @@ xm_file="ansidecl.h ${xm_file}"
 # UNSORTED
 # --------
 
-# Get the version trigger filename from the toplevel
-if test "${with_gcc_version_trigger+set}" = set; then
-       gcc_version_trigger=$with_gcc_version_trigger
-else
-       gcc_version_trigger=${srcdir}/version.c
-fi
 changequote(,)dnl
-gcc_version_full=`grep version_string ${gcc_version_trigger} | sed -e 's/.*"\([^"]*\)".*/\1/'`
-gcc_version=`echo ${gcc_version_full} | sed -e 's/\([^ ]*\) .*/\1/'`
-
 # Compile in configure arguments.
 if test -f configargs.h ; then
        # Being re-configured.
@@ -1509,10 +1526,14 @@ case "$LN_S" in
                ;;
 esac
 
+# This is a terrible hack which will go away some day.
+host_cc_for_libada=${CC}
+AC_SUBST(host_cc_for_libada)
+
 out_object_file=`basename $out_file .c`.o
 
-tm_file_list=
-tm_include_list=
+tm_file_list="options.h"
+tm_include_list="options.h"
 for f in $tm_file; do
   case $f in
     defaults.h )
@@ -1673,18 +1694,12 @@ then
     BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
 
     if test "x$TARGET_SYSTEM_ROOT" = x; then
-       STMP_FIXINC=
-       STMP_FIXPROTO=
+       if [ "x$STMP_FIXPROTO" != x ] ; then
+         STMP_FIXPROTO=stmp-install-fixproto
+       fi
     fi
 fi
 
-# When bootstrapping from the toplevel, only run fixincludes during stage1
-if test -d ../prev-gcc
-then
-    STMP_FIXINC=
-    cp -R ../prev-gcc/include include
-fi
-
 # Expand extra_headers to include complete path.
 # This substitutes for lots of t-* files.
 extra_headers_list=
@@ -1734,9 +1749,9 @@ gcc_cv_gas_minor_version=
 gcc_cv_as_gas_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/gas
 if test -x "$DEFAULT_ASSEMBLER"; then
        gcc_cv_as="$DEFAULT_ASSEMBLER"
-elif test -x as$host_exeext; then
+elif test -x as$build_exeext; then
        # Build using assembler in the current directory.
-       gcc_cv_as=./as$host_exeext
+       gcc_cv_as=./as$build_exeext
 elif test -f $gcc_cv_as_gas_srcdir/configure.in \
      && test -f ../gas/Makefile \
      && test x$build = x$host; then
@@ -1745,8 +1760,8 @@ elif test -f $gcc_cv_as_gas_srcdir/configure.in \
   # we'll use what we're building after installation anyway.
   in_tree_gas=yes
   _gcc_COMPUTE_GAS_VERSION
-  rm -f as$host_exeext
-  $LN_S ../gas/as-new$host_exeext as$host_exeext 2>/dev/null
+  rm -f as$build_exeext
+  $LN_S ../gas/as-new$build_exeext as$build_exeext 2>/dev/null
   in_tree_gas_is_elf=no
   if grep 'obj_format = elf' ../gas/Makefile > /dev/null \
      || (grep 'obj_format = multi' ../gas/Makefile \
@@ -1784,12 +1799,14 @@ if test "x$gcc_cv_as" = x; then
        fi
 
        # If the loop below does not find an assembler, then use whatever
-       # one we can find in the users's path.
-       # user's path.
+       # one we can find in the users's path.  We are looking for a
+       # ${build} -> ${target} assembler.
        if test "x$program_prefix" != xNONE; then
-               gcc_cv_as=${program_prefix}as$host_exeext
+               gcc_cv_as=${program_prefix}as$build_exeext
+       elif test x$build != x$host && test x$build != x$target; then
+               gcc_cv_as=${target_noncanonical}-as$build_exeext
        else
-               gcc_cv_as=`echo as | sed "${program_transform_name}"`$host_exeext
+               gcc_cv_as=`echo as | sed "${program_transform_name}"`$build_exeext
        fi
 
        if test x$host = x$build; then
@@ -1803,7 +1820,7 @@ if test "x$gcc_cv_as" = x; then
            test_dirs=
        fi
 
-       if test x$host = x$target; then
+       if test x$build = x$target; then
            test_dirs="$test_dirs \
                   /usr/libexec \
                   /usr/ccs/gcc \
@@ -1818,8 +1835,8 @@ if test "x$gcc_cv_as" = x; then
        fi
 
        for dir in $test_dirs; do
-               if test -x $dir/as$host_exeext; then
-                       gcc_cv_as=$dir/as$host_exeext
+               if test -x $dir/as$build_exeext; then
+                       gcc_cv_as=$dir/as$build_exeext
                        break;
                fi
        done
@@ -1849,9 +1866,9 @@ gcc_cv_ld_gld_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/ld
 gcc_cv_ld_bfd_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/bfd
 if test -x "$DEFAULT_LINKER"; then
        gcc_cv_ld="$DEFAULT_LINKER"
-elif test -x collect-ld$host_exeext; then
+elif test -x collect-ld$build_exeext; then
        # Build using linker in the current directory.
-       gcc_cv_ld=./collect-ld$host_exeext
+       gcc_cv_ld=./collect-ld$build_exeext
 elif test -f $gcc_cv_ld_gld_srcdir/configure.in \
      && test -f ../ld/Makefile \
      && test x$build = x$host; then
@@ -1878,8 +1895,8 @@ changequote(,)dnl
        gcc_cv_gld_major_version=`expr "$gcc_cv_gld_version" : "VERSION=\([0-9]*\)"`
        gcc_cv_gld_minor_version=`expr "$gcc_cv_gld_version" : "VERSION=[0-9]*\.\([0-9]*\)"`
 changequote([,])dnl
-       rm -f collect-ld$host_exeext
-       $LN_S ../ld/ld-new$host_exeext collect-ld$host_exeext 2>/dev/null
+       rm -f collect-ld$build_exeext
+       $LN_S ../ld/ld-new$build_exeext collect-ld$build_exeext 2>/dev/null
 elif test -x "$LD_FOR_TARGET"; then
         gcc_cv_ld="$LD_FOR_TARGET"
 elif test -x "$LD" && test x$host = x$target; then
@@ -1908,13 +1925,15 @@ if test "x$gcc_cv_ld" = x; then
                test_prefix=$exec_prefix
        fi
 
-       # If the loop below does not find an linker, then use whatever
-       # one we can find in the users's path.
-       # user's path.
+       # If the loop below does not find a linker, then use whatever
+       # one we can find in the users's path.  We are looking for a
+       # ${build} -> ${target} linker.
        if test "x$program_prefix" != xNONE; then
-               gcc_cv_ld=${program_prefix}ld$host_exeext
+               gcc_cv_ld=${program_prefix}ld$build_exeext
+       elif test x$build != x$host && test x$build != x$target; then
+               gcc_cv_ld=${target_noncanonical}-ld$build_exeext
        else
-               gcc_cv_ld=`echo ld | sed "${program_transform_name}"`$host_exeext
+               gcc_cv_ld=`echo ld | sed "${program_transform_name}"`$build_exeext
        fi
 
        if test x$host = x$build; then
@@ -1928,7 +1947,7 @@ if test "x$gcc_cv_ld" = x; then
            test_dirs=
        fi
 
-       if test x$host = x$target; then
+       if test x$build = x$target; then
            test_dirs="$test_dirs \
                   /usr/libexec \
                   /usr/ccs/gcc \
@@ -1943,8 +1962,8 @@ if test "x$gcc_cv_ld" = x; then
        fi
 
        for dir in $test_dirs; do
-               if test -x $dir/ld$host_exeext; then
-                       gcc_cv_ld=$dir/ld$host_exeext
+               if test -x $dir/ld$build_exeext; then
+                       gcc_cv_ld=$dir/ld$build_exeext
                        break;
                fi
        done
@@ -1962,19 +1981,21 @@ esac
 gcc_cv_binutils_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/binutils
 AC_MSG_CHECKING(what nm to use)
 in_tree_nm=no
-if test -x nm$host_exeext; then
-       gcc_cv_nm=./nm$host_exeext
+if test -x nm$build_exeext; then
+       gcc_cv_nm=./nm$build_exeext
 elif test -f $gcc_cv_binutils_srcdir/configure.in \
      && test -f ../binutils/Makefile; then
        # Single tree build which includes binutils.
        in_tree_nm=yes
-       gcc_cv_nm=./nm$host_exeext
-       rm -f nm$host_exeext
-       $LN_S ../binutils/nm-new$host_exeext nm$host_exeext 2>/dev/null
+       gcc_cv_nm=./nm$build_exeext
+       rm -f nm$build_exeext
+       $LN_S ../binutils/nm-new$build_exeext nm$build_exeext 2>/dev/null
 elif test "x$program_prefix" != xNONE; then
-       gcc_cv_nm=${program_prefix}nm$host_exeext
+       gcc_cv_nm=${program_prefix}nm$build_exeext
+elif test x$build != x$host && test x$build != x$target; then
+       gcc_cv_nm=${target_noncanonical}-nm$build_exeext
 else
-       gcc_cv_nm=`echo nm | sed "${program_transform_name}"`$host_exeext
+       gcc_cv_nm=`echo nm | sed "${program_transform_name}"`$build_exeext
 fi
 case $in_tree_nm in
   yes) AC_MSG_RESULT("newly built nm") ;;
@@ -1984,20 +2005,22 @@ esac
 # Figure out what objdump we will be using.
 AC_MSG_CHECKING(what objdump to use)
 in_tree_objdump=no
-if test -x objdump$host_exeext; then
-       gcc_cv_objdump=./objdump$host_exeext
+if test -x objdump$build_exeext; then
+       gcc_cv_objdump=./objdump$build_exeext
 elif test -f $gcc_cv_binutils_srcdir/configure.in \
      && test -f ../binutils/Makefile; then
        # Single tree build which includes binutils.
        in_tree_objdump=yes
-       gcc_cv_objdump=./objdump$host_exeext
-       rm -f objdump$host_exeext
-       $LN_S ../binutils/objdump$host_exeext objdump$host_exeext 2>/dev/null
+       gcc_cv_objdump=./objdump$build_exeext
+       rm -f objdump$build_exeext
+       $LN_S ../binutils/objdump$build_exeext objdump$build_exeext 2>/dev/null
 elif test "x$program_prefix" != xNONE; then
-       gcc_cv_objdump=${program_prefix}objdump$host_exeext
+       gcc_cv_objdump=${program_prefix}objdump$build_exeext
+elif test x$build != x$host && test x$build != x$target; then
+       gcc_cv_objdump=${target_noncanonical}-objdump$build_exeext
 else
        gcc_cv_objdump=`echo objdump | \
-               sed "${program_transform_name}"`$host_exeext
+               sed "${program_transform_name}"`$build_exeext
 fi
 case $in_tree_objdump in
   yes) AC_MSG_RESULT("newly built objdump") ;;
@@ -2043,6 +2066,12 @@ gcc_GAS_CHECK_FEATURE([.weak], gcc_cv_as_weak,
  [     .weak foobar],,
 [AC_DEFINE(HAVE_GAS_WEAK, 1, [Define if your assembler supports .weak.])])
 
+gcc_GAS_CHECK_FEATURE([.nsubspa comdat], gcc_cv_as_nsubspa_comdat,
+ [2,15,91],,
+ [     .SPACE $TEXT$
+       .NSUBSPA $CODE$,COMDAT],,
+[AC_DEFINE(HAVE_GAS_NSUBSPA_COMDAT, 1, [Define if your assembler supports .nsubspa comdat option.])])
+
 # .hidden needs to be supported in both the assembler and the linker,
 # because GNU LD versions before 2.12.1 have buggy support for STV_HIDDEN.
 # This is irritatingly difficult to feature test for; we have to check the
@@ -2269,6 +2298,15 @@ foo:     .long   25
        tls_first_minor=13
        tls_as_opt=--fatal-warnings
        ;;
+  frv*-*-*)
+    conftest_s='
+       .section ".tdata","awT",@progbits
+x:      .long   25
+        .text
+        call    #gettlsoff(x)'
+       tls_first_major=2
+       tls_first_minor=14
+       ;;
   i[34567]86-*-*)
     conftest_s='
        .section ".tdata","awT",@progbits
@@ -2322,6 +2360,23 @@ foo:     data8   25
        tls_first_minor=13
        tls_as_opt=--fatal-warnings
        ;;
+  mips*-*-*)
+    conftest_s='
+       .section .tdata,"awT",@progbits
+x:
+       .word 2
+       .text
+       addiu $4, $28, %tlsgd(x)
+       addiu $4, $28, %tlsldm(x)
+       lui $4, %dtprel_hi(x)
+       addiu $4, $4, %dtprel_lo(x)
+       lw $4, %gottprel(x)($28)
+       lui $4, %tprel_hi(x)
+       addiu $4, $4, %tprel_lo(x)'
+       tls_first_major=2
+       tls_first_minor=16
+       tls_as_opt='-32 --fatal-warnings'
+       ;;
   powerpc-*-*)
     conftest_s='
        .section ".tdata","awT",@progbits
@@ -2508,6 +2563,25 @@ fi
 
 # Target-specific assembler checks.
 
+AC_MSG_CHECKING(linker -Bstatic/-Bdynamic option)
+gcc_cv_ld_static_dynamic=no
+if test $in_tree_ld = yes ; then
+  if test "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -ge 10; then
+    gcc_cv_ld_static_dynamic=yes
+  fi
+elif test x$gcc_cv_ld != x; then
+       # Check if linker supports -Bstatic/-Bdynamic option
+       if $gcc_cv_ld --help 2>/dev/null | grep -- -Bstatic > /dev/null \
+         && $gcc_cv_ld --help 2>/dev/null | grep -- -Bdynamic > /dev/null; then
+               gcc_cv_ld_static_dynamic=yes
+       fi
+fi
+if test x"$gcc_cv_ld_static_dynamic" = xyes; then
+       AC_DEFINE(HAVE_LD_STATIC_DYNAMIC, 1,
+[Define if your linker supports -Bstatic/-Bdynamic option.])
+fi
+AC_MSG_RESULT($gcc_cv_ld_static_dynamic)
+
 if test x"$demangler_in_ld" = xyes; then
   AC_MSG_CHECKING(linker --demangle support)
   gcc_cv_ld_demangle=no
@@ -2624,7 +2698,7 @@ foo:
       [if test x$gcc_cv_objdump != x \
        && $gcc_cv_objdump -s -j .text conftest.o 2> /dev/null \
           | grep ' 82106000 82106000' > /dev/null 2>&1; then
-        gcc_cv_as_offsetable_lo10=yes
+        gcc_cv_as_sparc_offsetable_lo10=yes
        fi],
        [AC_DEFINE(HAVE_AS_OFFSETABLE_LO10, 1,
                 [Define if your assembler supports offsetable %lo().])])
@@ -2695,9 +2769,19 @@ foo:     nop
     case $target in
       *-*-aix*) conftest_s='   .csect .text[[PR]]
        mfcr 3,128';;
-      *-*-darwin*) conftest_s='        .text
+      *-*-darwin*)
+       gcc_GAS_CHECK_FEATURE([.machine directive support],
+         gcc_cv_as_machine_directive,,,
+         [     .machine ppc7400])
+       if test x$gcc_cv_as_machine_directive != xyes; then
+         echo "*** This target requires an assembler supporting \".machine\"" >&2
+         echo you can get it from: ftp://gcc.gnu.org/pub/gcc/infrastructure/cctools-528.5.dmg >&2
+         test x$build = x$target && exit 1
+       fi
+       conftest_s='    .text
        mfcr r3,128';;
-      *)       conftest_s='    .text
+      *) conftest_s='  .machine power4
+       .text
        mfcr 3,128';;
     esac
 
@@ -2755,8 +2839,9 @@ if test x"$insn" != x; then
  gcc_GAS_CHECK_FEATURE([dwarf2 debug_line support],
   gcc_cv_as_dwarf2_debug_line,
   [elf,2,11,0],, [$conftest_s],
-  [# ??? This fails with non-gnu grep.  Maybe use objdump?
-   if grep debug_line conftest.o > /dev/null 2>&1; then
+  [if test x$gcc_cv_objdump != x \
+   && $gcc_cv_objdump -h conftest.o 2> /dev/null \
+      | grep debug_line > /dev/null 2>&1; then
      gcc_cv_as_dwarf2_debug_line=yes
    fi])
 
@@ -2949,8 +3034,12 @@ AC_ARG_WITH(gc,
 [  --with-gc={page,zone}   choose the garbage collection mechanism to use
                           with the compiler],
 [case "$withval" in
-  page | zone)
+  page)
+    GGC=ggc-$withval
+    ;;
+  zone)
     GGC=ggc-$withval
+    AC_DEFINE(GGC_ZONE, 1, [Define if the zone collector is in use])
     ;;
   *)
     AC_MSG_ERROR([$withval is an invalid option to --with-gc])
@@ -3020,7 +3109,7 @@ all_languages=
 all_boot_languages=
 all_compilers=
 all_stagestuff=
-all_outputs='Makefile gccbug mklibgcc mkheaders libada-mk'
+all_outputs='Makefile gccbug mklibgcc libada-mk'
 # List of language makefile fragments.
 all_lang_makefrags=
 # List of language subdirectory makefiles.  Deprecated.
@@ -3225,9 +3314,6 @@ AC_SUBST(float_h_file)
 AC_SUBST(gcc_config_arguments)
 AC_SUBST(gcc_gxx_include_dir)
 AC_SUBST(libstdcxx_incdir)
-AC_SUBST(gcc_version)
-AC_SUBST(gcc_version_full)
-AC_SUBST(gcc_version_trigger)
 AC_SUBST(host_exeext)
 AC_SUBST(host_xm_file_list)
 AC_SUBST(host_xm_include_list)