OSDN Git Service

PR boehm-gc/21940
[pf3gnuchains/gcc-fork.git] / boehm-gc / configure.ac
index 5c26b84..29331e6 100644 (file)
@@ -173,8 +173,12 @@ case "$THREADS" in
        THREADLIBS=-pthread
        ;;
      *-*-solaris*)
-       AC_DEFINE(GC_SOLARIS_THREADS,1,[support for Solaris (thr_) threads])
        AC_DEFINE(GC_SOLARIS_PTHREADS,1,[support for Solaris pthreads])
+       # Need to use alternate thread library, otherwise gctest hangs
+       # on Solaris 8.
+       multi_os_directory=`$CC -print-multi-os-directory`
+       THREADLIBS="-L/usr/lib/lwp/$multi_os_directory \
+                   -R/usr/lib/lwp/$multi_os_directory -lpthread -lthread -lrt"
        ;;
      *-*-irix*)
        AC_DEFINE(GC_IRIX_THREADS,1,[support for Irix pthreads])