OSDN Git Service

* genattrtab.c (write_insn_cases): New function, split out from
[pf3gnuchains/gcc-fork.git] / libbanshee / points-to / andersen_terms_st.spec
1 % Copyright (c) 2000-2001
2 %      The Regents of the University of California.  All rights reserved.
3 %
4 % Redistribution and use in source and binary forms, with or without
5 % modification, are permitted provided that the following conditions
6 % are met:
7 % 1. Redistributions of source code must retain the above copyright
8 %    notice, this list of conditions and the following disclaimer.
9 % 2. Redistributions in binary form must reproduce the above copyright
10 %    notice, this list of conditions and the following disclaimer in the
11 %    documentation and/or other materials provided with the distribution.
12 % 3. Neither the name of the University nor the names of its contributors
13 %    may be used to endorse or promote products derived from this software
14 %    without specific prior written permission.
15 %
16 % THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
17 % ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
18 % IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
19 % ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
20 % FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
21 % DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
22 % OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 % HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
24 % LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
25 % OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
26 % SUCH DAMAGE.
27
28 specification andersen_terms : ANDERSEN_TERMS =
29   spec
30     data label_term : setST
31     data aterm : setST = ref of +label_term * -aterm * +aterm
32                    | lam of +label_term * -argterm * +aterm
33      and argterm : row(aterm)
34   end