OSDN Git Service

Delete auto-detection for MySQL server version.
authorsakamocchi <sakamocchi@1ca29b6e-896d-4ea0-84a5-967f57386b96>
Thu, 13 Jan 2011 06:00:59 +0000 (06:00 +0000)
committersakamocchi <sakamocchi@1ca29b6e-896d-4ea0-84a5-967f57386b96>
Thu, 13 Jan 2011 06:00:59 +0000 (06:00 +0000)
git-svn-id: https://svn.sourceforge.jp/svnroot/nucleus-jp/nucleus-jp/trunk@1086 1ca29b6e-896d-4ea0-84a5-967f57386b96

utf8/install/index.php

index 810c121..4352010 100755 (executable)
@@ -173,16 +173,14 @@ function showInstallForm() {
        } elseif (phpversion() < '5') {\r
                echo ' <span class="warning" style="display:block">' . _TEXT2_WARN3 . '</span>';\r
        }\r
        } elseif (phpversion() < '5') {\r
                echo ' <span class="warning" style="display:block">' . _TEXT2_WARN3 . '</span>';\r
        }\r
-?>\r
-\r
-                       </li>\r
-                       <li>MySQL:\r
-\r
-<?php\r
+       \r
+       echo "</li>\n";\r
+       /*\r
        // note: this piece of code is taken from phpMyAdmin\r
        // note: this piece of code is taken from phpMyAdmin\r
+       echo "<li>MySQL\n";\r
        $conn   = sql_connect_args('localhost','','');\r
        $result = @sql_query('SELECT VERSION() AS version', $conn);\r
        $conn   = sql_connect_args('localhost','','');\r
        $result = @sql_query('SELECT VERSION() AS version', $conn);\r
-\r
+       \r
        if ($result != FALSE && sql_num_rows($result) > 0) {\r
                $row   = sql_fetch_array($result);\r
                $match = explode('.', $row['version']);\r
        if ($result != FALSE && sql_num_rows($result) > 0) {\r
                $row   = sql_fetch_array($result);\r
                $match = explode('.', $row['version']);\r
@@ -204,27 +202,22 @@ function showInstallForm() {
                        }\r
                }\r
        }\r
                        }\r
                }\r
        }\r
-\r
        sql_disconnect($conn);\r
        $mysqlVersion = implode($match, '.');\r
        $minVersion   = '3.23';\r
        sql_disconnect($conn);\r
        $mysqlVersion = implode($match, '.');\r
        $minVersion   = '3.23';\r
-\r
        if ($mysqlVersion == '0.0.0') {\r
                echo _NOTIFICATION1;\r
        }\r
        else {\r
                echo $mysqlVersion;\r
        }\r
        if ($mysqlVersion == '0.0.0') {\r
                echo _NOTIFICATION1;\r
        }\r
        else {\r
                echo $mysqlVersion;\r
        }\r
-\r
        if ($mysqlVersion < $minVersion) {\r
                echo ' <span class="warning" style="display:block">' . sprintf(_TEXT2_WARN2, $minVersion) . '</span>';\r
        }\r
        if ($mysqlVersion < $minVersion) {\r
                echo ' <span class="warning" style="display:block">' . sprintf(_TEXT2_WARN2, $minVersion) . '</span>';\r
        }\r
-?>\r
-\r
-                       </li>\r
-               </ul>\r
+       echo "</li>\n";\r
+       */\r
+       echo "</ul>\n";\r
 \r
 \r
-<?php\r
        // tell people how they can have their config file filled out automatically\r
        if (@file_exists('../config.php') && @!is_writable('../config.php')) {\r
 ?>\r
        // tell people how they can have their config file filled out automatically\r
        if (@file_exists('../config.php') && @!is_writable('../config.php')) {\r
 ?>\r