OSDN Git Service

Unsupport PHP4.
authorsakamocchi <sakamocchi@1ca29b6e-896d-4ea0-84a5-967f57386b96>
Mon, 31 Jan 2011 13:52:07 +0000 (13:52 +0000)
committersakamocchi <sakamocchi@1ca29b6e-896d-4ea0-84a5-967f57386b96>
Mon, 31 Jan 2011 13:52:07 +0000 (13:52 +0000)
git-svn-id: https://svn.sourceforge.jp/svnroot/nucleus-jp/nucleus-jp/trunk@1127 1ca29b6e-896d-4ea0-84a5-967f57386b96

utf8/install/index.php
utf8/nucleus/upgrades/index.php

index a72682d..ab5fac3 100755 (executable)
@@ -211,7 +211,7 @@ function showInstallForm() {
                        </li>\r
                </ul>\r
 <?php\r
-       if (phpversion() < '6.0.0') {\r
+       if (phpversion() < '5.0.0') {\r
                echo ' <p class="deprecated">' . _TEXT2_WARN2 . '</p>';\r
 ?>\r
 </form>\r
index 163c629..570d0a9 100755 (executable)
@@ -61,7 +61,7 @@ upgrade_head();
 ?>
 <p class="ok">自動でできるアップグレードはありません。データベースは既に最新の Nucleus 用にアップデートされています。</p>        
 <?php
-       } else if (phpversion() < '5') {
+       } else if (phpversion() < '5.0.0') {
 ?>             
 <p class="deprecated">警告! 動作しているPHPのバージョンが古く、正常な動作を保証できません。アップグレード作業を中止して、PHP5以上が使えないかどうか、サーバ管理者に確認して下さい。</p>
 <?php